gnu: gnutls: Patch bug in 'set-session-server-name!'.

* gnu/packages/patches/gnutls-server-name-fix.patch: New file.
* gnu/packages/gnutls.scm (gnutls)[source]: Use it.
* gnu-system.am (dist_patch_DATA): Add it.
master
Ludovic Courtès 2014-10-14 23:09:07 +02:00
parent 11c38cbe0d
commit 51861587c6
3 changed files with 20 additions and 1 deletions

View File

@ -344,6 +344,7 @@ dist_patch_DATA = \
gnu/packages/patches/glibc-ldd-x86_64.patch \
gnu/packages/patches/gnunet-fix-scheduler.patch \
gnu/packages/patches/gnunet-fix-tests.patch \
gnu/packages/patches/gnutls-server-name-fix.patch \
gnu/packages/patches/gobject-introspection-cc.patch \
gnu/packages/patches/grub-gets-undeclared.patch \
gnu/packages/patches/gstreamer-0.10-bison3.patch \

View File

@ -74,7 +74,8 @@ specifications.")
"/gnutls-" version ".tar.xz"))
(sha256
(base32
"1krx33ab2ijwfz71f1ba8labxfsic7jhlhv6rvjsyw566jj9a3d2"))))
"1krx33ab2ijwfz71f1ba8labxfsic7jhlhv6rvjsyw566jj9a3d2"))
(patches (list (search-patch "gnutls-server-name-fix.patch")))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))

View File

@ -0,0 +1,17 @@
Fix a typo introduced in the first series implementing
'set-session-server-name!' whereby the trailing nul character would
be passed on the wire, thereby breaking connections.
diff --git a/guile/src/core.c b/guile/src/core.c
index 82fd573..2778205 100644
--- a/guile/src/core.c
+++ b/guile/src/core.c
@@ -719,7 +719,7 @@ SCM_DEFINE (scm_gnutls_set_session_server_name_x, "set-session-server-name!",
c_name = scm_to_locale_string (name);
err = gnutls_server_name_set (c_session, c_type, c_name,
- strlen (c_name) + 1);
+ strlen (c_name));
free (c_name);
if (EXPECT_FALSE (err != GNUTLS_E_SUCCESS))