gnu: util-linux: Update to 2.33.1.

* gnu/packages/linux.scm (util-linux): Update to 2.33.1.
* gnu/packages/patches/util-linux-tests.patch: Skip one new test.
master
Marius Bakke 2019-03-11 21:15:15 +01:00
parent b0c1c9b314
commit 520ae432d4
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
2 changed files with 15 additions and 2 deletions

View File

@ -600,7 +600,7 @@ providing the system administrator with some help in common tasks.")
(define-public util-linux
(package
(name "util-linux")
(version "2.32.1")
(version "2.33.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/utils/"
@ -608,7 +608,7 @@ providing the system administrator with some help in common tasks.")
name "-" version ".tar.xz"))
(sha256
(base32
"1ck7d8srw5szpjq7v0gpmjahnjs6wgqzm311ki4gazww6xx71rl6"))
"08ggvgrb59m5jbq29950xxirsgv4xj3nwsc7vf82nyg1nvrxjjy1"))
(patches (search-patches "util-linux-tests.patch"))
(modules '((guix build utils)))
(snippet

View File

@ -2,6 +2,8 @@ This test checks whether 'root' is successfully translated to UID/GID 0,
using 'getpwnam' in libmount. This doesn't work in the chroot because
/etc/passwd doesn't contain an entry for 'root' so skip it.
The second test requires that '/sys/dev/block' is present, which is not
the case inside the build container.
--- util-linux-2.25.2/tests/ts/libmount/optstr 2015-01-23 13:58:41.181151194 +0100
+++ util-linux-2.25.2/tests/ts/libmount/optstr 2015-01-23 13:58:42.829161716 +0100
@ -16,3 +18,14 @@ using 'getpwnam' in libmount. This doesn't work in the chroot because
ts_init_subtest "deduplicate"
ts_run $TESTPROG --dedup bbb,ccc,AAA,xxx,AAA=a,AAA=bbb,ddd,AAA=ccc,fff=eee AAA &> $TS_OUTPUT
ts_finalize_subtest
--- a/tests/ts/lsblk/lsblk 2019-03-11 21:08:23.734387391 +0100
+++ b/tests/ts/lsblk/lsblk 2019-03-11 21:12:43.635473111 +0100
@@ -22,6 +22,8 @@
ts_init "$*"
+ts_skip "/sys/dev/block is not available"
+
ts_check_test_command "$TS_CMD_LSBLK"
ts_check_prog xz
ts_check_prog tar