gnu: sed: Set PATH_MAX for Hurd systems.
* gnu/packages/patches/sed-hurd-path-max.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
This commit is contained in:
parent
8d866b96f7
commit
56eba3d152
|
@ -534,6 +534,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/ratpoison-shell.patch \
|
||||
gnu/packages/patches/readline-link-ncurses.patch \
|
||||
gnu/packages/patches/ripperx-libm.patch \
|
||||
gnu/packages/patches/sed-hurd-path-max.patch \
|
||||
gnu/packages/patches/scheme48-tests.patch \
|
||||
gnu/packages/patches/scotch-test-threading.patch \
|
||||
gnu/packages/patches/sdl-libx11-1.6.patch \
|
||||
|
|
|
@ -101,7 +101,8 @@ including, for example, recursive directory searching.")
|
|||
".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1myvrmh99jsvk7v3d7crm0gcrq51hmmm1r2kjyyci152in1x2j7h"))))
|
||||
"1myvrmh99jsvk7v3d7crm0gcrq51hmmm1r2kjyyci152in1x2j7h"))
|
||||
(patches (list (search-patch "sed-hurd-path-max.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(synopsis "Stream editor")
|
||||
(arguments
|
||||
|
|
|
@ -0,0 +1,34 @@
|
|||
7bb8d35d0330161a5af5341471d0c183a067e8c2
|
||||
Author: Jose E. Marchesi <jemarch@gnu.org>
|
||||
Date: Sun Oct 6 14:43:38 2013 +0200
|
||||
|
||||
Set PATH_MAX to some constant in case it is not defined in system
|
||||
headers.
|
||||
|
||||
2013-10-06 Jose E. Marchesi <jemarch@gnu.org>
|
||||
|
||||
* basicdefs.h (PATH_MAX): Defined to some constant in case it is
|
||||
not defined by system headers.
|
||||
* sed/utils.c: Do not include pathmax.h anymore.
|
||||
* bootstrap.conf (gnulib_modules): Do not use the gnulib module
|
||||
pathmax.
|
||||
|
||||
diff --git a/basicdefs.h b/basicdefs.h
|
||||
index 0d28a97..09f5beb 100644
|
||||
--- a/basicdefs.h
|
||||
+++ b/basicdefs.h
|
||||
@@ -40,6 +41,13 @@ typedef unsigned long countT;
|
||||
#define obstack_chunk_alloc ck_malloc
|
||||
#define obstack_chunk_free free
|
||||
|
||||
+/* MAX_PATH is not defined in some platforms, most notably GNU/Hurd.
|
||||
+ In that case we define it here to some constant. Note however that
|
||||
+ this relies in the fact that sed does reallocation if a buffer
|
||||
+ needs to be larger than PATH_MAX. */
|
||||
+#ifndef PATH_MAX
|
||||
+# define PATH_MAX 200
|
||||
+#endif
|
||||
|
||||
/* handle misdesigned <ctype.h> macros (snarfed from lib/regex.c) */
|
||||
/* Jim Meyering writes:
|
||||
|
Loading…
Reference in New Issue