gnu: netsurf: Upgrade to 3.6.
* gnu/packages/web.scm (netsurf): Upgrade to 3.6. [source]: 'https' -> 'http'. Remove modules, snippet, and patches. [home-page]: 'https' -> 'http'. [arguments]: Adjust source directories. * gnu/packages/patches/netsurf-about.patch: Delete patch. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
faa9ba4653
commit
57c211cd71
|
@ -771,7 +771,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/net-tools-bitrot.patch \
|
%D%/packages/patches/net-tools-bitrot.patch \
|
||||||
%D%/packages/patches/netcdf-date-time.patch \
|
%D%/packages/patches/netcdf-date-time.patch \
|
||||||
%D%/packages/patches/netcdf-tst_h_par.patch \
|
%D%/packages/patches/netcdf-tst_h_par.patch \
|
||||||
%D%/packages/patches/netsurf-about.patch \
|
|
||||||
%D%/packages/patches/ngircd-handle-zombies.patch \
|
%D%/packages/patches/ngircd-handle-zombies.patch \
|
||||||
%D%/packages/patches/ngircd-no-dns-in-tests.patch \
|
%D%/packages/patches/ngircd-no-dns-in-tests.patch \
|
||||||
%D%/packages/patches/ninja-tests.patch \
|
%D%/packages/patches/ninja-tests.patch \
|
||||||
|
|
|
@ -1,26 +0,0 @@
|
||||||
--- netsurf-all-3.5/netsurf/gtk/about.c
|
|
||||||
+++ netsurf-all-3.5/netsurf/gtk/about.c
|
|
||||||
@@ -79,11 +79,11 @@
|
|
||||||
switch (response_id) {
|
|
||||||
|
|
||||||
case ABOUT_RESPONSE_ID_LICENCE:
|
|
||||||
- about_open("about:credits");
|
|
||||||
+ about_open("about:licence");
|
|
||||||
break;
|
|
||||||
|
|
||||||
case ABOUT_RESPONSE_ID_CREDITS:
|
|
||||||
- about_open("about:licence");
|
|
||||||
+ about_open("about:credits");
|
|
||||||
break;
|
|
||||||
}
|
|
||||||
|
|
||||||
--- netsurf-all-3.5/netsurf/desktop/version.c
|
|
||||||
+++ netsurf-all-3.5/netsurf/desktop/version.c
|
|
||||||
@@ -20,6 +20,6 @@
|
|
||||||
|
|
||||||
#include "desktop/version.h"
|
|
||||||
|
|
||||||
-const char * const netsurf_version = "3.5 (6th April 1016)";
|
|
||||||
+const char * const netsurf_version = "3.5 (6th April 2016)";
|
|
||||||
const int netsurf_version_major = 3;
|
|
||||||
const int netsurf_version_minor = 5;
|
|
|
@ -3730,26 +3730,16 @@ tools they trust (e.g. wget).")
|
||||||
(define-public netsurf
|
(define-public netsurf
|
||||||
(package
|
(package
|
||||||
(name "netsurf")
|
(name "netsurf")
|
||||||
(version "3.5")
|
(version "3.6")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://download.netsurf-browser.org/"
|
(uri (string-append "http://download.netsurf-browser.org/"
|
||||||
"netsurf/releases/source-full/netsurf-all-"
|
"netsurf/releases/source-full/netsurf-all-"
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1vdldzcv42wykajmw8vbql0f1yd44gbx30kywfrrh2x3064ly609"))
|
"1cgq9n4nvkpih93sfpdadv3666ycsx9bnp8kwalbs8h232mr7ppx"))))
|
||||||
(modules '((guix build utils)))
|
|
||||||
(snippet
|
|
||||||
'(begin
|
|
||||||
(substitute* "Makefile"
|
|
||||||
;; Do not clobber PKG_CONFIG_PATH from the environment
|
|
||||||
(("PKG_CONFIG_PATH = \\$")
|
|
||||||
"PKG_CONFIG_PATH := $(PKG_CONFIG_PATH):$")
|
|
||||||
;; Honor make variables
|
|
||||||
(("shell cc") "shell $(CC)"))))
|
|
||||||
(patches (search-patches "netsurf-about.patch"))))
|
|
||||||
(build-system glib-or-gtk-build-system)
|
(build-system glib-or-gtk-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("pkg-config" ,pkg-config)
|
`(("pkg-config" ,pkg-config)
|
||||||
|
@ -3788,7 +3778,7 @@ tools they trust (e.g. wget).")
|
||||||
(add-after 'build 'adjust-welcome
|
(add-after 'build 'adjust-welcome
|
||||||
(lambda _
|
(lambda _
|
||||||
;; First, fix some unended tags and simple substitutions
|
;; First, fix some unended tags and simple substitutions
|
||||||
(substitute* "netsurf/gtk/res/welcome.html"
|
(substitute* "netsurf/frontends/gtk/res/welcome.html"
|
||||||
(("<(img|input)([^>]*)>" _ tag contents)
|
(("<(img|input)([^>]*)>" _ tag contents)
|
||||||
(string-append "<" tag contents " />"))
|
(string-append "<" tag contents " />"))
|
||||||
(("Licence") "License") ;prefer GNU spelling
|
(("Licence") "License") ;prefer GNU spelling
|
||||||
|
@ -3799,7 +3789,7 @@ tools they trust (e.g. wget).")
|
||||||
(("Google Search") "DuckDuckGo Search")
|
(("Google Search") "DuckDuckGo Search")
|
||||||
(("name=\"btnG\"") ""))
|
(("name=\"btnG\"") ""))
|
||||||
;; Remove default links so it doesn't seem we're endorsing them
|
;; Remove default links so it doesn't seem we're endorsing them
|
||||||
(with-atomic-file-replacement "netsurf/gtk/res/welcome.html"
|
(with-atomic-file-replacement "netsurf/frontends/gtk/res/welcome.html"
|
||||||
(lambda (in out)
|
(lambda (in out)
|
||||||
;; Leave the DOCTYPE header as is
|
;; Leave the DOCTYPE header as is
|
||||||
(display (read-line in 'concat) out)
|
(display (read-line in 'concat) out)
|
||||||
|
@ -3821,7 +3811,7 @@ tools they trust (e.g. wget).")
|
||||||
(desktop (string-append out "/share/applications/"
|
(desktop (string-append out "/share/applications/"
|
||||||
"netsurf.desktop")))
|
"netsurf.desktop")))
|
||||||
(mkdir-p (dirname desktop))
|
(mkdir-p (dirname desktop))
|
||||||
(copy-file "netsurf/gtk/res/netsurf-gtk.desktop"
|
(copy-file "netsurf/frontends/gtk/res/netsurf-gtk.desktop"
|
||||||
desktop)
|
desktop)
|
||||||
(substitute* desktop
|
(substitute* desktop
|
||||||
(("netsurf-gtk") (string-append out "/bin/netsurf"))
|
(("netsurf-gtk") (string-append out "/bin/netsurf"))
|
||||||
|
@ -3830,7 +3820,7 @@ tools they trust (e.g. wget).")
|
||||||
(install-file "netsurf/Docs/netsurf-gtk.1"
|
(install-file "netsurf/Docs/netsurf-gtk.1"
|
||||||
(string-append out "/share/man/man1/"))
|
(string-append out "/share/man/man1/"))
|
||||||
#t))))))
|
#t))))))
|
||||||
(home-page "https://www.netsurf-browser.org")
|
(home-page "http://www.netsurf-browser.org")
|
||||||
(synopsis "Web browser")
|
(synopsis "Web browser")
|
||||||
(description
|
(description
|
||||||
"NetSurf is a lightweight web browser that has its own layout and
|
"NetSurf is a lightweight web browser that has its own layout and
|
||||||
|
|
Loading…
Reference in New Issue