gnu: nss: Fix build failure on armhf-linux.

Fixes <https://bugs.gnu.org/36930>.

* gnu/packages/patches/nss-freebl-stubs.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/nss.scm (nss)[source](patches): Add it.
master
Marius Bakke 2019-08-06 17:06:57 +02:00
parent c94884bcc1
commit 58e37b5441
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 22 additions and 0 deletions

View File

@ -1119,6 +1119,7 @@ dist_patch_DATA = \
%D%/packages/patches/nfs-utils-missing-headers.patch \
%D%/packages/patches/ngircd-handle-zombies.patch \
%D%/packages/patches/nm-plugin-path.patch \
%D%/packages/patches/nss-freebl-stubs.patch \
%D%/packages/patches/nss-increase-test-timeout.patch \
%D%/packages/patches/nss-pkgconfig.patch \
%D%/packages/patches/ntfs-3g-CVE-2019-9755.patch \

View File

@ -84,6 +84,7 @@ in the Mozilla clients.")
"12sfq9xvpwpc22qnjsg1if1lmchiy33byrh92wn91phz7li0abqi"))
;; Create nss.pc and nss-config.
(patches (search-patches "nss-pkgconfig.patch"
"nss-freebl-stubs.patch"
"nss-increase-test-timeout.patch"))))
(build-system gnu-build-system)
(outputs '("out" "bin"))

View File

@ -0,0 +1,20 @@
This patch is required for Makefile-based builds of NSS 3.45 on armhf-linux.
Taken from upstream bug tracker:
https://bugzilla.mozilla.org/show_bug.cgi?id=1571316
diff --git a/nss/lib/freebl/ecl/curve25519_32.c b/nss/lib/freebl/ecl/curve25519_32.c
--- a/nss/lib/freebl/ecl/curve25519_32.c
+++ b/nss/lib/freebl/ecl/curve25519_32.c
@@ -29,6 +29,10 @@
* 1. Convert custom integer types to stdint.h types
*/
+#ifdef FREEBL_NO_DEPEND
+#include "../stubs.h"
+#endif
+
#include "ecl-priv.h"
/* fe means field element. Here the field is \Z/(2^255-19). An element t,