gnu: guile-ssh: Fix bug in 'node-guile-version'.
* gnu/packages/patches/guile-ssh-rexec-bug.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/ssh.scm (guile-ssh)[source](patches): New field.
This commit is contained in:
parent
d116695b31
commit
5a3429bcc5
|
@ -649,6 +649,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/guile-present-coding.patch \
|
||||
%D%/packages/patches/guile-relocatable.patch \
|
||||
%D%/packages/patches/guile-rsvg-pkgconfig.patch \
|
||||
%D%/packages/patches/guile-ssh-rexec-bug.patch \
|
||||
%D%/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch \
|
||||
%D%/packages/patches/gtk2-respect-GUIX_GTK2_IM_MODULE_FILE.patch \
|
||||
%D%/packages/patches/gtk2-theme-paths.patch \
|
||||
|
|
|
@ -0,0 +1,16 @@
|
|||
Fix a bug whereby 'node-guile-version' would pass a node instead of
|
||||
a session to 'rexec'.
|
||||
|
||||
diff --git a/modules/ssh/dist/node.scm b/modules/ssh/dist/node.scm
|
||||
index 9c065c7..29a3906 100644
|
||||
--- a/modules/ssh/dist/node.scm
|
||||
+++ b/modules/ssh/dist/node.scm
|
||||
@@ -411,7 +411,8 @@ procedure returns the 1st evaluated value if multiple values were returned."
|
||||
"Get Guile version installed on a NODE, return the version string. Return
|
||||
#f if Guile is not installed."
|
||||
(receive (result rc)
|
||||
- (rexec node "which guile > /dev/null && guile --version")
|
||||
+ (rexec (node-session node)
|
||||
+ "which guile > /dev/null && guile --version")
|
||||
(and (zero? rc)
|
||||
(car result))))
|
|
@ -226,6 +226,7 @@ Additionally, various channel-specific options can be negotiated.")
|
|||
(sha256
|
||||
(base32
|
||||
"0r261i8kc3avbmbwgyzak2vnqwssjlgz37g2y2fwm80w9bmn2m7j"))
|
||||
(patches (search-patches "guile-ssh-rexec-bug.patch"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
;; 'configure.ac' mistakenly tries to link files from examples/
|
||||
|
|
Loading…
Reference in New Issue