gnu: sssd: Update to 1.16.4.
* gnu/packages/patches/sssd-curl-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/sssd.scm (sssd): Update to 1.16.4. [source](patches): Remove. [arguments]: Enable fixed tests.
This commit is contained in:
parent
2b3a10b6b5
commit
5c3f1e4306
|
@ -1309,7 +1309,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/snappy-add-O2-flag-in-CmakeLists.txt.patch \
|
||||
%D%/packages/patches/sooperlooper-build-with-wx-30.patch \
|
||||
%D%/packages/patches/soundconverter-remove-gconf-dependency.patch \
|
||||
%D%/packages/patches/sssd-curl-compat.patch \
|
||||
%D%/packages/patches/steghide-fixes.patch \
|
||||
%D%/packages/patches/strace-ipc-tests.patch \
|
||||
%D%/packages/patches/streamlink-update-test.patch \
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
Fix build with curl >= 7.62. Patch taken from upstream:
|
||||
|
||||
https://pagure.io/SSSD/sssd/c/4d3841ca379afc01184453ba45ab3e75ffec60da?branch=sssd-1-16
|
||||
|
||||
diff --git a/src/util/tev_curl.c b/src/util/tev_curl.c
|
||||
index 6a7a580..d70a429 100644
|
||||
--- a/src/util/tev_curl.c
|
||||
+++ b/src/util/tev_curl.c
|
||||
@@ -97,7 +97,9 @@ static errno_t curl_code2errno(CURLcode crv)
|
||||
return ETIMEDOUT;
|
||||
case CURLE_SSL_ISSUER_ERROR:
|
||||
case CURLE_SSL_CACERT_BADFILE:
|
||||
+#if LIBCURL_VERSION_NUM < 0x073e00
|
||||
case CURLE_SSL_CACERT:
|
||||
+#endif
|
||||
case CURLE_SSL_CERTPROBLEM:
|
||||
return ERR_INVALID_CERT;
|
||||
|
|
@ -81,15 +81,14 @@ fundamental object types for C.")
|
|||
(define-public sssd
|
||||
(package
|
||||
(name "sssd")
|
||||
(version "1.16.2")
|
||||
(version "1.16.4")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://releases.pagure.org/SSSD/sssd/"
|
||||
"sssd-" version ".tar.gz"))
|
||||
(patches (search-patches "sssd-curl-compat.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"032ppk57qs1lnvz7pb7lw9ldwm9i1yagh9fzgqgn6na3bg61ynzy"))))
|
||||
"0ngr7cgimyjc6flqkm7psxagp1m4jlzpqkn28pliifbmdg6i5ckb"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:make-flags
|
||||
|
@ -130,10 +129,6 @@ fundamental object types for C.")
|
|||
(lambda _
|
||||
(substitute* "src/tests/responder_socket_access-tests.c"
|
||||
(("tcase_add_test\\(tc_utils, resp_str_to_array_test\\);") ""))
|
||||
;; XXX: These tests fail with recent versions of ldb. See
|
||||
;; <https://pagure.io/SSSD/sssd/issue/3563>.
|
||||
(substitute* "Makefile.in"
|
||||
(("sysdb-tests\\$\\(EXEEXT\\)") ""))
|
||||
#t)))))
|
||||
(inputs
|
||||
`(("augeas" ,augeas)
|
||||
|
|
Loading…
Reference in New Issue