gnu: gnome-todo: Fix compatibility with libical >= 3.0.

* gnu/packages/patches/gnome-todo-libical-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/gnome.scm (gnome-todo)[source](patches): Use it.
master
Marius Bakke 2018-03-06 17:25:02 +01:00
parent 4c8413cd61
commit 5de561a796
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 19 additions and 0 deletions

View File

@ -724,6 +724,7 @@ dist_patch_DATA = \
%D%/packages/patches/glog-gcc-5-demangling.patch \
%D%/packages/patches/gmp-arm-asm-nothumb.patch \
%D%/packages/patches/gmp-faulty-test.patch \
%D%/packages/patches/gnome-todo-libical-compat.patch \
%D%/packages/patches/gnome-tweak-tool-search-paths.patch \
%D%/packages/patches/gnucash-price-quotes-perl.patch \
%D%/packages/patches/gnutls-skip-trust-store-test.patch \

View File

@ -6207,6 +6207,7 @@ desktop. It supports multiple calendars, month, week and year view.")
(uri (string-append "mirror://gnome/sources/" name "/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(patches (search-patches "gnome-todo-libical-compat.patch"))
(sha256
(base32
"106xx1w18pxjmj5k0k2qjzi6b3c3kaz7b5kyrpknykibnr401ff9"))))

View File

@ -0,0 +1,17 @@
Fix compatibility with libical 3.0.
Patch copied from Arch Linux:
https://git.archlinux.org/svntogit/packages.git/tree/trunk/gnome-todo-3.26.2-libical-3.0.patch?h=packages/gnome-todo
diff -up gnome-todo-3.26.2/src/gtd-task.c.libical-3.0 gnome-todo-3.26.2/src/gtd-task.c
--- gnome-todo-3.26.2/src/gtd-task.c.libical-3.0 2017-11-08 14:53:53.484294926 +0100
+++ gnome-todo-3.26.2/src/gtd-task.c 2017-11-08 14:53:57.208294874 +0100
@@ -778,7 +778,7 @@ gtd_task_set_complete (GtdTask *task,
dt->minute = g_date_time_get_minute (now);
dt->second = g_date_time_get_seconds (now);
dt->is_date = 0;
- dt->is_utc = 1;
+ dt->zone = icaltimezone_get_utc_timezone ();
/* convert timezone
*