gnu: alsa-lib: Update to 1.1.3.

* gnu/packages/patches/alsa-lib-mips-atomic-fix.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/linux.scm (alsa-lib): Update to 1.1.3.
[source]: Remove patch.
[home-page]: Use HTTPS.
This commit is contained in:
Marius Bakke 2017-02-23 10:56:15 +01:00
parent 2f7b4749e7
commit 5f3070a500
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 3 additions and 47 deletions

View File

@ -481,7 +481,6 @@ dist_patch_DATA = \
%D%/packages/patches/aegis-test-fixup-1.patch \ %D%/packages/patches/aegis-test-fixup-1.patch \
%D%/packages/patches/aegis-test-fixup-2.patch \ %D%/packages/patches/aegis-test-fixup-2.patch \
%D%/packages/patches/agg-am_c_prototype.patch \ %D%/packages/patches/agg-am_c_prototype.patch \
%D%/packages/patches/alsa-lib-mips-atomic-fix.patch \
%D%/packages/patches/antiword-CVE-2014-8123.patch \ %D%/packages/patches/antiword-CVE-2014-8123.patch \
%D%/packages/patches/apr-skip-getservbyname-test.patch \ %D%/packages/patches/apr-skip-getservbyname-test.patch \
%D%/packages/patches/arb-ldconfig.patch \ %D%/packages/patches/arb-ldconfig.patch \

View File

@ -865,7 +865,7 @@ intercept and print the system calls executed by the program.")
(define-public alsa-lib (define-public alsa-lib
(package (package
(name "alsa-lib") (name "alsa-lib")
(version "1.0.27.1") (version "1.1.3")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append (uri (string-append
@ -873,10 +873,9 @@ intercept and print the system calls executed by the program.")
version ".tar.bz2")) version ".tar.bz2"))
(sha256 (sha256
(base32 (base32
"0fx057746dj7rjdi0jnvx2m9b0y1lgdkh1hks87d8w32xyihf3k9")) "174n2psp0328xcy2f1ayls67598bxli6q9cf00d2qnac3012aa3i"))))
(patches (search-patches "alsa-lib-mips-atomic-fix.patch"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(home-page "http://www.alsa-project.org/") (home-page "https://www.alsa-project.org/")
(synopsis "The Advanced Linux Sound Architecture libraries") (synopsis "The Advanced Linux Sound Architecture libraries")
(description (description
"The Advanced Linux Sound Architecture (ALSA) provides audio and "The Advanced Linux Sound Architecture (ALSA) provides audio and

View File

@ -1,42 +0,0 @@
Fix the declarations of inlined atomic ops for mips.
This patch was copied from Debian.
--- alsa-lib/include/iatomic.h.orig 2013-05-21 04:48:28.000000000 -0400
+++ alsa-lib/include/iatomic.h 2013-10-29 13:01:37.055995968 -0400
@@ -720,7 +720,7 @@
* Atomically adds @i to @v. Note that the guaranteed useful range
* of an atomic_t is only 24 bits.
*/
-extern __inline__ void atomic_add(int i, atomic_t * v)
+static __inline__ void atomic_add(int i, atomic_t * v)
{
unsigned long temp;
@@ -744,7 +744,7 @@
* Atomically subtracts @i from @v. Note that the guaranteed
* useful range of an atomic_t is only 24 bits.
*/
-extern __inline__ void atomic_sub(int i, atomic_t * v)
+static __inline__ void atomic_sub(int i, atomic_t * v)
{
unsigned long temp;
@@ -763,7 +763,7 @@
/*
* Same as above, but return the result value
*/
-extern __inline__ int atomic_add_return(int i, atomic_t * v)
+static __inline__ int atomic_add_return(int i, atomic_t * v)
{
unsigned long temp, result;
@@ -784,7 +784,7 @@
return result;
}
-extern __inline__ int atomic_sub_return(int i, atomic_t * v)
+static __inline__ int atomic_sub_return(int i, atomic_t * v)
{
unsigned long temp, result;