gnu: nfs-utils: Adapt to changes in glibc 2.26.
* gnu/packages/patches/nfs-utils-missing-headers.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/nfs.scm (nfs-utils)[source]: Use it.
This commit is contained in:
parent
03674a7ca2
commit
606e246861
|
@ -893,6 +893,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/netsurf-longer-test-timeout.patch \
|
||||
%D%/packages/patches/newsbeuter-CVE-2017-12904.patch \
|
||||
%D%/packages/patches/newsbeuter-CVE-2017-14500.patch \
|
||||
%D%/packages/patches/nfs-utils-missing-headers.patch \
|
||||
%D%/packages/patches/ngircd-handle-zombies.patch \
|
||||
%D%/packages/patches/ninja-zero-mtime.patch \
|
||||
%D%/packages/patches/nss-increase-test-timeout.patch \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
|
||||
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
|
||||
;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -47,6 +47,7 @@
|
|||
(uri (string-append
|
||||
"mirror://kernel.org/linux/utils/nfs-utils/" version
|
||||
"/nfs-utils-" version ".tar.xz"))
|
||||
(patches (search-patches "nfs-utils-missing-headers.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"1vqrqzhg9nh2wj1icp7k8v9dibgnn521b45np79nnkmqf16bbbhg"))))
|
||||
|
|
|
@ -0,0 +1,19 @@
|
|||
Fix compilation failure with glibc 2.26 caused by missing type
|
||||
declarations:
|
||||
|
||||
------
|
||||
rpc.c: In function ‘nsm_recv_getport’:
|
||||
rpc.c:469:13: error: ‘UINT16_MAX’ undeclared (first use in this function)
|
||||
if (port > UINT16_MAX) {
|
||||
------
|
||||
|
||||
--- a/support/nsm/rpc.c.orig 2016-08-03 20:25:15.000000000 +0200
|
||||
+++ b/support/nsm/rpc.c 2017-08-26 07:41:11.884000000 +0200
|
||||
@@ -40,6 +40,7 @@
|
||||
|
||||
#include <time.h>
|
||||
#include <stdbool.h>
|
||||
+#include <stdint.h>
|
||||
#include <string.h>
|
||||
#include <unistd.h>
|
||||
#include <fcntl.h>
|
Loading…
Reference in New Issue