gnu: php: Update to 7.1.2.
* gnu/packages/php.scm (php): Update to 7.1.2. [inputs]: Add gnutls. [arguments]: Disable more tests in 'prepare-tests' phase. (gd-for-php): Remove variable. * gnu/packages/patches/gd-fix-chunk-size-on-boundaries.patch, gnu/packages/patches/gd-fix-truecolor-format-correction.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. Signed-off-by: Leo Famulari <leo@famulari.name>
This commit is contained in:
parent
e8293ef12c
commit
60a5080675
|
@ -578,10 +578,8 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gcc-6-cross-environment-variables.patch \
|
||||
%D%/packages/patches/gcj-arm-mode.patch \
|
||||
%D%/packages/patches/gdk-pixbuf-list-dir.patch \
|
||||
%D%/packages/patches/gd-fix-chunk-size-on-boundaries.patch \
|
||||
%D%/packages/patches/gd-fix-gd2-read-test.patch \
|
||||
%D%/packages/patches/gd-fix-tests-on-i686.patch \
|
||||
%D%/packages/patches/gd-fix-truecolor-format-correction.patch \
|
||||
%D%/packages/patches/gd-freetype-test-failure.patch \
|
||||
%D%/packages/patches/gd-php-73968-Fix-109-XBM-reading.patch \
|
||||
%D%/packages/patches/gegl-CVE-2012-4433.patch \
|
||||
|
|
|
@ -1,102 +0,0 @@
|
|||
This fixes PHP bug #73155: https://bugs.php.net/bug.php?id=73155
|
||||
|
||||
Patch adapted from upstream source repository:
|
||||
|
||||
https://github.com/libgd/libgd/commit/8067a8ac336dfe0acbe96ec2eb24572209a7f279
|
||||
|
||||
(.gitignore change removed)
|
||||
|
||||
From 8067a8ac336dfe0acbe96ec2eb24572209a7f279 Mon Sep 17 00:00:00 2001
|
||||
From: "Christoph M. Becker" <cmbecker69@gmx.de>
|
||||
Date: Fri, 23 Sep 2016 18:29:52 +0200
|
||||
Subject: [PATCH] Fix #309: gdImageGd2() writes wrong chunk sizes on boundaries
|
||||
|
||||
(cherry picked from commit bb1998a16e30d542ab22eba5501911a9aa066edb)
|
||||
---
|
||||
src/gd_gd2.c | 4 ++--
|
||||
tests/gd2/CMakeLists.txt | 1 +
|
||||
tests/gd2/Makemodule.am | 1 +
|
||||
tests/gd2/bug00309.c | 37 +++++++++++++++++++++++++++++++++++++
|
||||
4 files changed, 41 insertions(+), 2 deletions(-)
|
||||
create mode 100644 tests/gd2/bug00309.c
|
||||
|
||||
diff --git a/src/gd_gd2.c b/src/gd_gd2.c
|
||||
index 75e5e1f..b9b2f93 100644
|
||||
--- a/src/gd_gd2.c
|
||||
+++ b/src/gd_gd2.c
|
||||
@@ -938,8 +938,8 @@ _gdImageGd2 (gdImagePtr im, gdIOCtx * out, int cs, int fmt)
|
||||
};
|
||||
|
||||
/* Work out number of chunks. */
|
||||
- ncx = im->sx / cs + 1;
|
||||
- ncy = im->sy / cs + 1;
|
||||
+ ncx = (im->sx + cs - 1) / cs;
|
||||
+ ncy = (im->sy + cs - 1) / cs;
|
||||
|
||||
/* Write the standard header. */
|
||||
_gd2PutHeader (im, out, cs, fmt, ncx, ncy);
|
||||
diff --git a/tests/gd2/CMakeLists.txt b/tests/gd2/CMakeLists.txt
|
||||
index 3b650ad..247b466 100644
|
||||
--- a/tests/gd2/CMakeLists.txt
|
||||
+++ b/tests/gd2/CMakeLists.txt
|
||||
@@ -1,5 +1,6 @@
|
||||
SET(TESTS_FILES
|
||||
bug_289
|
||||
+ bug00309
|
||||
gd2_empty_file
|
||||
gd2_im2im
|
||||
gd2_null
|
||||
diff --git a/tests/gd2/Makemodule.am b/tests/gd2/Makemodule.am
|
||||
index b8ee946..d69aee0 100644
|
||||
--- a/tests/gd2/Makemodule.am
|
||||
+++ b/tests/gd2/Makemodule.am
|
||||
@@ -1,5 +1,6 @@
|
||||
libgd_test_programs += \
|
||||
gd2/bug_289 \
|
||||
+ gd2/bug00309 \
|
||||
gd2/gd2_empty_file \
|
||||
gd2/php_bug_72339 \
|
||||
gd2/gd2_read_corrupt
|
||||
diff --git a/tests/gd2/bug00309.c b/tests/gd2/bug00309.c
|
||||
new file mode 100644
|
||||
index 0000000..b649cdc
|
||||
--- /dev/null
|
||||
+++ b/tests/gd2/bug00309.c
|
||||
@@ -0,0 +1,37 @@
|
||||
+/**
|
||||
+ * Regression test for <https://github.com/libgd/libgd/issues/309>.
|
||||
+ *
|
||||
+ * We test that an image with 64x64 pixels reports only a single chunk in the
|
||||
+ * GD2 image header when the chunk size is 64.
|
||||
+ */
|
||||
+
|
||||
+
|
||||
+#include "gd.h"
|
||||
+#include "gdtest.h"
|
||||
+
|
||||
+
|
||||
+int main()
|
||||
+{
|
||||
+ gdImagePtr im;
|
||||
+ unsigned char *buf;
|
||||
+ int size, word;
|
||||
+
|
||||
+ im = gdImageCreate(64, 64);
|
||||
+ gdImageColorAllocate(im, 0, 0, 0);
|
||||
+
|
||||
+ buf = gdImageGd2Ptr(im, 64, 1, &size);
|
||||
+
|
||||
+ gdImageDestroy(im);
|
||||
+
|
||||
+ word = buf[10] << 8 | buf[11];
|
||||
+ gdTestAssertMsg(word == 64, "chunk size is %d, but expected 64\n", word);
|
||||
+ word = buf[14] << 8 | buf[15];
|
||||
+ gdTestAssertMsg(word == 1, "x chunk count is %d, but expected 1\n", word);
|
||||
+ word = buf[16] << 8 | buf[17];
|
||||
+ gdTestAssertMsg(word == 1, "y chunk count is %d, but expected 1\n", word);
|
||||
+ gdTestAssertMsg(size == 5145, "file size is %d, but expected 5145\n", size);
|
||||
+
|
||||
+ gdFree(buf);
|
||||
+
|
||||
+ return gdNumFailures();
|
||||
+}
|
|
@ -1,95 +0,0 @@
|
|||
This fixes PHP bug #73159: https://bugs.php.net/bug.php?id=73159
|
||||
|
||||
Patch lifted from upstream source repository:
|
||||
|
||||
https://github.com/libgd/libgd/commit/e1f61a4141d2e0937a13b8bfb1992b9f29eb05f5
|
||||
|
||||
From e1f61a4141d2e0937a13b8bfb1992b9f29eb05f5 Mon Sep 17 00:00:00 2001
|
||||
From: "Christoph M. Becker" <cmbecker69@gmx.de>
|
||||
Date: Mon, 15 Aug 2016 17:49:40 +0200
|
||||
Subject: [PATCH] Fix #289: Passing unrecognized formats to gdImageGd2 results
|
||||
in corrupted files
|
||||
|
||||
We must not apply the format correction twice for truecolor images.
|
||||
|
||||
(cherry picked from commit 09090c125658e23a4ae2a2e002646bb7278bd89e)
|
||||
---
|
||||
src/gd_gd2.c | 2 +-
|
||||
tests/gd2/CMakeLists.txt | 1 +
|
||||
tests/gd2/Makemodule.am | 1 +
|
||||
tests/gd2/bug_289.c | 33 +++++++++++++++++++++++++++++++++
|
||||
4 files changed, 36 insertions(+), 1 deletion(-)
|
||||
create mode 100644 tests/gd2/bug_289.c
|
||||
|
||||
diff --git a/src/gd_gd2.c b/src/gd_gd2.c
|
||||
index 86c881e..75e5e1f 100644
|
||||
--- a/src/gd_gd2.c
|
||||
+++ b/src/gd_gd2.c
|
||||
@@ -918,7 +918,7 @@ _gdImageGd2 (gdImagePtr im, gdIOCtx * out, int cs, int fmt)
|
||||
/* Force fmt to a valid value since we don't return anything. */
|
||||
/* */
|
||||
if ((fmt != GD2_FMT_RAW) && (fmt != GD2_FMT_COMPRESSED)) {
|
||||
- fmt = im->trueColor ? GD2_FMT_TRUECOLOR_COMPRESSED : GD2_FMT_COMPRESSED;
|
||||
+ fmt = GD2_FMT_COMPRESSED;
|
||||
};
|
||||
if (im->trueColor) {
|
||||
fmt += 2;
|
||||
diff --git a/tests/gd2/CMakeLists.txt b/tests/gd2/CMakeLists.txt
|
||||
index 8aecacc..3b650ad 100644
|
||||
--- a/tests/gd2/CMakeLists.txt
|
||||
+++ b/tests/gd2/CMakeLists.txt
|
||||
@@ -1,4 +1,5 @@
|
||||
SET(TESTS_FILES
|
||||
+ bug_289
|
||||
gd2_empty_file
|
||||
gd2_im2im
|
||||
gd2_null
|
||||
diff --git a/tests/gd2/Makemodule.am b/tests/gd2/Makemodule.am
|
||||
index 754a284..b8ee946 100644
|
||||
--- a/tests/gd2/Makemodule.am
|
||||
+++ b/tests/gd2/Makemodule.am
|
||||
@@ -1,4 +1,5 @@
|
||||
libgd_test_programs += \
|
||||
+ gd2/bug_289 \
|
||||
gd2/gd2_empty_file \
|
||||
gd2/php_bug_72339 \
|
||||
gd2/gd2_read_corrupt
|
||||
diff --git a/tests/gd2/bug_289.c b/tests/gd2/bug_289.c
|
||||
new file mode 100644
|
||||
index 0000000..ad311e9
|
||||
--- /dev/null
|
||||
+++ b/tests/gd2/bug_289.c
|
||||
@@ -0,0 +1,33 @@
|
||||
+/**
|
||||
+ * Passing an unrecognized format to gdImageGd2() should result in
|
||||
+ * GD2_FMT_TRUECOLOR_COMPRESSED for truecolor images.
|
||||
+ *
|
||||
+ * See <https://github.com/libgd/libgd/issues/289>.
|
||||
+ */
|
||||
+
|
||||
+#include "gd.h"
|
||||
+#include "gdtest.h"
|
||||
+
|
||||
+
|
||||
+#define GD2_FMT_UNRECOGNIZED 0
|
||||
+#define GD2_FMT_TRUECOLOR_COMPRESSED 4
|
||||
+
|
||||
+#define MSG "expected %s byte to be %d, but got %d\n"
|
||||
+
|
||||
+
|
||||
+int main()
|
||||
+{
|
||||
+ gdImagePtr im;
|
||||
+ char *buffer;
|
||||
+ int size;
|
||||
+
|
||||
+ im = gdImageCreateTrueColor(10, 10);
|
||||
+ gdTestAssert(im != NULL);
|
||||
+ buffer = (char *) gdImageGd2Ptr(im, 128, GD2_FMT_UNRECOGNIZED, &size);
|
||||
+ gdTestAssert(buffer != NULL);
|
||||
+ gdImageDestroy(im);
|
||||
+ gdTestAssertMsg(buffer[12] == 0, MSG, "1st", 0, buffer[12]);
|
||||
+ gdTestAssertMsg(buffer[13] == GD2_FMT_TRUECOLOR_COMPRESSED, MSG, "2nd", GD2_FMT_TRUECOLOR_COMPRESSED, buffer[13]);
|
||||
+
|
||||
+ return gdNumFailures();
|
||||
+}
|
|
@ -50,21 +50,10 @@
|
|||
#:use-module (guix build-system gnu)
|
||||
#:use-module ((guix licenses) #:prefix license:))
|
||||
|
||||
;; This fixes PHP bugs 73155 and 73159. Remove when gd
|
||||
;; is updated to > 2.2.3.
|
||||
(define gd-for-php
|
||||
(package (inherit gd)
|
||||
(source
|
||||
(origin
|
||||
(inherit (package-source gd))
|
||||
(patches (search-patches
|
||||
"gd-fix-truecolor-format-correction.patch"
|
||||
"gd-fix-chunk-size-on-boundaries.patch"))))))
|
||||
|
||||
(define-public php
|
||||
(package
|
||||
(name "php")
|
||||
(version "7.0.14")
|
||||
(version "7.1.2")
|
||||
(home-page "https://secure.php.net/")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
|
@ -72,7 +61,7 @@
|
|||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"12ccgbrfchgvmcfb88rcknq7xmrf19c5ysdr4v8jxk51j9izy78g"))
|
||||
"0wg9ng230w724rpwsrhcg4pw41xm1xhz0zx76haanyymkz1s05fq"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(with-directory-excursion "ext"
|
||||
|
@ -179,6 +168,13 @@
|
|||
"ext/standard/tests/general_functions/bug44667.phpt"
|
||||
"ext/standard/tests/general_functions/proc_open.phpt")
|
||||
(("/bin/cat") (which "cat")))
|
||||
|
||||
;; These tests fail because they include a file whose modification
|
||||
;; time is 0. Touch them to make the test pass. The issue is reported
|
||||
;; upstream as #74137.
|
||||
(utime "sapi/phpdbg/tests/include.inc" 1 1)
|
||||
(utime "sapi/phpdbg/tests/phpdbg_get_executable_stream_wrapper.inc" 1 1)
|
||||
|
||||
;; The encoding of this file is not recognized, so we simply drop it.
|
||||
(delete-file "ext/mbstring/tests/mb_send_mail07.phpt")
|
||||
|
||||
|
@ -257,8 +253,10 @@
|
|||
;; The test expects an Array, but instead get the contents(?).
|
||||
"ext/gd/tests/bug43073.phpt"
|
||||
;; imagettftext() returns wrong coordinates.
|
||||
"ext/gd/tests/bug48732-mb.phpt"
|
||||
"ext/gd/tests/bug48732.phpt"
|
||||
;; Similarly for imageftbbox().
|
||||
"ext/gd/tests/bug48801-mb.phpt"
|
||||
"ext/gd/tests/bug48801.phpt"
|
||||
;; Different expected output from imagecolorallocate().
|
||||
"ext/gd/tests/bug53504.phpt"
|
||||
|
@ -291,10 +289,11 @@
|
|||
("curl" ,curl)
|
||||
("cyrus-sasl" ,cyrus-sasl)
|
||||
("freetype" ,freetype)
|
||||
("gd" ,gd-for-php)
|
||||
("gd" ,gd)
|
||||
("gdbm" ,gdbm)
|
||||
("glibc" ,glibc)
|
||||
("gmp" ,gmp)
|
||||
("gnutls" ,gnutls)
|
||||
("libgcrypt" ,libgcrypt)
|
||||
("libjpeg" ,libjpeg)
|
||||
("libpng" ,libpng)
|
||||
|
|
Loading…
Reference in New Issue