gnu: inkscape: Update to 0.48.5.
* gnu/packages/patches/inkscape-stray-comma.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove it. * gnu/packages/inkscape.scm (inkscape): Update to 0.48.5. Remove patch. Use the .bz2 source tarball. Use current libgc. Add 'fix-test-includes' phase.
This commit is contained in:
parent
ce4d7abf02
commit
618ea7c94e
|
@ -388,7 +388,6 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/icecat-CVE-2014-1592.patch \
|
gnu/packages/patches/icecat-CVE-2014-1592.patch \
|
||||||
gnu/packages/patches/icecat-CVE-2014-1593.patch \
|
gnu/packages/patches/icecat-CVE-2014-1593.patch \
|
||||||
gnu/packages/patches/icecat-CVE-2014-1594.patch \
|
gnu/packages/patches/icecat-CVE-2014-1594.patch \
|
||||||
gnu/packages/patches/inkscape-stray-comma.patch \
|
|
||||||
gnu/packages/patches/jbig2dec-ignore-testtest.patch \
|
gnu/packages/patches/jbig2dec-ignore-testtest.patch \
|
||||||
gnu/packages/patches/kmod-module-directory.patch \
|
gnu/packages/patches/kmod-module-directory.patch \
|
||||||
gnu/packages/patches/libarchive-CVE-2013-0211.patch \
|
gnu/packages/patches/libarchive-CVE-2013-0211.patch \
|
||||||
|
|
|
@ -1,5 +1,6 @@
|
||||||
;;; GNU Guix --- Functional package management for GNU
|
;;; GNU Guix --- Functional package management for GNU
|
||||||
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
|
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
|
||||||
|
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -41,15 +42,14 @@
|
||||||
(define-public inkscape
|
(define-public inkscape
|
||||||
(package
|
(package
|
||||||
(name "inkscape")
|
(name "inkscape")
|
||||||
(version "0.48.4")
|
(version "0.48.5")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://sourceforge/inkscape/inkscape-"
|
(uri (string-append "mirror://sourceforge/inkscape/inkscape-"
|
||||||
version ".tar.gz"))
|
version ".tar.bz2"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0nhxsgrgsx6zrgpkd1akxjvmdqjp8ccnsvlwxh62l0brg84fw6bf"))
|
"0sfr7a1vr1066rrkkqbqvcqs3gawalj68ralnhd6k87jz62fcv1b"))))
|
||||||
(patches (list (search-patch "inkscape-stray-comma.patch")))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs
|
(inputs
|
||||||
`(("aspell" ,aspell)
|
`(("aspell" ,aspell)
|
||||||
|
@ -60,11 +60,7 @@
|
||||||
("libpng" ,libpng)
|
("libpng" ,libpng)
|
||||||
("libxml2" ,libxml2)
|
("libxml2" ,libxml2)
|
||||||
("libxslt" ,libxslt)
|
("libxslt" ,libxslt)
|
||||||
|
("libgc" ,libgc)
|
||||||
;; With libgc 7.4, compilation fails with:
|
|
||||||
;; gc.cpp:123:1: error: invalid conversion from 'int (*)(void**, const void*)' to 'int (*)(void**, void*)'
|
|
||||||
("libgc" ,libgc-7.2)
|
|
||||||
|
|
||||||
("freetype" ,freetype)
|
("freetype" ,freetype)
|
||||||
("popt" ,popt)
|
("popt" ,popt)
|
||||||
("python" ,python-2)
|
("python" ,python-2)
|
||||||
|
@ -74,6 +70,13 @@
|
||||||
`(("intltool" ,intltool)
|
`(("intltool" ,intltool)
|
||||||
("perl" ,perl)
|
("perl" ,perl)
|
||||||
("pkg-config" ,pkg-config)))
|
("pkg-config" ,pkg-config)))
|
||||||
|
(arguments
|
||||||
|
`(#:phases (alist-cons-after
|
||||||
|
'unpack 'fix-test-includes
|
||||||
|
(lambda _
|
||||||
|
(substitute* "src/cxxtests.cpp"
|
||||||
|
(("\\.\\./\\.\\./src") "../src")))
|
||||||
|
%standard-phases)))
|
||||||
(home-page "http://inkscape.org/")
|
(home-page "http://inkscape.org/")
|
||||||
(synopsis "Vector graphics editor")
|
(synopsis "Vector graphics editor")
|
||||||
(description "Inkscape is a vector graphics editor. What sets Inkscape
|
(description "Inkscape is a vector graphics editor. What sets Inkscape
|
||||||
|
|
|
@ -1,13 +0,0 @@
|
||||||
This is verbatim from Upstream: http://bazaar.launchpad.net/~inkscape.dev/inkscape/RELEASE_0_48_BRANCH/diff/9943
|
|
||||||
--- a/src/widgets/desktop-widget.h 2011-06-06 06:43:00 +0000
|
|
||||||
+++ b/src/widgets/desktop-widget.h 2013-01-05 14:34:09 +0000
|
|
||||||
@@ -239,7 +239,7 @@
|
|
||||||
private:
|
|
||||||
GtkWidget *tool_toolbox;
|
|
||||||
GtkWidget *aux_toolbox;
|
|
||||||
- GtkWidget *commands_toolbox,;
|
|
||||||
+ GtkWidget *commands_toolbox;
|
|
||||||
GtkWidget *snap_toolbox;
|
|
||||||
|
|
||||||
static void init(SPDesktopWidget *widget);
|
|
||||||
|
|
Loading…
Reference in New Issue