gnu: libssh2: Update to 1.9.0.
* gnu/packages/patches/libssh2-fix-build-failure-with-gcrypt.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/ssh.scm (libssh2): Update to 1.9.0. [source](patches): Remove.
This commit is contained in:
parent
2528006581
commit
61f34ae5bb
|
@ -1020,7 +1020,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libsndfile-CVE-2017-8361-8363-8365.patch \
|
||||
%D%/packages/patches/libsndfile-CVE-2017-8362.patch \
|
||||
%D%/packages/patches/libsndfile-CVE-2017-12562.patch \
|
||||
%D%/packages/patches/libssh2-fix-build-failure-with-gcrypt.patch \
|
||||
%D%/packages/patches/libtar-CVE-2013-4420.patch \
|
||||
%D%/packages/patches/libtheora-config-guess.patch \
|
||||
%D%/packages/patches/libtommath-fix-linkage.patch \
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
This fixes a regression introduced in 1.8.0 where libssh2 fails to build
|
||||
with the gcrypt backend.
|
||||
|
||||
Upstream bug URL:
|
||||
|
||||
https://github.com/libssh2/libssh2/issues/150
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://github.com/libssh2/libssh2/commit/ced924b78a40126606797ef57a74066eb3b4b83f
|
||||
|
||||
From ced924b78a40126606797ef57a74066eb3b4b83f Mon Sep 17 00:00:00 2001
|
||||
From: Sergei Trofimovich <siarheit@google.com>
|
||||
Date: Mon, 31 Oct 2016 09:04:33 +0000
|
||||
Subject: [PATCH] acinclude.m4: fix ./configure --with-libgcrypt
|
||||
|
||||
diff --git a/acinclude.m4 b/acinclude.m4
|
||||
index 734ef07..c78260c 100644
|
||||
--- a/acinclude.m4
|
||||
+++ b/acinclude.m4
|
||||
@@ -412,9 +412,9 @@ AC_DEFUN([LIBSSH2_CHECKFOR_GCRYPT], [
|
||||
|
||||
old_LDFLAGS=$LDFLAGS
|
||||
old_CFLAGS=$CFLAGS
|
||||
- if test -n "$use_libgcrypt" && test "$use_libgcrypt" != "no"; then
|
||||
- LDFLAGS="$LDFLAGS -L$use_libgcrypt/lib"
|
||||
- CFLAGS="$CFLAGS -I$use_libgcrypt/include"
|
||||
+ if test -n "$with_libgcrypt_prefix" && test "$use_libgcrypt" != "no"; then
|
||||
+ LDFLAGS="$LDFLAGS -L$with_libgcrypt_prefix/lib"
|
||||
+ CFLAGS="$CFLAGS -I$with_libgcrypt_prefix/include"
|
||||
fi
|
||||
AC_LIB_HAVE_LINKFLAGS([gcrypt], [], [
|
||||
#include <gcrypt.h>
|
|
@ -111,7 +111,7 @@ applications.")
|
|||
(define-public libssh2
|
||||
(package
|
||||
(name "libssh2")
|
||||
(version "1.8.2")
|
||||
(version "1.9.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -119,21 +119,13 @@ applications.")
|
|||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0rqd37pc80nm2pz4sa2m9pfc48axys7jwq1l7z0vii5nyvchg0q8"))
|
||||
(patches
|
||||
(search-patches "libssh2-fix-build-failure-with-gcrypt.patch"))))
|
||||
"1zfsz9nldakfz61d2j70pk29zlmj7w2vv46s9l3x2prhcgaqpyym"))))
|
||||
(build-system gnu-build-system)
|
||||
;; The installed libssh2.pc file does not include paths to libgcrypt and
|
||||
;; zlib libraries, so we need to propagate the inputs.
|
||||
(propagated-inputs `(("libgcrypt" ,libgcrypt)
|
||||
("zlib" ,zlib)))
|
||||
(arguments `(#:configure-flags `("--with-libgcrypt")
|
||||
#:phases (modify-phases %standard-phases
|
||||
(replace 'bootstrap
|
||||
(lambda _
|
||||
(invoke "autoreconf" "-v"))))))
|
||||
(native-inputs `(("autoconf" ,autoconf)
|
||||
("automake" ,automake)))
|
||||
(arguments `(#:configure-flags `("--with-libgcrypt")))
|
||||
(synopsis "Client-side C library implementing the SSH2 protocol")
|
||||
(description
|
||||
"libssh2 is a library intended to allow software developers access to
|
||||
|
|
Loading…
Reference in New Issue