gnu: zathura: Fix plugin path regression.

eb6a5dab5c (gnu: zathura: Update to 0.3.9)
silently broke Zathura's (Guix-specific) ZATHURA_PLUGIN_PATH mechanism.

My environment was so filthy that all happened to work just fine, but as
usual Marius was right and the patch needed tweaking.

* gnu/packages/patches/zathura-plugindir-environment-variable.patch:
Tweak.
master
Tobias Geerinckx-Rice 2018-06-18 01:23:43 +02:00
parent 3b6ba18bab
commit 6321610d41
No known key found for this signature in database
GPG Key ID: 0DB0FF884F556D79
1 changed files with 4 additions and 7 deletions

View File

@ -8,15 +8,15 @@ different file formats) called ZATHURA_PLUGIN_PATH. Command line option
-p still takes precedence.
Patch by Paul van der Walt <paul@denknerd.org>
Adjusted for Zathura 0.3.9 by Tobias Geerinckx-Rice <me@tobias.gr>
---
zathura/zathura.c | 7 +++++++
1 file changed, 7 insertions(+)
diff --git a/zathura/zathura.c b/zathura/zathura.c
index 589dd28..375ec54 100644
--- a/zathura/zathura.c
+++ b/zathura/zathura.c
@@ -413,6 +413,13 @@ zathura_set_plugin_dir(zathura_t* zathura, const char* dir)
@@ -597,6 +597,13 @@ zathura_set_plugin_dir(zathura_t* zathura, const char* dir)
g_return_if_fail(zathura != NULL);
g_return_if_fail(zathura->plugins.manager != NULL);
@ -28,8 +28,5 @@ index 589dd28..375ec54 100644
+ dir = g_getenv("ZATHURA_PLUGIN_PATH");
+
if (dir != NULL) {
girara_list_t* paths = girara_split_path_array(dir);
GIRARA_LIST_FOREACH(paths, char*, iter, path)
--
2.3.1
set_plugin_dir(zathura, dir);
#ifdef ZATHURA_PLUGINDIR