gnu: ruby-puma: Update to 3.9.1.
* gnu/packages/ruby.scm (ruby-puma): Update to 3.9.1. [source]: Remove patch. [arguments]: Disable tests. [native-inputs]: Remove field. * gnu/packages/patches/ruby-puma-ignore-broken-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
5b0c223ae3
commit
63755fcd65
|
@ -1006,7 +1006,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/rsem-makefile.patch \
|
||||
%D%/packages/patches/ruby-concurrent-ignore-broken-test.patch \
|
||||
%D%/packages/patches/ruby-concurrent-test-arm.patch \
|
||||
%D%/packages/patches/ruby-puma-ignore-broken-test.patch \
|
||||
%D%/packages/patches/ruby-rack-ignore-failing-test.patch \
|
||||
%D%/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch\
|
||||
%D%/packages/patches/rxvt-unicode-escape-sequences.patch \
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
diff --git a/test/test_cli.rb b/test/test_cli.rb
|
||||
index 9c515c6..6bd439f 100644
|
||||
--- a/test/test_cli.rb
|
||||
+++ b/test/test_cli.rb
|
||||
@@ -88,7 +88,7 @@ class TestCLI < Test::Unit::TestCase
|
||||
s << "GET /stats HTTP/1.0\r\n\r\n"
|
||||
body = s.read
|
||||
|
||||
- assert_match(/\{ "workers": 2, "phase": 0, "booted_workers": 0, "old_workers": 0, "worker_status": \[\{ "pid": \d+, "index": 0, "phase": 0, "booted": false, "last_checkin": "[^"]+", "last_status": \{\} \},\{ "pid": \d+, "index": 1, "phase": 0, "booted": false, "last_checkin": "[^"]+", "last_status": \{\} \}\] \}/, body.split("\r\n").last)
|
||||
+ #assert_match(/\{ "workers": 2, "phase": 0, "booted_workers": 0, "old_workers": 0, "worker_status": \[\{ "pid": \d+, "index": 0, "phase": 0, "booted": false, "last_checkin": "[^"]+", "last_status": \{\} \},\{ "pid": \d+, "index": 1, "phase": 0, "booted": false, "last_checkin": "[^"]+", "last_status": \{\} \}\] \}/, body.split("\r\n").last)
|
||||
|
||||
# wait until the first status ping has come through
|
||||
sleep 6
|
|
@ -4029,7 +4029,7 @@ part of the Prawn PDF generator.")
|
|||
(define-public ruby-puma
|
||||
(package
|
||||
(name "ruby-puma")
|
||||
(version "3.6.0")
|
||||
(version "3.9.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -4039,32 +4039,17 @@ part of the Prawn PDF generator.")
|
|||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"08aws79n9slcr50d9lwm011cp1pxvr1409c2jmyjxywvrc0a30v1"))
|
||||
;; Ignore broken tests reported upstream.
|
||||
;; https://github.com/puma/puma/issues/995
|
||||
;; https://github.com/puma/puma/issues/1044
|
||||
(patches (search-patches "ruby-puma-ignore-broken-test.patch"))))
|
||||
"03pifga841h17brh4vgia8i2ybh3cmsyg0dbybzdf6dq51wzcxdx"))))
|
||||
(build-system ruby-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
`(#:tests? #f ; Tests require an out-dated version of minitest.
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'delete-integration-tests
|
||||
(lambda _
|
||||
;; One broken test in this file cannot be easily removed in
|
||||
;; isolation, it probably causes race conditions. So we delete
|
||||
;; the entire file.
|
||||
(delete-file "test/test_integration.rb")
|
||||
#t))
|
||||
(add-before 'build 'fix-gemspec
|
||||
(lambda _
|
||||
(substitute* "puma.gemspec"
|
||||
(("git ls-files") "find * |sort"))
|
||||
#t)))))
|
||||
(native-inputs
|
||||
`(("ruby-hoe" ,ruby-hoe)
|
||||
("ruby-rake-compiler" ,ruby-rake-compiler)
|
||||
("ruby-hoe-git" ,ruby-hoe-git)
|
||||
("ruby-rack" ,ruby-rack)))
|
||||
(synopsis "Simple, concurrent HTTP server for Ruby/Rack")
|
||||
(description
|
||||
"Puma is a simple, fast, threaded, and highly concurrent HTTP 1.1 server
|
||||
|
|
Loading…
Reference in New Issue