gnu: ruby-yard: Update to 0.9.6.

* gnu/packages/ruby.scm (ruby-yard): Update to 0.9.6.
[source]: Use 'GitHub' source.
[arguments]: Run tests without 'Rakefile'.
[native-inputs]: Replace 'ruby-rspec-2' with ruby-rspec'.
* gnu/packages/patches/ruby-yard-fix-skip-of-markdown-tests.patch: Delete
file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Ben Woodcroft 2017-01-08 10:18:41 +10:00
parent 57fe28a082
commit 6499893ef8
No known key found for this signature in database
GPG Key ID: 2A6AD9F4AAC20DF6
3 changed files with 31 additions and 53 deletions

View File

@ -844,7 +844,6 @@ dist_patch_DATA = \
%D%/packages/patches/ruby-puma-ignore-broken-test.patch \ %D%/packages/patches/ruby-puma-ignore-broken-test.patch \
%D%/packages/patches/ruby-rack-ignore-failing-test.patch \ %D%/packages/patches/ruby-rack-ignore-failing-test.patch \
%D%/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch\ %D%/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch\
%D%/packages/patches/ruby-yard-fix-skip-of-markdown-tests.patch \
%D%/packages/patches/sed-hurd-path-max.patch \ %D%/packages/patches/sed-hurd-path-max.patch \
%D%/packages/patches/scheme48-tests.patch \ %D%/packages/patches/scheme48-tests.patch \
%D%/packages/patches/scotch-test-threading.patch \ %D%/packages/patches/scotch-test-threading.patch \

View File

@ -1,17 +0,0 @@
The tests currently fail due to use of 'skip' rather than 'pending' to skip a
test usually not skipped by upstream. This patch has been proposed upstream
at https://github.com/lsegal/yard/pull/1033
diff --git a/spec/templates/helpers/html_helper_spec.rb b/spec/templates/helpers/html_helper_spec.rb
index 84624c3..9c4fc2b 100644
--- a/spec/templates/helpers/html_helper_spec.rb
+++ b/spec/templates/helpers/html_helper_spec.rb
@@ -184,7 +184,7 @@ describe YARD::Templates::Helpers::HtmlHelper do
it "creates tables (markdown specific)" do
log.enter_level(Logger::FATAL) do
unless markup_class(:markdown).to_s == "RedcarpetCompat"
- skip "This test depends on a markdown engine that supports tables"
+ pending "This test depends on a markdown engine that supports tables"
end
end

View File

@ -3049,35 +3049,31 @@ features such as filtering and fine grained logging.")
(license license:expat))) (license license:expat)))
(define-public ruby-yard (define-public ruby-yard
;; Use git reference because gem is >100 commits out of date and the tests
;; do not pass with the released gem.
(let ((commit "d816482a0d4850506c3bcccc9434550c536c28c6"))
(package (package
(name "ruby-yard") (name "ruby-yard")
(version (string-append "0.9.5-1." (string-take commit 8))) (version "0.9.6")
(source (source
(origin (origin
(method git-fetch) (method url-fetch)
(uri (git-reference ;; Tests do not pass if we build from the distributed gem.
(url "https://github.com/lsegal/yard.git") (uri (string-append "https://github.com/lsegal/yard/archive/v"
(commit commit))) version "tar.gz"))
(file-name (string-append name "-" version "-checkout")) (file-name (string-append name "-" version ".tar.gz"))
(sha256 (sha256
(base32 (base32
"1j16c85x22if7y0fzi3c900p9wzkx2riq1y7vsj92a0zvwsxai4i")) "0rsz4bghgx7fryzyhlz8wlnd2m9xgyvf1xhrq58mnzfrrfm41bdg"))))
(patches (search-patches "ruby-yard-fix-skip-of-markdown-tests.patch"))))
(build-system ruby-build-system) (build-system ruby-build-system)
(arguments (arguments
`(#:test-target "spec" `(#:phases
#:phases
(modify-phases %standard-phases (modify-phases %standard-phases
(add-before 'check 'set-HOME-and-disable-failing-test (replace 'check
(lambda _ (lambda _
;; $HOME needs to be set to somewhere writeable for tests to run ;; $HOME needs to be set to somewhere writeable for tests to run
(setenv "HOME" "/tmp") (setenv "HOME" "/tmp")
#t))))) ;; Run tests without using 'rake' to avoid dependencies.
(zero? (system* "rspec")))))))
(native-inputs (native-inputs
`(("ruby-rspec" ,ruby-rspec-2) `(("ruby-rspec" ,ruby-rspec)
("ruby-rack" ,ruby-rack))) ("ruby-rack" ,ruby-rack)))
(synopsis "Documentation generation tool for Ruby") (synopsis "Documentation generation tool for Ruby")
(description (description
@ -3086,7 +3082,7 @@ language. It enables the user to generate consistent, usable documentation
that can be exported to a number of formats very easily, and also supports that can be exported to a number of formats very easily, and also supports
extending for custom Ruby constructs such as custom class level definitions.") extending for custom Ruby constructs such as custom class level definitions.")
(home-page "http://yardoc.org") (home-page "http://yardoc.org")
(license license:expat)))) (license license:expat)))
(define-public ruby-clap (define-public ruby-clap
(package (package