gnu: ruby-yard: Update to 0.9.6.

* gnu/packages/ruby.scm (ruby-yard): Update to 0.9.6.
[source]: Use 'GitHub' source.
[arguments]: Run tests without 'Rakefile'.
[native-inputs]: Replace 'ruby-rspec-2' with ruby-rspec'.
* gnu/packages/patches/ruby-yard-fix-skip-of-markdown-tests.patch: Delete
file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Ben Woodcroft 2017-01-08 10:18:41 +10:00
parent 57fe28a082
commit 6499893ef8
No known key found for this signature in database
GPG Key ID: 2A6AD9F4AAC20DF6
3 changed files with 31 additions and 53 deletions

View File

@ -844,7 +844,6 @@ dist_patch_DATA = \
%D%/packages/patches/ruby-puma-ignore-broken-test.patch \ %D%/packages/patches/ruby-puma-ignore-broken-test.patch \
%D%/packages/patches/ruby-rack-ignore-failing-test.patch \ %D%/packages/patches/ruby-rack-ignore-failing-test.patch \
%D%/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch\ %D%/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch\
%D%/packages/patches/ruby-yard-fix-skip-of-markdown-tests.patch \
%D%/packages/patches/sed-hurd-path-max.patch \ %D%/packages/patches/sed-hurd-path-max.patch \
%D%/packages/patches/scheme48-tests.patch \ %D%/packages/patches/scheme48-tests.patch \
%D%/packages/patches/scotch-test-threading.patch \ %D%/packages/patches/scotch-test-threading.patch \

View File

@ -1,17 +0,0 @@
The tests currently fail due to use of 'skip' rather than 'pending' to skip a
test usually not skipped by upstream. This patch has been proposed upstream
at https://github.com/lsegal/yard/pull/1033
diff --git a/spec/templates/helpers/html_helper_spec.rb b/spec/templates/helpers/html_helper_spec.rb
index 84624c3..9c4fc2b 100644
--- a/spec/templates/helpers/html_helper_spec.rb
+++ b/spec/templates/helpers/html_helper_spec.rb
@@ -184,7 +184,7 @@ describe YARD::Templates::Helpers::HtmlHelper do
it "creates tables (markdown specific)" do
log.enter_level(Logger::FATAL) do
unless markup_class(:markdown).to_s == "RedcarpetCompat"
- skip "This test depends on a markdown engine that supports tables"
+ pending "This test depends on a markdown engine that supports tables"
end
end

View File

@ -3049,44 +3049,40 @@ features such as filtering and fine grained logging.")
(license license:expat))) (license license:expat)))
(define-public ruby-yard (define-public ruby-yard
;; Use git reference because gem is >100 commits out of date and the tests (package
;; do not pass with the released gem. (name "ruby-yard")
(let ((commit "d816482a0d4850506c3bcccc9434550c536c28c6")) (version "0.9.6")
(package (source
(name "ruby-yard") (origin
(version (string-append "0.9.5-1." (string-take commit 8))) (method url-fetch)
(source ;; Tests do not pass if we build from the distributed gem.
(origin (uri (string-append "https://github.com/lsegal/yard/archive/v"
(method git-fetch) version "tar.gz"))
(uri (git-reference (file-name (string-append name "-" version ".tar.gz"))
(url "https://github.com/lsegal/yard.git") (sha256
(commit commit))) (base32
(file-name (string-append name "-" version "-checkout")) "0rsz4bghgx7fryzyhlz8wlnd2m9xgyvf1xhrq58mnzfrrfm41bdg"))))
(sha256 (build-system ruby-build-system)
(base32 (arguments
"1j16c85x22if7y0fzi3c900p9wzkx2riq1y7vsj92a0zvwsxai4i")) `(#:phases
(patches (search-patches "ruby-yard-fix-skip-of-markdown-tests.patch")))) (modify-phases %standard-phases
(build-system ruby-build-system) (replace 'check
(arguments (lambda _
`(#:test-target "spec" ;; $HOME needs to be set to somewhere writeable for tests to run
#:phases (setenv "HOME" "/tmp")
(modify-phases %standard-phases ;; Run tests without using 'rake' to avoid dependencies.
(add-before 'check 'set-HOME-and-disable-failing-test (zero? (system* "rspec")))))))
(lambda _ (native-inputs
;; $HOME needs to be set to somewhere writeable for tests to run `(("ruby-rspec" ,ruby-rspec)
(setenv "HOME" "/tmp") ("ruby-rack" ,ruby-rack)))
#t))))) (synopsis "Documentation generation tool for Ruby")
(native-inputs (description
`(("ruby-rspec" ,ruby-rspec-2) "YARD is a documentation generation tool for the Ruby programming
("ruby-rack" ,ruby-rack)))
(synopsis "Documentation generation tool for Ruby")
(description
"YARD is a documentation generation tool for the Ruby programming
language. It enables the user to generate consistent, usable documentation language. It enables the user to generate consistent, usable documentation
that can be exported to a number of formats very easily, and also supports that can be exported to a number of formats very easily, and also supports
extending for custom Ruby constructs such as custom class level definitions.") extending for custom Ruby constructs such as custom class level definitions.")
(home-page "http://yardoc.org") (home-page "http://yardoc.org")
(license license:expat)))) (license license:expat)))
(define-public ruby-clap (define-public ruby-clap
(package (package