gnu: glib-networking: Update to 2.58.0.
* gnu/packages/gnome.scm (glib-networking): Update to 2.58.0. [build-system]: Change to MESON-BUILD-SYSTEM. [arguments]: Explicitly disable libproxy; add phase to appease tests. (libgdata, libsoup)[arguments]: Remove phase that sets SSL_CERT_FILE. * gnu/packages/spice.scm (spice)[arguments]: Likewise. * gnu/packages/web.scm (uhttpmock)[arguments]: Likewise.
This commit is contained in:
parent
f06fdbae8d
commit
6521155212
|
@ -741,7 +741,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/ghostscript-no-header-uuid.patch \
|
||||
%D%/packages/patches/ghostscript-no-header-creationdate.patch \
|
||||
%D%/packages/patches/giflib-make-reallocarray-private.patch \
|
||||
%D%/packages/patches/glib-networking-ssl-cert-file.patch \
|
||||
%D%/packages/patches/glib-tests-timer.patch \
|
||||
%D%/packages/patches/glibc-CVE-2015-5180.patch \
|
||||
%D%/packages/patches/glibc-CVE-2015-7547.patch \
|
||||
|
|
|
@ -360,12 +360,6 @@ formats like PNG, SVG, PDF and EPS.")
|
|||
(arguments
|
||||
'(#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-before 'check 'use-empty-ssl-cert-file
|
||||
(lambda _
|
||||
;; The ca-certificates.crt is not available in the build
|
||||
;; environment.
|
||||
(setenv "SSL_CERT_FILE" "/dev/null")
|
||||
#t))
|
||||
(add-before 'check 'disable-failing-tests
|
||||
(lambda _
|
||||
;; The PicasaWeb API tests fail with gnome-online-accounts@3.24.2.
|
||||
|
@ -2396,7 +2390,7 @@ library.")
|
|||
(define-public glib-networking
|
||||
(package
|
||||
(name "glib-networking")
|
||||
(version "2.54.1")
|
||||
(version "2.58.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnome/sources/glib-networking/"
|
||||
|
@ -2404,29 +2398,17 @@ library.")
|
|||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0bq16m9nh3gcz9x2fvygr0iwxd2pxcbrm3lj3kihsnh1afv8g9za"))
|
||||
(patches
|
||||
(search-patches "glib-networking-ssl-cert-file.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
"0s006gs9nsq6mg31spqha1jffzmp6qjh10y27h0fxf1iw1ah5ymx"))))
|
||||
(build-system meson-build-system)
|
||||
(arguments
|
||||
`(#:configure-flags
|
||||
'("--with-ca-certificates=/etc/ssl/certs/ca-certificates.crt")
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-before 'configure 'patch-giomoduledir
|
||||
;; Install GIO modules into $out/lib/gio/modules.
|
||||
(lambda _
|
||||
(substitute* "configure"
|
||||
(("GIO_MODULE_DIR=.*")
|
||||
(string-append "GIO_MODULE_DIR=" %output
|
||||
"/lib/gio/modules\n")))
|
||||
#t))
|
||||
(add-before 'check 'use-empty-ssl-cert-file
|
||||
(lambda _
|
||||
;; The ca-certificates.crt is not available in the build
|
||||
;; environment.
|
||||
(setenv "SSL_CERT_FILE" "/dev/null")
|
||||
#t)))))
|
||||
`(#:configure-flags '("-Dlibproxy_support=false")
|
||||
#:phases (modify-phases %standard-phases
|
||||
(add-before 'check 'disable-TLSv1.3
|
||||
(lambda _
|
||||
;; XXX: One test fails when TLS 1.3 is enabled, fixed in 2.60.0:
|
||||
;; <https://gitlab.com/gnutls/gnutls/issues/615>.
|
||||
(setenv "G_TLS_GNUTLS_PRIORITY" "NORMAL:-VERS-TLS1.3")
|
||||
#t)))))
|
||||
(native-inputs
|
||||
`(("pkg-config" ,pkg-config)
|
||||
("intltool" ,intltool)))
|
||||
|
@ -2516,9 +2498,6 @@ libxml to ease remote use of the RESTful API.")
|
|||
;; The 'check-local' target runs 'env LANG=C sort -u',
|
||||
;; unset 'LC_ALL' to make 'LANG' working.
|
||||
(unsetenv "LC_ALL")
|
||||
;; The ca-certificates.crt is not available in the build
|
||||
;; environment.
|
||||
(setenv "SSL_CERT_FILE" "/dev/null")
|
||||
;; HTTPD in Guix uses mod_event and does not build prefork.
|
||||
(substitute* "tests/httpd.conf"
|
||||
(("^LoadModule mpm_prefork_module.*$") "\n"))
|
||||
|
|
|
@ -1,29 +0,0 @@
|
|||
From b010e41346d418220582c20ab8d7f3971e4fb78a Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@gmail.com>
|
||||
Date: Fri, 14 Aug 2015 17:28:36 +0800
|
||||
Subject: [PATCH] gnutls: Allow overriding the anchor file location by
|
||||
'SSL_CERT_FILE'
|
||||
|
||||
---
|
||||
tls/gnutls/gtlsbackend-gnutls.c | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tls/gnutls/gtlsbackend-gnutls.c b/tls/gnutls/gtlsbackend-gnutls.c
|
||||
index 55ec1a5..217d3c8 100644
|
||||
--- a/tls/gnutls/gtlsbackend-gnutls.c
|
||||
+++ b/tls/gnutls/gtlsbackend-gnutls.c
|
||||
@@ -101,8 +101,10 @@ g_tls_backend_gnutls_real_create_database (GTlsBackendGnutls *self,
|
||||
GError **error)
|
||||
{
|
||||
const gchar *anchor_file = NULL;
|
||||
+ anchor_file = g_getenv ("SSL_CERT_FILE");
|
||||
#ifdef GTLS_SYSTEM_CA_FILE
|
||||
- anchor_file = GTLS_SYSTEM_CA_FILE;
|
||||
+ if (!anchor_file)
|
||||
+ anchor_file = GTLS_SYSTEM_CA_FILE;
|
||||
#endif
|
||||
return g_tls_file_database_new (anchor_file, error);
|
||||
}
|
||||
--
|
||||
2.4.3
|
||||
|
|
@ -213,11 +213,7 @@ which allows users to view a desktop computing environment.")
|
|||
"--enable-automated-tests")
|
||||
|
||||
;; Several tests appear to be opening the same sockets concurrently.
|
||||
#:parallel-tests? #f
|
||||
|
||||
#:phases (modify-phases %standard-phases
|
||||
(add-before 'check 'use-empty-ssl-cert-file
|
||||
(lambda _ (setenv "SSL_CERT_FILE" "/dev/null") #t)))))
|
||||
#:parallel-tests? #f))
|
||||
(synopsis "Server implementation of the SPICE protocol")
|
||||
(description "SPICE is a remote display system built for virtual
|
||||
environments which allows you to view a computing 'desktop' environment
|
||||
|
|
|
@ -4243,15 +4243,6 @@ you'd expect.")
|
|||
(base32
|
||||
"163py4klka423x7li2b685gmg3a6hjf074mlff2ajhmi3l0lm8x6"))))
|
||||
(build-system glib-or-gtk-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-before 'check 'use-empty-ssl-cert-file
|
||||
(lambda _
|
||||
;; Search for ca-certificates.crt files
|
||||
;; during the check phase.
|
||||
(setenv "SSL_CERT_FILE" "/dev/null")
|
||||
#t)))))
|
||||
(native-inputs
|
||||
`(("gobject-introspection" ,gobject-introspection)
|
||||
;; For check phase.
|
||||
|
|
Loading…
Reference in New Issue