gnu: Add python-slugify.
* gnu/packages/python-web.scm (python-slugify): New variable. * gnu/packages/patches/python-slugify-depend-on-unidecode.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
e41ba8606f
commit
6543bc80b4
|
@ -1231,6 +1231,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/python2-pygobject-2-gi-info-type-error-domain.patch \
|
%D%/packages/patches/python2-pygobject-2-gi-info-type-error-domain.patch \
|
||||||
%D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch \
|
%D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch \
|
||||||
%D%/packages/patches/python-robotframework-honor-source-date-epoch.patch \
|
%D%/packages/patches/python-robotframework-honor-source-date-epoch.patch \
|
||||||
|
%D%/packages/patches/python-slugify-depend-on-unidecode.patch \
|
||||||
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
|
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
|
||||||
%D%/packages/patches/python-unittest2-python3-compat.patch \
|
%D%/packages/patches/python-unittest2-python3-compat.patch \
|
||||||
%D%/packages/patches/python-unittest2-remove-argparse.patch \
|
%D%/packages/patches/python-unittest2-remove-argparse.patch \
|
||||||
|
|
|
@ -0,0 +1,22 @@
|
||||||
|
diff --git a/setup.py b/setup.py
|
||||||
|
index 4800173..6bdd77f 100755
|
||||||
|
--- a/setup.py
|
||||||
|
+++ b/setup.py
|
||||||
|
@@ -14,8 +14,7 @@ url = 'https://github.com/un33k/python-slugify'
|
||||||
|
author = 'Val Neekman'
|
||||||
|
author_email = 'info@neekware.com'
|
||||||
|
license = 'MIT'
|
||||||
|
-install_requires = ['text-unidecode==1.2']
|
||||||
|
-extras_require = {'unidecode': ['Unidecode==1.0.23']}
|
||||||
|
+install_requires = ['Unidecode']
|
||||||
|
|
||||||
|
classifiers = [
|
||||||
|
'Development Status :: 5 - Production/Stable',
|
||||||
|
@@ -67,7 +66,6 @@ setup(
|
||||||
|
author_email=author_email,
|
||||||
|
packages=find_packages(exclude=EXCLUDE_FROM_PACKAGES),
|
||||||
|
install_requires=install_requires,
|
||||||
|
- extras_require=extras_require,
|
||||||
|
classifiers=classifiers,
|
||||||
|
entry_points={'console_scripts': ['slugify=slugify.slugify:main']},
|
||||||
|
)
|
|
@ -29,6 +29,7 @@
|
||||||
;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
||||||
;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
|
;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
|
||||||
;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
|
;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
|
||||||
|
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -3165,3 +3166,33 @@ Python.")
|
||||||
(propagated-inputs
|
(propagated-inputs
|
||||||
`(("python-gevent" ,python2-gevent)
|
`(("python-gevent" ,python2-gevent)
|
||||||
("python-tornado" ,python2-tornado)))))
|
("python-tornado" ,python2-tornado)))))
|
||||||
|
|
||||||
|
(define-public python-slugify
|
||||||
|
(package
|
||||||
|
(name "python-slugify")
|
||||||
|
(version "3.0.2")
|
||||||
|
(source
|
||||||
|
(origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (pypi-uri "python-slugify" version))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"0n6pfmsq899c54plpvzi46l7zrpa3zfpm8im6h32czjw6kxky5jp"))
|
||||||
|
(patches
|
||||||
|
(search-patches "python-slugify-depend-on-unidecode.patch"))))
|
||||||
|
(native-inputs
|
||||||
|
`(("python-wheel" ,python-wheel)))
|
||||||
|
(propagated-inputs
|
||||||
|
`(("python-unidecode" ,python-unidecode)))
|
||||||
|
(arguments
|
||||||
|
`(#:phases
|
||||||
|
(modify-phases %standard-phases
|
||||||
|
(replace 'check
|
||||||
|
(lambda _
|
||||||
|
(invoke "python" "test.py"))))))
|
||||||
|
(build-system python-build-system)
|
||||||
|
(home-page "https://github.com/un33k/python-slugify")
|
||||||
|
(synopsis "Python Slugify application that handles Unicode")
|
||||||
|
(description "This package provides a @command{slufigy} command and
|
||||||
|
library to create slugs from unicode strings while keeping it DRY.")
|
||||||
|
(license license:expat)))
|
||||||
|
|
Loading…
Reference in New Issue