gnu: Add perl-b-keywords.

* gnu/packages/perl.scm (perl-b-keywords): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
master
Petter 2017-10-25 08:53:26 +02:00 committed by Ricardo Wurmus
parent 2a013d0f09
commit 65f7f60693
No known key found for this signature in database
GPG Key ID: 197A5888235FACAC
1 changed files with 22 additions and 0 deletions

View File

@ -406,6 +406,28 @@ parent.")
compiling the surrounding scope.")
(license (package-license perl))))
(define-public perl-b-keywords
(package
(name "perl-b-keywords")
(version "1.15")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/R/RU/RURBAN/B-Keywords-"
version ".tar.gz"))
(sha256
(base32
"1nhdplmd0y69lnwyajg3anhk6pm13nm6qzm05nzpz8zl7j7fzlk5"))))
(build-system perl-build-system)
(home-page "http://search.cpan.org/dist/B-Keywords/")
(synopsis "Lists of reserved barewords and symbol names")
(description "@code{B::Keywords} supplies several arrays of exportable
keywords: @code{@@Scalars, @@Arrays, @@Hashes, @@Filehandles, @@Symbols,
@@Functions, @@Barewords, @@TieIOMethods, @@UNIVERSALMethods and
@@ExporterSymbols}.")
;; GPLv2 only
(license gpl2)))
(define-public perl-benchmark-timer
(package
(name "perl-benchmark-timer")