gnu: openssh: Fix CVE-2015-8325.
* gnu/packages/patches/openssh-CVE-2015-8325.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/ssh.scm (openssh): Use it.
This commit is contained in:
parent
a7d94b54c7
commit
67157996e2
|
@ -633,6 +633,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/openimageio-boost-1.60.patch \
|
||||
gnu/packages/patches/openjpeg-CVE-2015-6581.patch \
|
||||
gnu/packages/patches/openjpeg-use-after-free-fix.patch \
|
||||
gnu/packages/patches/openssh-CVE-2015-8325.patch \
|
||||
gnu/packages/patches/openssl-runpath.patch \
|
||||
gnu/packages/patches/openssl-c-rehash-in.patch \
|
||||
gnu/packages/patches/orpheus-cast-errors-and-includes.patch \
|
||||
|
|
|
@ -0,0 +1,31 @@
|
|||
From 85bdcd7c92fe7ff133bbc4e10a65c91810f88755 Mon Sep 17 00:00:00 2001
|
||||
From: Damien Miller <djm@mindrot.org>
|
||||
Date: Wed, 13 Apr 2016 10:39:57 +1000
|
||||
Subject: ignore PAM environment vars when UseLogin=yes
|
||||
|
||||
If PAM is configured to read user-specified environment variables
|
||||
and UseLogin=yes in sshd_config, then a hostile local user may
|
||||
attack /bin/login via LD_PRELOAD or similar environment variables
|
||||
set via PAM.
|
||||
|
||||
CVE-2015-8325, found by Shayan Sadigh, via Colin Watson
|
||||
---
|
||||
session.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/session.c b/session.c
|
||||
index 4859245..4653b09 100644
|
||||
--- a/session.c
|
||||
+++ b/session.c
|
||||
@@ -1322,7 +1322,7 @@ do_setup_env(Session *s, const char *shell)
|
||||
* Pull in any environment variables that may have
|
||||
* been set by PAM.
|
||||
*/
|
||||
- if (options.use_pam) {
|
||||
+ if (options.use_pam && !options.use_login) {
|
||||
char **p;
|
||||
|
||||
p = fetch_pam_child_environment();
|
||||
--
|
||||
cgit v0.11.2
|
||||
|
|
@ -126,7 +126,8 @@ a server that supports the SSH-2 protocol.")
|
|||
(string-append "http://ftp2.fr.openbsd.org/pub/OpenBSD/OpenSSH/portable/"
|
||||
tail))))
|
||||
(sha256 (base32
|
||||
"132lh9aanb0wkisji1d6cmsxi520m8nh7c7i9wi6m1s3l38q29x7"))))
|
||||
"132lh9aanb0wkisji1d6cmsxi520m8nh7c7i9wi6m1s3l38q29x7"))
|
||||
(patches (search-patches "openssh-CVE-2015-8325.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("groff" ,groff)
|
||||
("openssl" ,openssl)
|
||||
|
|
Loading…
Reference in New Issue