gnu: bluez: Update to 5.35, fix test.
* gnu/packages/patches/bluez-tests.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/linux.scm (bluez): Update to 5.35. [source]: Add patch.
This commit is contained in:
parent
26909789d0
commit
6747de140d
|
@ -411,6 +411,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/binutils-ld-new-dtags.patch \
|
||||
gnu/packages/patches/binutils-loongson-workaround.patch \
|
||||
gnu/packages/patches/bitlbee-configure-doc-fix.patch \
|
||||
gnu/packages/patches/bluez-tests.patch \
|
||||
gnu/packages/patches/boost-mips-avoid-m32.patch \
|
||||
gnu/packages/patches/calibre-drop-unrar.patch \
|
||||
gnu/packages/patches/calibre-no-updates-dialog.patch \
|
||||
|
|
|
@ -2315,7 +2315,7 @@ applications.")
|
|||
(define-public bluez
|
||||
(package
|
||||
(name "bluez")
|
||||
(version "5.30")
|
||||
(version "5.35")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -2323,7 +2323,9 @@ applications.")
|
|||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0b1qbnq1xzcdw5rajg9yyg31bf21jnff0n6gnf1snz89bbdllfhy"))))
|
||||
"1qphz25hganfnd5ipfscbj7s70anv5favmwqmi9ig2saciaf1zhs"))
|
||||
(patches
|
||||
(list (search-patch "bluez-tests.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:configure-flags
|
||||
|
|
|
@ -0,0 +1,25 @@
|
|||
From 484ad8c9263bb524051a999ce19a994960e69572 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@gmail.com>
|
||||
Date: Fri, 23 Oct 2015 20:48:57 +0800
|
||||
Subject: [PATCH] unit/test-gobex-header: Fix duplicate test names
|
||||
|
||||
---
|
||||
unit/test-gobex-header.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/unit/test-gobex-header.c b/unit/test-gobex-header.c
|
||||
index 6f49312..8705892 100644
|
||||
--- a/unit/test-gobex-header.c
|
||||
+++ b/unit/test-gobex-header.c
|
||||
@@ -554,7 +554,7 @@ int main(int argc, char *argv[])
|
||||
test_header_encode_name_umlaut);
|
||||
g_test_add_func("/gobex/test_header_encode_body",
|
||||
test_header_encode_body);
|
||||
- g_test_add_func("/gobex/test_header_encode_connid",
|
||||
+ g_test_add_func("/gobex/test_header_encode_actionid",
|
||||
test_header_encode_actionid);
|
||||
g_test_add_func("/gobex/test_header_encode_apparam",
|
||||
test_header_encode_apparam);
|
||||
--
|
||||
2.5.0
|
||||
|
Loading…
Reference in New Issue