gnu: cool-retro-term: Upgrade to 1.1.1.

* gnu/packages/terminals.scm (cool-retro-term)[source]: Upgrade to 1.1.1.
Remove patches.  Adjust filtering in snippet for added/removed fonts.
[arguments]: Return #t in 'add-alternate-name' phase.
* gnu/packages/patches/cool-retro-term-dont-check-uninit-member.patch,
  gnu/packages/patches/cool-retro-term-fix-array-size.patch,
  gnu/packages/patches/cool-retro-term-memory-leak-1.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Remove them.
master
Eric Bavier 2019-02-09 00:45:47 -06:00
parent 41313acebf
commit 68a116bd56
No known key found for this signature in database
GPG Key ID: FD73CAC719D32566
5 changed files with 10 additions and 107 deletions

View File

@ -696,9 +696,6 @@ dist_patch_DATA = \
%D%/packages/patches/coda-use-system-libs.patch \
%D%/packages/patches/combinatorial-blas-awpm.patch \
%D%/packages/patches/combinatorial-blas-io-fix.patch \
%D%/packages/patches/cool-retro-term-dont-check-uninit-member.patch \
%D%/packages/patches/cool-retro-term-fix-array-size.patch \
%D%/packages/patches/cool-retro-term-memory-leak-1.patch \
%D%/packages/patches/cpio-CVE-2016-2037.patch \
%D%/packages/patches/cpufrequtils-fix-aclocal.patch \
%D%/packages/patches/cracklib-CVE-2016-6318.patch \

View File

@ -1,33 +0,0 @@
From 126a97d1f22f7d784d392b2b7d5aadf0a4e18c0d Mon Sep 17 00:00:00 2001
From: Petter <petter@mykolab.ch>
Date: Thu, 27 Apr 2017 20:28:02 +0200
Subject: [PATCH] Avoid checking uninitialized member + simplify condition
---
qmltermwidget/lib/TerminalDisplay.cpp | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/qmltermwidget/lib/TerminalDisplay.cpp b/qmltermwidget/lib/TerminalDisplay.cpp
index 189a609..36d2cd2 100644
--- a/qmltermwidget/lib/TerminalDisplay.cpp
+++ b/qmltermwidget/lib/TerminalDisplay.cpp
@@ -325,6 +325,7 @@ TerminalDisplay::TerminalDisplay(QQuickItem *parent)
,_terminalSizeHint(false)
,_terminalSizeStartup(true)
,_bidiEnabled(false)
+,_mouseMarks(false)
,_actSel(0)
,_wordSelectionMode(false)
,_lineSelectionMode(false)
@@ -1846,7 +1847,7 @@ void TerminalDisplay::mousePressEvent(QMouseEvent* ev)
}
else if ( ev->button() == Qt::MidButton )
{
- if ( _mouseMarks || (!_mouseMarks && (ev->modifiers() & Qt::ShiftModifier)) )
+ if ( _mouseMarks || (ev->modifiers() & Qt::ShiftModifier) )
emitSelection(true,ev->modifiers() & Qt::ControlModifier);
else
emit mouseSignal( 1, charColumn +1, charLine +1 +_scrollBar->value() -_scrollBar->maximum() , 0);
--
2.12.2

View File

@ -1,25 +0,0 @@
From c91d7ae5dbb00c8392a9f93283dc56c3e296cccd Mon Sep 17 00:00:00 2001
From: Petter <petter@mykolab.ch>
Date: Thu, 27 Apr 2017 20:19:21 +0200
Subject: [PATCH] Fix size of the array passed to memset()
---
qmltermwidget/lib/History.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/qmltermwidget/lib/History.cpp b/qmltermwidget/lib/History.cpp
index 0f9c13f..ab6f7be 100644
--- a/qmltermwidget/lib/History.cpp
+++ b/qmltermwidget/lib/History.cpp
@@ -515,7 +515,7 @@ void HistoryScrollBlockArray::addCells(const Character a[], int count)
// put cells in block's data
assert((count * sizeof(Character)) < ENTRIES);
- memset(b->data, 0, ENTRIES);
+ memset(b->data, 0, sizeof(b->data));
memcpy(b->data, a, count * sizeof(Character));
b->size = count * sizeof(Character);
--
2.12.2

View File

@ -1,32 +0,0 @@
From 08628fda19128b75248548357e416bc373f14f91 Mon Sep 17 00:00:00 2001
From: Yen Chi Hsuan <yan12125@gmail.com>
Date: Sat, 18 Mar 2017 02:50:34 +0800
Subject: [PATCH] Fix memory leak in hotspot (URLs & emails) detection
---
qmltermwidget/lib/Filter.cpp | 2 ++
1 file changed, 2 insertions(+)
diff --git a/qmltermwidget/lib/Filter.cpp b/qmltermwidget/lib/Filter.cpp
index 5ca7bee..2e8d2fb 100644
--- a/qmltermwidget/lib/Filter.cpp
+++ b/qmltermwidget/lib/Filter.cpp
@@ -26,6 +26,7 @@
// Qt
#include <QAction>
#include <QApplication>
+#include <QtAlgorithms>
#include <QClipboard>
#include <QString>
#include <QTextStream>
@@ -194,6 +195,7 @@ Filter::~Filter()
}
void Filter::reset()
{
+ qDeleteAll(_hotspotList);
_hotspots.clear();
_hotspotList.clear();
}
--
2.12.2

View File

@ -13,6 +13,7 @@
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018, 2019 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@ -472,11 +473,11 @@ embedded kernel situations.")
(license license:expat)))
(define-public cool-retro-term
(let ((commit "dd799cf5c0eda92cf44f3938c0c2dcae5651a99e")
(revision "1"))
(let ((commit "1.1.1")
(revision "0")) ;not used currently
(package
(name "cool-retro-term")
(version (string-append "1.0.1-" revision "." (string-take commit 7)))
(version "1.1.1")
(source (origin
(method git-fetch)
(file-name (string-append name "-" version "-checkout"))
@ -485,11 +486,7 @@ embedded kernel situations.")
(commit commit)
(recursive? #t)))
(sha256
(base32 "08mrvj8zk9ck15q90ipjzza1acnnsjhprv2rxg8yyck0xl9p40jd"))
(patches
(search-patches "cool-retro-term-fix-array-size.patch"
"cool-retro-term-dont-check-uninit-member.patch"
"cool-retro-term-memory-leak-1.patch"))
(base32 "0wb6anchxa5jpn9c73kr4byrf2xlj8x8qzc5x7ny6saj7kbbvp75"))
(modules '((guix build utils)
(srfi srfi-1)
(srfi srfi-26)
@ -497,20 +494,18 @@ embedded kernel situations.")
(ice-9 regex)))
(snippet
'(let* ((fonts '(;"1971-ibm-3278" ; BSD 3-clause
;"1975-knight-tv" ; GPL
"1977-apple2" ; Non-Free
"1977-commodore-pet" ; Non-Free
"1979-atari-400-800" ; Non-Free
"1982-commodore64" ; Non-Free
"1985-atari-st" ; ?
"1985-ibm-pc-vga" ; Unclear
;"1981-ibm-pc ; CC-SA 4.0
"1982-commodore64")) ; Non-Free
;"1985-ibm-pc-vga" ; CC-SA 4.0
;"modern-fixedsys-excelsior" ; Redistributable
;"modern-hermit" ; SIL
;"modern-inconsolata"; SIL
;"modern-pro-font-win-tweaked" ; X11
;"modern-proggy-tiny"; X11
;"modern-terminus" ; SIL
"modern-monaco")) ; Apple Non-Free
(name-rx (make-regexp " *name: *\"([^\"]*)\""))
(source-rx (make-regexp " *source: \"fonts/([^/]*)[^\"]*\""))
(fontname-rx (make-regexp "\"fontName\":\"([^\"]*).*"))
@ -626,7 +621,8 @@ embedded kernel situations.")
(lambda* (#:key outputs #:allow-other-keys)
(let ((bin (string-append (assoc-ref outputs "out") "/bin")))
(symlink (string-append bin "/cool-retro-term")
(string-append bin "/crt")))))
(string-append bin "/crt"))
#t)))
(add-after 'install 'install-man
(lambda* (#:key outputs #:allow-other-keys)
(let ((mandir (string-append (assoc-ref outputs "out")