gnu: qtbase: Restore compilation on linux kernels < 4.11.

Fixes <https://bugs.gnu.org/34431>.

* gnu/packages/patches/qtbase-old-kernel.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register patch.
* gnu/packages/qt.scm (qtbase): Add patch.
master
Andreas Enge 2019-02-14 00:10:01 +01:00
parent 58c6a93d9d
commit 69c15ad8a4
No known key found for this signature in database
GPG Key ID: F7D5C9BF765C61E3
3 changed files with 28 additions and 1 deletions

View File

@ -1180,6 +1180,7 @@ dist_patch_DATA = \
%D%/packages/patches/qemu-CVE-2018-16872.patch \
%D%/packages/patches/qemu-CVE-2019-6778.patch \
%D%/packages/patches/qt4-ldflags.patch \
%D%/packages/patches/qtbase-old-kernel.patch \
%D%/packages/patches/qtbase-use-TZDIR.patch \
%D%/packages/patches/qtscript-disable-tests.patch \
%D%/packages/patches/quagga-reproducible-build.patch \

View File

@ -0,0 +1,25 @@
https://672856.bugs.gentoo.org/attachment.cgi?id=557978
https://bugs.gentoo.org/672856
The patch fixes building qtbase with linux kernels < 4.11.
See bug #34431.
diff -Naurp a/src/corelib/global/minimum-linux_p.h b/src/corelib/global/minimum-linux_p.h
--- a/src/corelib/global/minimum-linux_p.h 2018-11-25 15:51:11.000000000 +0300
+++ b/src/corelib/global/minimum-linux_p.h 2018-12-17 13:25:38.176823753 +0300
@@ -75,14 +75,9 @@ QT_BEGIN_NAMESPACE
* - accept4 2.6.28
* - renameat2 3.16 QT_CONFIG(renameat2)
* - getrandom 3.17 QT_CONFIG(getentropy)
- * - statx 4.11 QT_CONFIG(statx)
*/
-#if QT_CONFIG(statx)
-# define MINLINUX_MAJOR 4
-# define MINLINUX_MINOR 11
-# define MINLINUX_PATCH 0
-#elif QT_CONFIG(getentropy)
+#if QT_CONFIG(getentropy)
# define MINLINUX_MAJOR 3
# define MINLINUX_MINOR 17
# define MINLINUX_PATCH 0

View File

@ -512,7 +512,8 @@ system, and the core design of Django is reused in Grantlee.")
(base32
"071yc9iz14qs4s8yvrwllyfdzp5yjxsdpvbjxdrf0g5q69vqigy6"))
;; Use TZDIR to avoid depending on package "tzdata".
(patches (search-patches "qtbase-use-TZDIR.patch"))
(patches (search-patches "qtbase-use-TZDIR.patch"
"qtbase-old-kernel.patch"))
(modules '((guix build utils)))
(snippet
;; corelib uses bundled harfbuzz, md4, md5, sha3