gnu: openimageio: Update to 1.6.15.
* gnu/packages/graphics.scm (openimageio): Update to 1.6.15. [source]: Remove patch. * gnu/packages/patches/openimageio-boost-1.60.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
0a7fc756fe
commit
6a628e8ba7
|
@ -688,7 +688,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/ocaml-CVE-2015-8869.patch \
|
||||
%D%/packages/patches/ocaml-findlib-make-install.patch \
|
||||
%D%/packages/patches/openexr-missing-samples.patch \
|
||||
%D%/packages/patches/openimageio-boost-1.60.patch \
|
||||
%D%/packages/patches/openjpeg-CVE-2015-6581.patch \
|
||||
%D%/packages/patches/openjpeg-use-after-free-fix.patch \
|
||||
%D%/packages/patches/openssh-CVE-2015-8325.patch \
|
||||
|
|
|
@ -255,7 +255,7 @@ storage of the \"EXR\" file format for storing 16-bit floating-point images.")
|
|||
(define-public openimageio
|
||||
(package
|
||||
(name "openimageio")
|
||||
(version "1.5.18")
|
||||
(version "1.6.15")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://github.com/OpenImageIO/oiio/"
|
||||
|
@ -263,8 +263,7 @@ storage of the \"EXR\" file format for storing 16-bit floating-point images.")
|
|||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0mn7cz19mn8dcrhkq15h25gl20ammr1wz0j2j3c2vxs6ph7zn8jy"))
|
||||
(patches (search-patches "openimageio-boost-1.60.patch"))))
|
||||
"144crq0205d0w5aq4iglh2rhzf54a8rv3pksy6d533b75w5d7rq7"))))
|
||||
(build-system cmake-build-system)
|
||||
;; FIXME: To run all tests successfully, test image sets from multiple
|
||||
;; third party sources have to be present. For details see
|
||||
|
|
|
@ -1,47 +0,0 @@
|
|||
From 875fbbd92695397bfc83d1cd5fdd4094e1d50199 Mon Sep 17 00:00:00 2001
|
||||
From: Larry Gritz <lg@larrygritz.com>
|
||||
Date: Mon, 28 Dec 2015 11:46:07 -0800
|
||||
Subject: [PATCH] Python ImageCache binding fixes -- disable broken calls
|
||||
|
||||
Some of these calls (thankfully undocumented and presumably unused)
|
||||
are horribly broken. They compiled before, but with new Boost 1.60
|
||||
they don't even compile properly. So just comment them out on this
|
||||
obsolete branch. They are fully fixed in RB-1.6 and beyond.
|
||||
|
||||
--- a/src/python/py_imagecache.cpp
|
||||
+++ b/src/python/py_imagecache.cpp
|
||||
@@ -199,23 +199,24 @@ void declare_imagecache()
|
||||
.def("destroy", &ImageCacheWrap::destroy)
|
||||
.staticmethod("destroy")
|
||||
.def("clear", &ImageCacheWrap::clear)
|
||||
- .def("attribute", &ImageCacheWrap::attribute)
|
||||
+ // .def("attribute", &ImageCacheWrap::attribute)
|
||||
.def("attribute", &ImageCacheWrap::attribute_int)
|
||||
.def("attribute", &ImageCacheWrap::attribute_float)
|
||||
- .def("attribute", &ImageCacheWrap::attribute_double)
|
||||
- .def("attribute", &ImageCacheWrap::attribute_char)
|
||||
+ // .def("attribute", &ImageCacheWrap::attribute_double)
|
||||
+ // .def("attribute", &ImageCacheWrap::attribute_char)
|
||||
.def("attribute", &ImageCacheWrap::attribute_string)
|
||||
- .def("getattribute", &ImageCacheWrap::attribute)
|
||||
+ // .def("getattribute", &ImageCacheWrap::attribute)
|
||||
.def("getattribute", &ImageCacheWrap::getattribute_int)
|
||||
.def("getattribute", &ImageCacheWrap::getattribute_float)
|
||||
- .def("getattribute", &ImageCacheWrap::getattribute_double)
|
||||
- .def("getattribute", &ImageCacheWrap::getattribute_char)
|
||||
+ // .def("getattribute", &ImageCacheWrap::getattribute_double)
|
||||
+ // .def("getattribute", &ImageCacheWrap::getattribute_char)
|
||||
.def("getattribute", &ImageCacheWrap::getattribute_string)
|
||||
- .def("resolve_filename", &ImageCacheWrap::resolve_filename)
|
||||
- .def("get_image_info", &ImageCacheWrap::get_image_info)
|
||||
- .def("get_image_info", &ImageCacheWrap::get_image_info_old)
|
||||
+ // .def("get_image_info", &ImageCacheWrap::get_image_info)
|
||||
+ // .def("get_image_info", &ImageCacheWrap::get_image_info_old)
|
||||
.def("get_imagespec", &ImageCacheWrap::get_imagespec)
|
||||
- .def("get_pixels", &ImageCacheWrap::get_pixels)
|
||||
+ // .def("get_pixels", &ImageCacheWrap::get_pixels)
|
||||
+ .def("resolve_filename", &ImageCacheWrap::resolve_filename)
|
||||
+
|
||||
// .def("get_tile", &ImageCacheWrap::get_tile)
|
||||
// .def("release_tile", &ImageCacheWrap::release_tile)
|
||||
// .def("tile_pixels", &ImageCacheWrap::tile_pixels)
|
Loading…
Reference in New Issue