gnu: m4: Remove already-applied patch.
* gnu/packages/patches/m4-readlink-EINVAL.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove it. * gnu/packages/m4.scm (m4): Remove patch.
This commit is contained in:
parent
0d12bc744e
commit
6ac8aa3d75
|
@ -403,7 +403,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/lm-sensors-hwmon-attrs.patch \
|
||||
gnu/packages/patches/luit-posix.patch \
|
||||
gnu/packages/patches/m4-gets-undeclared.patch \
|
||||
gnu/packages/patches/m4-readlink-EINVAL.patch \
|
||||
gnu/packages/patches/make-impure-dirs.patch \
|
||||
gnu/packages/patches/mc-fix-ncurses-build.patch \
|
||||
gnu/packages/patches/mcron-install.patch \
|
||||
|
|
|
@ -33,8 +33,7 @@
|
|||
version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"0w0da1chh12mczxa5lnwzjk9czi3dq6gnnndbpa6w4rj76b1yklf"))
|
||||
(patches (list (search-patch "m4-readlink-EINVAL.patch")))))
|
||||
"0w0da1chh12mczxa5lnwzjk9czi3dq6gnnndbpa6w4rj76b1yklf"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
;; XXX: Disable tests on those platforms with know issues.
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
Newer Linux kernels would return EINVAL instead of ENOENT.
|
||||
The patch below, taken from Gnulib, allows the test to pass when
|
||||
these Linux versions are in use:
|
||||
https://lists.gnu.org/archive/html/bug-gnulib/2011-03/msg00308.html .
|
||||
|
||||
diff --git a/tests/test-readlink.h b/tests/test-readlink.h
|
||||
index 08d5662..7247fc4 100644
|
||||
--- a/tests/test-readlink.h
|
||||
+++ b/tests/test-readlink.h
|
||||
@@ -38,7 +38,7 @@ test_readlink (ssize_t (*func) (char const *, char *, size_t), bool print)
|
||||
ASSERT (errno == ENOENT);
|
||||
errno = 0;
|
||||
ASSERT (func ("", buf, sizeof buf) == -1);
|
||||
- ASSERT (errno == ENOENT);
|
||||
+ ASSERT (errno == ENOENT || errno == EINVAL);
|
||||
errno = 0;
|
||||
ASSERT (func (".", buf, sizeof buf) == -1);
|
||||
ASSERT (errno == EINVAL);
|
Loading…
Reference in New Issue