gnu: zathura: Update to 0.4.3.

* gnu/packages/patches/zathura-plugindir-environment-variable.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/pdf.scm (zathura): Update to 0.4.3.
[source](patches): Remove.
[native-search-paths]: Adjust for upstreamed patch.
master
Marius Bakke 2018-12-23 22:39:27 +01:00
parent e59a9cf7f0
commit 6bd8ba619d
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 4 additions and 39 deletions

View File

@ -1264,8 +1264,7 @@ dist_patch_DATA = \
%D%/packages/patches/xfce4-settings-defaults.patch \
%D%/packages/patches/xinetd-fix-fd-leak.patch \
%D%/packages/patches/xinetd-CVE-2013-4342.patch \
%D%/packages/patches/xmodmap-asprintf.patch \
%D%/packages/patches/zathura-plugindir-environment-variable.patch
%D%/packages/patches/xmodmap-asprintf.patch
MISC_DISTRO_FILES = \
%D%/packages/ld-wrapper.in

View File

@ -1,32 +0,0 @@
From ae8e4cc9ab57ff25d2ba6c4b369e8531ce43a6d2 Mon Sep 17 00:00:00 2001
From: Paul van der Walt <paul@denknerd.org>
Date: Mon, 2 Mar 2015 22:15:39 +0100
Subject: [PATCH] Search path environment variable for Zathura.
Adds a search path environment variable for zathura plugins (for reading
different file formats) called ZATHURA_PLUGIN_PATH. Command line option
-p still takes precedence.
Patch by Paul van der Walt <paul@denknerd.org>
Adjusted for Zathura 0.3.9 by Tobias Geerinckx-Rice <me@tobias.gr>
---
zathura/zathura.c | 7 +++++++
1 file changed, 7 insertions(+)
diff --git a/zathura/zathura.c b/zathura/zathura.c
--- a/zathura/zathura.c
+++ b/zathura/zathura.c
@@ -597,6 +597,13 @@ zathura_set_plugin_dir(zathura_t* zathura, const char* dir)
g_return_if_fail(zathura != NULL);
g_return_if_fail(zathura->plugins.manager != NULL);
+ /* Added for Guix: check if environment variable
+ * is set to specify location of zathura plugins.
+ */
+
+ if (dir == NULL)
+ dir = g_getenv("ZATHURA_PLUGIN_PATH");
+
if (dir != NULL) {
set_plugin_dir(zathura, dir);
#ifdef ZATHURA_PLUGINDIR

View File

@ -496,7 +496,7 @@ by using the poppler rendering engine.")
(define-public zathura
(package
(name "zathura")
(version "0.4.0")
(version "0.4.3")
(source (origin
(method url-fetch)
(uri
@ -504,9 +504,7 @@ by using the poppler rendering engine.")
version ".tar.xz"))
(sha256
(base32
"1j0yah09adv3bsjhhbqra5lambal32svk8fxmf89wwmcqrcr4qma"))
(patches (search-patches
"zathura-plugindir-environment-variable.patch"))))
"0hgx5x09i6d0z45llzdmh4l348fxh1y102sb1w76f2fp4r21j4ky"))))
(native-inputs `(("pkg-config" ,pkg-config)
("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
@ -523,7 +521,7 @@ by using the poppler rendering engine.")
("girara" ,girara)))
(native-search-paths
(list (search-path-specification
(variable "ZATHURA_PLUGIN_PATH")
(variable "ZATHURA_PLUGINS_PATH")
(files '("lib/zathura")))))
(build-system meson-build-system)
(arguments