Merge branch 'xorg' into core-updates
This commit is contained in:
commit
6be960c7f7
|
@ -108,6 +108,7 @@ MODULES = \
|
||||||
gnu/packages/irssi.scm \
|
gnu/packages/irssi.scm \
|
||||||
gnu/packages/ld-wrapper.scm \
|
gnu/packages/ld-wrapper.scm \
|
||||||
gnu/packages/less.scm \
|
gnu/packages/less.scm \
|
||||||
|
gnu/packages/lesstif.scm \
|
||||||
gnu/packages/libapr.scm \
|
gnu/packages/libapr.scm \
|
||||||
gnu/packages/libdaemon.scm \
|
gnu/packages/libdaemon.scm \
|
||||||
gnu/packages/libevent.scm \
|
gnu/packages/libevent.scm \
|
||||||
|
@ -177,6 +178,7 @@ MODULES = \
|
||||||
gnu/packages/wget.scm \
|
gnu/packages/wget.scm \
|
||||||
gnu/packages/which.scm \
|
gnu/packages/which.scm \
|
||||||
gnu/packages/xml.scm \
|
gnu/packages/xml.scm \
|
||||||
|
gnu/packages/xorg.scm \
|
||||||
gnu/packages/zile.scm \
|
gnu/packages/zile.scm \
|
||||||
gnu/packages/zip.scm \
|
gnu/packages/zip.scm \
|
||||||
gnu/system/vm.scm
|
gnu/system/vm.scm
|
||||||
|
@ -235,7 +237,8 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/tcsh-fix-autotest.patch \
|
gnu/packages/patches/tcsh-fix-autotest.patch \
|
||||||
gnu/packages/patches/teckit-cstdio.patch \
|
gnu/packages/patches/teckit-cstdio.patch \
|
||||||
gnu/packages/patches/vpnc-script.patch \
|
gnu/packages/patches/vpnc-script.patch \
|
||||||
gnu/packages/patches/w3m-fix-compile.patch
|
gnu/packages/patches/w3m-fix-compile.patch \
|
||||||
|
gnu/packages/patches/xpdf-constchar.patch
|
||||||
|
|
||||||
bootstrapdir = $(guilemoduledir)/gnu/packages/bootstrap
|
bootstrapdir = $(guilemoduledir)/gnu/packages/bootstrap
|
||||||
bootstrap_x86_64_linuxdir = $(bootstrapdir)/x86_64-linux
|
bootstrap_x86_64_linuxdir = $(bootstrapdir)/x86_64-linux
|
||||||
|
|
|
@ -38,6 +38,20 @@
|
||||||
(sha256 (base32
|
(sha256 (base32
|
||||||
"0gpcz6swir64kp0dk3rwgqqkmf48b90dqgczdmznjjryhrahx9r9"))))
|
"0gpcz6swir64kp0dk3rwgqqkmf48b90dqgczdmznjjryhrahx9r9"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
|
(arguments
|
||||||
|
`(#:phases
|
||||||
|
(alist-replace
|
||||||
|
'install
|
||||||
|
(lambda* (#:key outputs #:allow-other-keys #:rest args)
|
||||||
|
(let ((install (assoc-ref %standard-phases 'install))
|
||||||
|
(include (string-append (assoc-ref outputs "out") "/include")))
|
||||||
|
(apply install args)
|
||||||
|
;; Unravel one directory, since ft2build.h includes directly from
|
||||||
|
;; freetype/, not freetype2/freetype; this is announced in the file
|
||||||
|
;; to be changed in a future release.
|
||||||
|
(symlink (string-append include "/freetype2/freetype")
|
||||||
|
(string-append include "/freetype"))))
|
||||||
|
%standard-phases)))
|
||||||
(synopsis "Freetype, a library to render fonts")
|
(synopsis "Freetype, a library to render fonts")
|
||||||
(description
|
(description
|
||||||
"Freetype is a library that can be used by applications to access the
|
"Freetype is a library that can be used by applications to access the
|
||||||
|
|
|
@ -0,0 +1,50 @@
|
||||||
|
;;; GNU Guix --- Functional package management for GNU
|
||||||
|
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
|
||||||
|
;;;
|
||||||
|
;;; This file is part of GNU Guix.
|
||||||
|
;;;
|
||||||
|
;;; GNU Guix is free software; you can redistribute it and/or modify it
|
||||||
|
;;; under the terms of the GNU General Public License as published by
|
||||||
|
;;; the Free Software Foundation; either version 3 of the License, or (at
|
||||||
|
;;; your option) any later version.
|
||||||
|
;;;
|
||||||
|
;;; GNU Guix is distributed in the hope that it will be useful, but
|
||||||
|
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||||
|
;;; GNU General Public License for more details.
|
||||||
|
;;;
|
||||||
|
;;; You should have received a copy of the GNU General Public License
|
||||||
|
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
|
||||||
|
|
||||||
|
(define-module (gnu packages lesstif)
|
||||||
|
#:use-module ((guix licenses)
|
||||||
|
#:renamer (symbol-prefix-proc 'license:))
|
||||||
|
#:use-module (guix packages)
|
||||||
|
#:use-module (guix download)
|
||||||
|
#:use-module (guix build-system gnu)
|
||||||
|
#:use-module (gnu packages xorg))
|
||||||
|
|
||||||
|
|
||||||
|
(define-public lesstif
|
||||||
|
(package
|
||||||
|
(name "lesstif")
|
||||||
|
(version "0.95.2")
|
||||||
|
(source
|
||||||
|
(origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (string-append
|
||||||
|
"mirror://sourceforge/lesstif/lesstif/" version
|
||||||
|
"/lesstif-" version ".tar.bz2"))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"1qzpxjjf7ri1jzv71mvq5m9g8hfaj5yzwp30rwxlm6n2b24a6jpb"))))
|
||||||
|
(build-system gnu-build-system)
|
||||||
|
(propagated-inputs
|
||||||
|
`(("printproto" ,printproto)))
|
||||||
|
(inputs
|
||||||
|
`(("libxext" ,libxext)
|
||||||
|
("libxt" ,libxt)))
|
||||||
|
(home-page "http://lesstif.sourceforge.net/")
|
||||||
|
(synopsis "Clone of the Motif toolkit for the X window system")
|
||||||
|
(description "Clone of the Motif toolkit for the X window system")
|
||||||
|
(license license:gpl2+))) ; some files are lgpl2.1+ or x11
|
|
@ -0,0 +1,15 @@
|
||||||
|
This patch circumvents an error with 'const char *' to 'char *' conversion,
|
||||||
|
see http://gnats.netbsd.org/45562 .
|
||||||
|
|
||||||
|
diff -u a/xpdf/XPDFViewer.cc b/xpdf/XPDFViewer.cc
|
||||||
|
--- a/xpdf/XPDFViewer.cc 2011-08-15 23:08:53.000000000 +0200
|
||||||
|
+++ b/xpdf/XPDFViewer.cc 2013-03-31 15:13:21.000000000 +0200
|
||||||
|
@@ -1803,7 +1803,7 @@
|
||||||
|
menuPane = XmCreatePulldownMenu(toolBar, "zoomMenuPane", args, n);
|
||||||
|
for (i = 0; i < nZoomMenuItems; ++i) {
|
||||||
|
n = 0;
|
||||||
|
- s = XmStringCreateLocalized(zoomMenuInfo[i].label);
|
||||||
|
+ s = XmStringCreateLocalized((char *) zoomMenuInfo[i].label);
|
||||||
|
XtSetArg(args[n], XmNlabelString, s); ++n;
|
||||||
|
XtSetArg(args[n], XmNuserData, (XtPointer)i); ++n;
|
||||||
|
sprintf(buf, "zoom%d", i);
|
|
@ -17,16 +17,21 @@
|
||||||
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
|
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
|
||||||
|
|
||||||
(define-module (gnu packages pdf)
|
(define-module (gnu packages pdf)
|
||||||
#:use-module ((guix licenses) #:select (gpl2+))
|
#:use-module ((guix licenses)
|
||||||
|
#:renamer (symbol-prefix-proc 'license:))
|
||||||
#:use-module (guix packages)
|
#:use-module (guix packages)
|
||||||
#:use-module (guix download)
|
#:use-module (guix download)
|
||||||
#:use-module (guix build-system gnu)
|
#:use-module (guix build-system gnu)
|
||||||
#:use-module (gnu packages)
|
#:use-module (gnu packages)
|
||||||
#:use-module (gnu packages compression)
|
#:use-module (gnu packages compression)
|
||||||
#:use-module (gnu packages fontutils)
|
#:use-module (gnu packages fontutils)
|
||||||
|
#:use-module (gnu packages ghostscript)
|
||||||
|
#:use-module (gnu packages lesstif)
|
||||||
#:use-module (gnu packages libjpeg)
|
#:use-module (gnu packages libjpeg)
|
||||||
|
#:use-module (gnu packages libpng)
|
||||||
#:use-module (gnu packages libtiff)
|
#:use-module (gnu packages libtiff)
|
||||||
#:use-module (gnu packages pkg-config))
|
#:use-module (gnu packages pkg-config)
|
||||||
|
#:use-module (gnu packages xorg))
|
||||||
|
|
||||||
(define-public poppler
|
(define-public poppler
|
||||||
(package
|
(package
|
||||||
|
@ -40,17 +45,59 @@
|
||||||
"1rmrspavldlpqi6g76fijcmshy80m0kxd01nc1dmy4id3h4las44"))))
|
"1rmrspavldlpqi6g76fijcmshy80m0kxd01nc1dmy4id3h4las44"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
;; FIXME: more dependencies could be added
|
;; FIXME: more dependencies could be added
|
||||||
|
;; cairo output: no (requires cairo >= 1.10.0)
|
||||||
|
;; qt4 wrapper: no
|
||||||
|
;; glib wrapper: no (requires cairo output)
|
||||||
|
;; introspection: no
|
||||||
|
;; use gtk-doc: no
|
||||||
|
;; use libcurl: no
|
||||||
|
;; use libopenjpeg: no
|
||||||
(inputs `(("fontconfig" ,fontconfig)
|
(inputs `(("fontconfig" ,fontconfig)
|
||||||
("freetype" ,freetype)
|
("freetype" ,freetype)
|
||||||
("libjpeg-8" ,libjpeg-8)
|
("libjpeg-8" ,libjpeg-8)
|
||||||
|
("libpng" ,libpng)
|
||||||
("libtiff" ,libtiff)
|
("libtiff" ,libtiff)
|
||||||
("pkg-config" ,pkg-config)
|
("pkg-config" ,pkg-config)
|
||||||
("zlib" ,zlib)))
|
("zlib" ,zlib)))
|
||||||
(arguments
|
(arguments
|
||||||
`(#:tests? #f ; no test data provided with the tarball
|
`(#:tests? #f ; no test data provided with the tarball
|
||||||
#:configure-flags '("--enable-xpdf-headers"))) ; to install header files
|
#:configure-flags
|
||||||
|
'("--enable-xpdf-headers" ; to install header files
|
||||||
|
"--enable-zlib")))
|
||||||
(synopsis "Poppler, a pdf rendering library")
|
(synopsis "Poppler, a pdf rendering library")
|
||||||
(description
|
(description
|
||||||
"Poppler is a PDF rendering library based on the xpdf-3.0 code base.")
|
"Poppler is a PDF rendering library based on the xpdf-3.0 code base.")
|
||||||
(license gpl2+)
|
(license license:gpl2+)
|
||||||
(home-page "http://poppler.freedesktop.org/")))
|
(home-page "http://poppler.freedesktop.org/")))
|
||||||
|
|
||||||
|
(define-public xpdf
|
||||||
|
(package
|
||||||
|
(name "xpdf")
|
||||||
|
(version "3.03")
|
||||||
|
(source (origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (string-append "ftp://ftp.foolabs.com/pub/xpdf/xpdf-"
|
||||||
|
version ".tar.gz"))
|
||||||
|
(sha256 (base32
|
||||||
|
"1jnfzdqc54wa73lw28kjv0m7120mksb0zkcn81jdlvijyvc67kq2"))))
|
||||||
|
(build-system gnu-build-system)
|
||||||
|
(inputs `(("freetype" ,freetype)
|
||||||
|
("lesstif" ,lesstif)
|
||||||
|
("libpaper" ,libpaper)
|
||||||
|
("libx11" ,libx11)
|
||||||
|
("libxext" ,libxext)
|
||||||
|
("libxp" ,libxp)
|
||||||
|
("libxpm" ,libxpm)
|
||||||
|
("libxt" ,libxt)
|
||||||
|
("zlib" ,zlib)
|
||||||
|
("patch/constchar"
|
||||||
|
,(search-patch "xpdf-constchar.patch"))))
|
||||||
|
(arguments
|
||||||
|
`(#:tests? #f ; there is no check target
|
||||||
|
#:patches (list (assoc-ref %build-inputs
|
||||||
|
"patch/constchar"))))
|
||||||
|
(synopsis "Viewer for pdf files based on the Motif toolkit.")
|
||||||
|
(description
|
||||||
|
"Xpdf is a viewer for Portable Document Format (PDF) files")
|
||||||
|
(license license:gpl3) ; or gpl2, but not gpl2+
|
||||||
|
(home-page "http://www.foolabs.com/xpdf/")))
|
||||||
|
|
|
@ -33,6 +33,7 @@
|
||||||
#:use-module (gnu packages pkg-config)
|
#:use-module (gnu packages pkg-config)
|
||||||
#:use-module (gnu packages python)
|
#:use-module (gnu packages python)
|
||||||
#:use-module (gnu packages tcsh)
|
#:use-module (gnu packages tcsh)
|
||||||
|
#:use-module (gnu packages xorg)
|
||||||
#:use-module (gnu packages zip))
|
#:use-module (gnu packages zip))
|
||||||
|
|
||||||
(define texlive-extra-src
|
(define texlive-extra-src
|
||||||
|
@ -66,6 +67,8 @@
|
||||||
("icu4c" ,icu4c)
|
("icu4c" ,icu4c)
|
||||||
("ghostscript" ,ghostscript)
|
("ghostscript" ,ghostscript)
|
||||||
("libpng" ,libpng)
|
("libpng" ,libpng)
|
||||||
|
("libxaw" ,libxaw)
|
||||||
|
("libxt" ,libxt)
|
||||||
("perl" ,perl)
|
("perl" ,perl)
|
||||||
("poppler" ,poppler)
|
("poppler" ,poppler)
|
||||||
("pkg-config" ,pkg-config)
|
("pkg-config" ,pkg-config)
|
||||||
|
@ -88,7 +91,6 @@
|
||||||
,(string-append "--datarootdir=" (assoc-ref %outputs "data"))
|
,(string-append "--datarootdir=" (assoc-ref %outputs "data"))
|
||||||
,(string-append "--infodir=" (assoc-ref %outputs "out") "/share/info")
|
,(string-append "--infodir=" (assoc-ref %outputs "out") "/share/info")
|
||||||
,(string-append "--mandir=" (assoc-ref %outputs "out") "/share/man")
|
,(string-append "--mandir=" (assoc-ref %outputs "out") "/share/man")
|
||||||
"--without-x" ; FIXME: Drop as soon as X is available.
|
|
||||||
"--with-system-freetype2"
|
"--with-system-freetype2"
|
||||||
;; "--with-system-gd"
|
;; "--with-system-gd"
|
||||||
;; "--with-system-graphite"
|
;; "--with-system-graphite"
|
||||||
|
|
|
@ -19,6 +19,7 @@
|
||||||
|
|
||||||
(define-module (gnu packages xml)
|
(define-module (gnu packages xml)
|
||||||
#:use-module (gnu packages)
|
#:use-module (gnu packages)
|
||||||
|
#:use-module (gnu packages compression)
|
||||||
#:use-module (gnu packages gnupg)
|
#:use-module (gnu packages gnupg)
|
||||||
#:use-module (gnu packages perl)
|
#:use-module (gnu packages perl)
|
||||||
#:use-module (gnu packages python)
|
#:use-module (gnu packages python)
|
||||||
|
@ -64,7 +65,21 @@ things the parser might find in the XML document (like start tags).")
|
||||||
(home-page "http://www.xmlsoft.org/")
|
(home-page "http://www.xmlsoft.org/")
|
||||||
(synopsis "libxml2, a C parser for XML")
|
(synopsis "libxml2, a C parser for XML")
|
||||||
(inputs `(("perl" ,perl)
|
(inputs `(("perl" ,perl)
|
||||||
("python" ,python)))
|
("python" ,python)
|
||||||
|
("zlib" ,zlib)))
|
||||||
|
(arguments
|
||||||
|
`(#:phases
|
||||||
|
(alist-replace
|
||||||
|
'install
|
||||||
|
(lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
|
||||||
|
(let ((install (assoc-ref %standard-phases 'install))
|
||||||
|
(glibc (assoc-ref inputs "libc"))
|
||||||
|
(out (assoc-ref outputs "out")))
|
||||||
|
(apply install args)
|
||||||
|
(chdir "python")
|
||||||
|
(substitute* "setup.py" (("/opt/include") (string-append glibc "/include")))
|
||||||
|
(system* "python" "setup.py" "install" (string-append "--prefix=" out))))
|
||||||
|
%standard-phases)))
|
||||||
(description
|
(description
|
||||||
"Libxml2 is the XML C parser and toolkit developed for the Gnome project
|
"Libxml2 is the XML C parser and toolkit developed for the Gnome project
|
||||||
(but it is usable outside of the Gnome platform).")
|
(but it is usable outside of the Gnome platform).")
|
||||||
|
@ -86,7 +101,19 @@ things the parser might find in the XML document (like start tags).")
|
||||||
(synopsis "libxslt, a C library for applying XSLT stylesheets to XML documents")
|
(synopsis "libxslt, a C library for applying XSLT stylesheets to XML documents")
|
||||||
(inputs `(("libgcrypt" ,libgcrypt)
|
(inputs `(("libgcrypt" ,libgcrypt)
|
||||||
("libxml2" ,libxml2)
|
("libxml2" ,libxml2)
|
||||||
("python" ,python)))
|
("python" ,python)
|
||||||
|
("zlib" ,zlib)))
|
||||||
|
(arguments
|
||||||
|
`(#:phases
|
||||||
|
(alist-replace
|
||||||
|
'configure
|
||||||
|
(lambda* (#:key inputs #:allow-other-keys #:rest args)
|
||||||
|
(let ((configure (assoc-ref %standard-phases 'configure))
|
||||||
|
(libxml2 (assoc-ref inputs "libxml2")))
|
||||||
|
;; FIXME: This should be done more centrally.
|
||||||
|
(setenv "PYTHONPATH" (string-append libxml2 "/lib/python2.7/site-packages"))
|
||||||
|
(apply configure args)))
|
||||||
|
%standard-phases)))
|
||||||
(description
|
(description
|
||||||
"Libxslt is an XSLT C library developed for the GNOME project. It is
|
"Libxslt is an XSLT C library developed for the GNOME project. It is
|
||||||
based on libxml for XML parsing, tree manipulation and XPath support.")
|
based on libxml for XML parsing, tree manipulation and XPath support.")
|
||||||
|
@ -99,7 +126,7 @@ based on libxml for XML parsing, tree manipulation and XPath support.")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append
|
(uri (string-append
|
||||||
"mirror://cpan/authors/id/M/MS/MSERGEANT/XML-Parser-"
|
"mirror://cpan/authors/id/T/TO/TODDR/XML-Parser-"
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
|
@ -122,3 +149,41 @@ then passed on to the Expat object on each parse call. They can also be given
|
||||||
as extra arguments to the parse methods, in which case they override options
|
as extra arguments to the parse methods, in which case they override options
|
||||||
given at XML::Parser creation time.")
|
given at XML::Parser creation time.")
|
||||||
(home-page "http://search.cpan.org/~toddr/XML-Parser-2.41/Parser.pm")))
|
(home-page "http://search.cpan.org/~toddr/XML-Parser-2.41/Parser.pm")))
|
||||||
|
|
||||||
|
(define-public intltool
|
||||||
|
(package
|
||||||
|
(name "intltool")
|
||||||
|
(version "0.50.2")
|
||||||
|
(source (origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (string-append "https://launchpad.net/intltool/trunk/"
|
||||||
|
version "/+download/intltool-"
|
||||||
|
version ".tar.gz"))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"01j4yd7i84n9nk4ccs6yifg84pp68nr9by57jdbhj7dpdxf5rwk7"))))
|
||||||
|
(build-system gnu-build-system)
|
||||||
|
(propagated-inputs
|
||||||
|
`(("perl" ,perl)
|
||||||
|
("perl-xml-parser" ,perl-xml-parser)))
|
||||||
|
(arguments
|
||||||
|
`(#:phases
|
||||||
|
(alist-replace
|
||||||
|
'configure
|
||||||
|
(lambda* (#:key inputs #:allow-other-keys #:rest args)
|
||||||
|
(let ((configure (assoc-ref %standard-phases 'configure))
|
||||||
|
(perl-xml-parser (assoc-ref inputs "perl-xml-parser")))
|
||||||
|
;; FIXME: This should be done more centrally.
|
||||||
|
(setenv "PERL5LIB" (string-append perl-xml-parser "/lib/perl5/site_perl"))
|
||||||
|
(apply configure args)))
|
||||||
|
%standard-phases)))
|
||||||
|
(home-page "https://launchpad.net/intltool/+download")
|
||||||
|
(synopsis "Utility scripts for internationalising xml")
|
||||||
|
(description
|
||||||
|
"intltool automatically extracts translatable strings from oaf, glade,
|
||||||
|
bonobo ui, nautilus theme and other XML files into the po files.
|
||||||
|
It automatically merges translations from po files back into .oaf files
|
||||||
|
(encoding to be 7-bit clean). The merging mechanism can also be extended to
|
||||||
|
support other types of XML files.")
|
||||||
|
(license license:gpl2+)))
|
||||||
|
|
||||||
|
|
File diff suppressed because it is too large
Load Diff
|
@ -105,8 +105,7 @@
|
||||||
"http://mirrors.ircam.fr/pub/apache/"
|
"http://mirrors.ircam.fr/pub/apache/"
|
||||||
"http://apache-mirror.rbc.ru/pub/apache/")
|
"http://apache-mirror.rbc.ru/pub/apache/")
|
||||||
(xorg ; from http://www.x.org/wiki/Releases/Download
|
(xorg ; from http://www.x.org/wiki/Releases/Download
|
||||||
"http://xorg.freedesktop.org/releases/" ; main mirrors
|
"http://www.x.org/releases/" ; main mirrors
|
||||||
"http://www.x.org/pub/"
|
|
||||||
"ftp://mirror.csclub.uwaterloo.ca/x.org/" ; North America
|
"ftp://mirror.csclub.uwaterloo.ca/x.org/" ; North America
|
||||||
"ftp://xorg.mirrors.pair.com/"
|
"ftp://xorg.mirrors.pair.com/"
|
||||||
"http://mirror.csclub.uwaterloo.ca/x.org/"
|
"http://mirror.csclub.uwaterloo.ca/x.org/"
|
||||||
|
|
Loading…
Reference in New Issue