gnu: ntfs-3g: Fix CVE-2019-9755.
* gnu/packages/patches/ntfs-3g-CVE-2019-9755.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/linux.scm (ntfs-3g)[source]: Use it.
This commit is contained in:
parent
5427db0dc0
commit
6d01a7f4c4
|
@ -1086,6 +1086,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/ngircd-handle-zombies.patch \
|
%D%/packages/patches/ngircd-handle-zombies.patch \
|
||||||
%D%/packages/patches/nss-increase-test-timeout.patch \
|
%D%/packages/patches/nss-increase-test-timeout.patch \
|
||||||
%D%/packages/patches/nss-pkgconfig.patch \
|
%D%/packages/patches/nss-pkgconfig.patch \
|
||||||
|
%D%/packages/patches/ntfs-3g-CVE-2019-9755.patch \
|
||||||
%D%/packages/patches/nvi-assume-preserve-path.patch \
|
%D%/packages/patches/nvi-assume-preserve-path.patch \
|
||||||
%D%/packages/patches/nvi-dbpagesize-binpower.patch \
|
%D%/packages/patches/nvi-dbpagesize-binpower.patch \
|
||||||
%D%/packages/patches/nvi-db4.patch \
|
%D%/packages/patches/nvi-db4.patch \
|
||||||
|
|
|
@ -3641,6 +3641,7 @@ from userspace.")
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://tuxera.com/opensource/"
|
(uri (string-append "https://tuxera.com/opensource/"
|
||||||
"ntfs-3g_ntfsprogs-" version ".tgz"))
|
"ntfs-3g_ntfsprogs-" version ".tgz"))
|
||||||
|
(patches (search-patches "ntfs-3g-CVE-2019-9755.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1mb228p80hv97pgk3myyvgp975r9mxq56c6bdn1n24kngcfh4niy"))
|
"1mb228p80hv97pgk3myyvgp975r9mxq56c6bdn1n24kngcfh4niy"))
|
||||||
|
|
|
@ -0,0 +1,72 @@
|
||||||
|
Fix CVE-2019-9755:
|
||||||
|
|
||||||
|
https://security-tracker.debian.org/tracker/CVE-2019-9755
|
||||||
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9755
|
||||||
|
|
||||||
|
Patch copied from upstream source repository:
|
||||||
|
|
||||||
|
https://sourceforge.net/p/ntfs-3g/ntfs-3g/ci/85c1634a26faa572d3c558d4cf8aaaca5202d4e9/
|
||||||
|
|
||||||
|
From 85c1634a26faa572d3c558d4cf8aaaca5202d4e9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Jean-Pierre=20Andr=C3=A9?= <jean-pierre.andre@wanadoo.fr>
|
||||||
|
Date: Wed, 19 Dec 2018 15:57:50 +0100
|
||||||
|
Subject: [PATCH] Fixed reporting an error when failed to build the mountpoint
|
||||||
|
|
||||||
|
The size check was inefficient because getcwd() uses an unsigned int
|
||||||
|
argument.
|
||||||
|
---
|
||||||
|
src/lowntfs-3g.c | 6 +++++-
|
||||||
|
src/ntfs-3g.c | 6 +++++-
|
||||||
|
2 files changed, 10 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/lowntfs-3g.c b/src/lowntfs-3g.c
|
||||||
|
index 993867fa..0660439b 100644
|
||||||
|
--- a/src/lowntfs-3g.c
|
||||||
|
+++ b/src/lowntfs-3g.c
|
||||||
|
@@ -4411,7 +4411,8 @@ int main(int argc, char *argv[])
|
||||||
|
else {
|
||||||
|
ctx->abs_mnt_point = (char*)ntfs_malloc(PATH_MAX);
|
||||||
|
if (ctx->abs_mnt_point) {
|
||||||
|
- if (getcwd(ctx->abs_mnt_point,
|
||||||
|
+ if ((strlen(opts.mnt_point) < PATH_MAX)
|
||||||
|
+ && getcwd(ctx->abs_mnt_point,
|
||||||
|
PATH_MAX - strlen(opts.mnt_point) - 1)) {
|
||||||
|
strcat(ctx->abs_mnt_point, "/");
|
||||||
|
strcat(ctx->abs_mnt_point, opts.mnt_point);
|
||||||
|
@@ -4419,6 +4420,9 @@ int main(int argc, char *argv[])
|
||||||
|
/* Solaris also wants the absolute mount point */
|
||||||
|
opts.mnt_point = ctx->abs_mnt_point;
|
||||||
|
#endif /* defined(__sun) && defined (__SVR4) */
|
||||||
|
+ } else {
|
||||||
|
+ free(ctx->abs_mnt_point);
|
||||||
|
+ ctx->abs_mnt_point = (char*)NULL;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
}
|
||||||
|
diff --git a/src/ntfs-3g.c b/src/ntfs-3g.c
|
||||||
|
index 6ce89fef..4e0912ae 100644
|
||||||
|
--- a/src/ntfs-3g.c
|
||||||
|
+++ b/src/ntfs-3g.c
|
||||||
|
@@ -4148,7 +4148,8 @@ int main(int argc, char *argv[])
|
||||||
|
else {
|
||||||
|
ctx->abs_mnt_point = (char*)ntfs_malloc(PATH_MAX);
|
||||||
|
if (ctx->abs_mnt_point) {
|
||||||
|
- if (getcwd(ctx->abs_mnt_point,
|
||||||
|
+ if ((strlen(opts.mnt_point) < PATH_MAX)
|
||||||
|
+ && getcwd(ctx->abs_mnt_point,
|
||||||
|
PATH_MAX - strlen(opts.mnt_point) - 1)) {
|
||||||
|
strcat(ctx->abs_mnt_point, "/");
|
||||||
|
strcat(ctx->abs_mnt_point, opts.mnt_point);
|
||||||
|
@@ -4156,6 +4157,9 @@ int main(int argc, char *argv[])
|
||||||
|
/* Solaris also wants the absolute mount point */
|
||||||
|
opts.mnt_point = ctx->abs_mnt_point;
|
||||||
|
#endif /* defined(__sun) && defined (__SVR4) */
|
||||||
|
+ } else {
|
||||||
|
+ free(ctx->abs_mnt_point);
|
||||||
|
+ ctx->abs_mnt_point = (char*)NULL;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
}
|
||||||
|
--
|
||||||
|
2.21.0
|
||||||
|
|
Loading…
Reference in New Issue