gnu: xdotools: Update to 3.20150503.1
* gnu/packages/xdisorg.scm (xdotools): Upgrade to 3.20150503.1. * gnu/packages/patches/xdotool-fix-makefile.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
This commit is contained in:
parent
d9f0788ad2
commit
6f74aecdb3
|
@ -754,6 +754,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/wpa-supplicant-CVE-2015-5314.patch \
|
||||
gnu/packages/patches/wpa-supplicant-CVE-2015-5315.patch \
|
||||
gnu/packages/patches/wpa-supplicant-CVE-2015-5316.patch \
|
||||
gnu/packages/patches/xdotool-fix-makefile.patch \
|
||||
gnu/packages/patches/xf86-video-ark-remove-mibstore.patch \
|
||||
gnu/packages/patches/xf86-video-ast-remove-mibstore.patch \
|
||||
gnu/packages/patches/xf86-video-geode-glibc-2.20.patch \
|
||||
|
|
|
@ -0,0 +1,16 @@
|
|||
Fix Makefile, which missed including a necessary library for compiling in the
|
||||
0.5.0 release.
|
||||
|
||||
See https://github.com/jordansissel/xdotool/pull/81 for more information.
|
||||
|
||||
--- xdotool-3.20150503.1/Makefile 2014-10-20 13:05:34.000000000 -0700
|
||||
+++ xdotool-3.20150503.1/Makefile 2016-02-05 14:44:18.652734272 -0800
|
||||
@@ -28,7 +28,7 @@
|
||||
CFLAGS+=-g # TODO(sissel): Comment before release
|
||||
CFLAGS+=$(CPPFLAGS)
|
||||
|
||||
-DEFAULT_LIBS=-L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXtst -lXinerama
|
||||
+DEFAULT_LIBS=-L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXtst -lXinerama -lxkbcommon
|
||||
DEFAULT_INC=-I/usr/X11R6/include -I/usr/local/include
|
||||
|
||||
XDOTOOL_LIBS=$(shell pkg-config --libs x11 2> /dev/null || echo "$(DEFAULT_LIBS)") $(shell sh platform.sh extralibs)
|
|
@ -9,6 +9,7 @@
|
|||
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
|
||||
;;; Copyright © 2015 xd1le <elisp.vim@gmail.com>
|
||||
;;; Copyright © 2015 Florian Paul Schmidt <mista.tapas@gmx.net>
|
||||
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -48,6 +49,7 @@
|
|||
#:use-module (gnu packages guile)
|
||||
#:use-module (gnu packages xml)
|
||||
#:use-module (gnu packages gtk)
|
||||
#:use-module (gnu packages qt)
|
||||
#:use-module (gnu packages xorg))
|
||||
|
||||
;; packages outside the x.org system proper
|
||||
|
@ -107,16 +109,17 @@ avoiding password prompts when X11 forwarding has already been setup.")
|
|||
(define-public xdotool
|
||||
(package
|
||||
(name "xdotool")
|
||||
(version "2.20110530.1")
|
||||
(version "3.20150503.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"http://semicomplete.googlecode.com/files/" name "-"
|
||||
version ".tar.gz"))
|
||||
"https://github.com/jordansissel/xdotool/releases/download/v"
|
||||
version "/xdotool-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0rxggg1cy7nnkwidx8x2w3c5f3pk6dh2b6q0q7hp069r3n5jrd77"))))
|
||||
"1lcngsw33fy9my21rdiz1gs474bfdqcfxjrnfggbx4aypn1nhcp8"))
|
||||
(patches (list (search-patch "xdotool-fix-makefile.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:tests? #f ; Test suite requires a lot of black magic
|
||||
|
@ -134,7 +137,8 @@ avoiding password prompts when X11 forwarding has already been setup.")
|
|||
("libxext" ,libxext)
|
||||
("libxi" ,libxi)
|
||||
("libxinerama" ,libxinerama)
|
||||
("libxtst" ,libxtst)))
|
||||
("libxtst" ,libxtst)
|
||||
("libxkbcommon" ,libxkbcommon)))
|
||||
(home-page "http://www.semicomplete.com/projects/xdotool")
|
||||
(synopsis "Fake keyboard/mouse input, window management, and more")
|
||||
(description "Xdotool lets you simulate keyboard input and mouse activity,
|
||||
|
|
Loading…
Reference in New Issue