distro: Add patches forgotten in previous commits.
* distro/packages/patches/bigloo-gc-shebangs.patch, distro/packages/patches/emacs-configure-sh.patch, distro/packages/patches/procps-make-3.82.patch: New files. * Makefile.am (dist_patch_DATA): Add them.
This commit is contained in:
parent
ed9f9a7765
commit
727afa3be8
|
@ -119,9 +119,11 @@ nobase_dist_guilemodule_DATA = $(MODULES)
|
||||||
|
|
||||||
patchdir = $(guilemoduledir)/distro/packages/patches
|
patchdir = $(guilemoduledir)/distro/packages/patches
|
||||||
dist_patch_DATA = \
|
dist_patch_DATA = \
|
||||||
|
distro/packages/patches/bigloo-gc-shebangs.patch \
|
||||||
distro/packages/patches/binutils-ld-new-dtags.patch \
|
distro/packages/patches/binutils-ld-new-dtags.patch \
|
||||||
distro/packages/patches/cpio-gets-undeclared.patch \
|
distro/packages/patches/cpio-gets-undeclared.patch \
|
||||||
distro/packages/patches/diffutils-gets-undeclared.patch \
|
distro/packages/patches/diffutils-gets-undeclared.patch \
|
||||||
|
distro/packages/patches/emacs-configure-sh.patch \
|
||||||
distro/packages/patches/flex-bison-tests.patch \
|
distro/packages/patches/flex-bison-tests.patch \
|
||||||
distro/packages/patches/gawk-shell.patch \
|
distro/packages/patches/gawk-shell.patch \
|
||||||
distro/packages/patches/gettext-gets-undeclared.patch \
|
distro/packages/patches/gettext-gets-undeclared.patch \
|
||||||
|
@ -140,6 +142,7 @@ dist_patch_DATA = \
|
||||||
distro/packages/patches/make-impure-dirs.patch \
|
distro/packages/patches/make-impure-dirs.patch \
|
||||||
distro/packages/patches/findutils-absolute-paths.patch \
|
distro/packages/patches/findutils-absolute-paths.patch \
|
||||||
distro/packages/patches/perl-no-sys-dirs.patch \
|
distro/packages/patches/perl-no-sys-dirs.patch \
|
||||||
|
distro/packages/patches/procps-make-3.82.patch \
|
||||||
distro/packages/patches/readline-link-ncurses.patch \
|
distro/packages/patches/readline-link-ncurses.patch \
|
||||||
distro/packages/patches/shishi-gets-undeclared.patch \
|
distro/packages/patches/shishi-gets-undeclared.patch \
|
||||||
distro/packages/patches/tar-gets-undeclared.patch
|
distro/packages/patches/tar-gets-undeclared.patch
|
||||||
|
|
|
@ -0,0 +1,17 @@
|
||||||
|
Patch shebangs in source that gets unpacked by `configure'.
|
||||||
|
|
||||||
|
--- bigloo3.9a/gc/install-gc-7.2d 2013-01-14 15:24:01.000000000 +0100
|
||||||
|
+++ bigloo3.9a/gc/install-gc-7.2d 2013-01-14 15:23:51.000000000 +0100
|
||||||
|
@@ -29,9 +29,11 @@ fi
|
||||||
|
# untar the two versions of the GC
|
||||||
|
$tar xfz $src -C ../gc || (echo "$tar xfz $src failed"; exit 1)
|
||||||
|
/bin/rm -rf "../gc/$gc"_fth
|
||||||
|
+find ../gc/gc-7.2 -perm /111 -type f | xargs sed -i -e"s|/bin/sh|`type -P bash`|g"
|
||||||
|
mv ../gc/gc-7.2 "../gc/$gc"_fth || (echo "mv gc-7.2 failed"; exit 1)
|
||||||
|
|
||||||
|
$tar xfz $src -C ../gc || (echo "$tar xfz $src failed"; exit 1)
|
||||||
|
+find ../gc/gc-7.2 -perm /111 -type f | xargs sed -i -e"s|/bin/sh|`type -P bash`|g"
|
||||||
|
mv ../gc/gc-7.2 "../gc/$gc"
|
||||||
|
|
||||||
|
# general Bigloo patch
|
||||||
|
|
|
@ -0,0 +1,14 @@
|
||||||
|
Make sure the right shell is used when creating src/epaths.h.
|
||||||
|
|
||||||
|
--- emacs-24.2/configure 2013-01-13 17:01:53.000000000 +0100
|
||||||
|
+++ emacs-24.2/configure 2013-01-13 17:01:57.000000000 +0100
|
||||||
|
@@ -24135,7 +24135,7 @@ done
|
||||||
|
;;
|
||||||
|
"epaths":C)
|
||||||
|
echo creating src/epaths.h
|
||||||
|
-${MAKE-make} epaths-force
|
||||||
|
+${MAKE-make} epaths-force SHELL="$CONFIG_SHELL"
|
||||||
|
;;
|
||||||
|
"gdbinit":C)
|
||||||
|
if test ! -f src/.gdbinit && test -f $srcdir/src/.gdbinit; then
|
||||||
|
|
|
@ -0,0 +1,14 @@
|
||||||
|
Fix compilation with GNU Make 3.82 (patch from Nixpkgs).
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index 09fb3ed..59eba16 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -174,7 +174,7 @@ INSTALL := $(BINFILES) $(MANFILES)
|
||||||
|
# want this rule first, use := on ALL, and ALL not filled in yet
|
||||||
|
all: do_all
|
||||||
|
|
||||||
|
--include */module.mk
|
||||||
|
+-include proc/module.mk ps/module.mk
|
||||||
|
|
||||||
|
do_all: $(ALL)
|
Loading…
Reference in New Issue