gnu: tar: Update to 1.29.
* gnu/packages/base.scm (tar): Update to 1.29. [source]: Remove 'tar-d_ino_in_dirent-fix.patch'. [arguments]: New field. * gnu/packages/patches/tar-d_ino_in_dirent-fix.patch: Remove. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
2135d1eb3f
commit
74d637397b
|
@ -721,7 +721,6 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/sudo-CVE-2015-5602.patch \
|
gnu/packages/patches/sudo-CVE-2015-5602.patch \
|
||||||
gnu/packages/patches/superlu-dist-scotchmetis.patch \
|
gnu/packages/patches/superlu-dist-scotchmetis.patch \
|
||||||
gnu/packages/patches/synfig-build-fix.patch \
|
gnu/packages/patches/synfig-build-fix.patch \
|
||||||
gnu/packages/patches/tar-d_ino_in_dirent-fix.patch \
|
|
||||||
gnu/packages/patches/tar-skip-unreliable-tests.patch \
|
gnu/packages/patches/tar-skip-unreliable-tests.patch \
|
||||||
gnu/packages/patches/tcl-mkindex-deterministic.patch \
|
gnu/packages/patches/tcl-mkindex-deterministic.patch \
|
||||||
gnu/packages/patches/tclxml-3.2-install.patch \
|
gnu/packages/patches/tclxml-3.2-install.patch \
|
||||||
|
|
|
@ -137,17 +137,27 @@ implementation offers several extensions over the standard utility.")
|
||||||
(define-public tar
|
(define-public tar
|
||||||
(package
|
(package
|
||||||
(name "tar")
|
(name "tar")
|
||||||
(version "1.28")
|
(version "1.29")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/tar/tar-"
|
(uri (string-append "mirror://gnu/tar/tar-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1wi2zwm4c9r3h3b8y4w0nm0qq897kn8kyj9k22ba0iqvxj48vvk4"))
|
"097hx7sbzp8qirl4m930lw84kn0wmxhmq7v1qpra3mrg0b8cyba0"))
|
||||||
(patches (search-patches "tar-d_ino_in_dirent-fix.patch"
|
(patches (search-patches "tar-skip-unreliable-tests.patch"))))
|
||||||
"tar-skip-unreliable-tests.patch"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
|
;; Note: test suite requires ~1GiB of disk space.
|
||||||
|
(arguments
|
||||||
|
'(#:phases (modify-phases %standard-phases
|
||||||
|
(add-before 'build 'set-shell-file-name
|
||||||
|
(lambda* (#:key inputs #:allow-other-keys)
|
||||||
|
;; Do not use "/bin/sh" to run programs.
|
||||||
|
(let ((bash (assoc-ref inputs "bash")))
|
||||||
|
(substitute* "src/system.c"
|
||||||
|
(("/bin/sh")
|
||||||
|
(string-append bash "/bin/sh")))
|
||||||
|
#t))))))
|
||||||
(synopsis "Managing tar archives")
|
(synopsis "Managing tar archives")
|
||||||
(description
|
(description
|
||||||
"Tar provides the ability to create tar archives, as well as the
|
"Tar provides the ability to create tar archives, as well as the
|
||||||
|
|
|
@ -1,33 +0,0 @@
|
||||||
commit e9ddc08da0982f36581ae5a8c7763453ff41cfe8
|
|
||||||
Author: Sergey Poznyakoff <gray@gnu.org>
|
|
||||||
Date: Thu Sep 25 00:22:16 2014 +0300
|
|
||||||
|
|
||||||
Bugfixes.
|
|
||||||
|
|
||||||
* doc/tar.1: Fix typo in font spec.
|
|
||||||
* src/tar.c (sort_mode_arg, sort_mode_flag): Protect "inode"
|
|
||||||
(SAVEDIR_SORT_INODE) with D_INO_IN_DIRENT
|
|
||||||
|
|
||||||
diff --git a/src/tar.c b/src/tar.c
|
|
||||||
index 225c624..f8102e0 100644
|
|
||||||
--- a/src/tar.c
|
|
||||||
+++ b/src/tar.c
|
|
||||||
@@ -1341,14 +1341,18 @@ static char filename_terminator;
|
|
||||||
static char const *const sort_mode_arg[] = {
|
|
||||||
"none",
|
|
||||||
"name",
|
|
||||||
+#if D_INO_IN_DIRENT
|
|
||||||
"inode",
|
|
||||||
+#endif
|
|
||||||
NULL
|
|
||||||
};
|
|
||||||
|
|
||||||
static int sort_mode_flag[] = {
|
|
||||||
SAVEDIR_SORT_NONE,
|
|
||||||
SAVEDIR_SORT_NAME,
|
|
||||||
+#if D_INO_IN_DIRENT
|
|
||||||
SAVEDIR_SORT_INODE
|
|
||||||
+#endif
|
|
||||||
};
|
|
||||||
|
|
||||||
ARGMATCH_VERIFY (sort_mode_arg, sort_mode_flag);
|
|
Loading…
Reference in New Issue