gnu: clisp: Fix build with glibc 2.26.

* gnu/packages/patches/clisp-glibc-2.26.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/lisp.scm (clisp)[source]: Use it.
master
Kei Kebreau 2018-01-20 15:42:00 -05:00
parent 7c29129695
commit 75033216ea
No known key found for this signature in database
GPG Key ID: E6A5EE3C19467A0D
3 changed files with 23 additions and 1 deletions

View File

@ -581,6 +581,7 @@ dist_patch_DATA = \
%D%/packages/patches/clang-runtime-asan-build-fixes.patch \
%D%/packages/patches/clang-runtime-esan-build-fixes.patch \
%D%/packages/patches/clementine-use-openssl.patch \
%D%/packages/patches/clisp-glibc-2.26.patch \
%D%/packages/patches/clisp-remove-failing-test.patch \
%D%/packages/patches/clucene-pkgconfig.patch \
%D%/packages/patches/clx-remove-demo.patch \

View File

@ -262,7 +262,8 @@ supporting ASDF, Sockets, Gray streams, MOP, and other useful components.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32 "0qjv3z274rbdmb941hy03hl63f4z7bmci234f8dyz4skgfr82d3i"))
(patches (search-patches "clisp-remove-failing-test.patch"))))
(patches (search-patches "clisp-glibc-2.26.patch"
"clisp-remove-failing-test.patch"))))
(build-system gnu-build-system)
(inputs `(("libffcall" ,libffcall)
("ncurses" ,ncurses)

View File

@ -0,0 +1,20 @@
This patch comes from Debian.
Description: cfree is not present in glibc-2.26, stop wrapping it
Author: Adam Conrad <adconrad@ubuntu.com>
Bug: https://sourceforge.net/p/clisp/bugs/717/
Bug-Debian: https://bugs.debian.org/880686
Applied-Upstream: https://sourceforge.net/p/clisp/clisp/ci/3bc928712d150ff1e5f6b2bfb7838655f3ff52fa/
Reviewed-By: Sébastien Villemot <sebastien@debian.org>
Last-Update: 2017-11-27
--- clisp-2.49.20170913.orig/modules/bindings/glibc/linux.lisp
+++ clisp-2.49.20170913/modules/bindings/glibc/linux.lisp
@@ -649,7 +649,6 @@
(def-call-out calloc (:arguments (nmemb size_t) (size size_t))
(:return-type c-pointer))
(def-call-out free (:arguments (ptr c-pointer)) (:return-type nil))
-(def-call-out cfree (:arguments (ptr c-pointer)) (:return-type nil))
(def-call-out valloc (:arguments (size size_t)) (:return-type c-pointer))
(def-call-out abort (:arguments) (:return-type nil))