gnu: xapian: Fix notmuch test failure.
* gnu/packages/patches/xapian-revert-5489fb2f8.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/search.scm (xapian)[source](patches): Use it.
This commit is contained in:
parent
9866825961
commit
7519dc95c7
|
@ -1214,6 +1214,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/wpa-supplicant-krack-followups.patch \
|
||||
%D%/packages/patches/wxmaxima-do-not-use-old-gnuplot-parameters.patch \
|
||||
%D%/packages/patches/x265-fix-ppc64le-build.patch \
|
||||
%D%/packages/patches/xapian-revert-5489fb2f8.patch \
|
||||
%D%/packages/patches/xboing-CVE-2004-0149.patch \
|
||||
%D%/packages/patches/xdotool-fix-makefile.patch \
|
||||
%D%/packages/patches/xf86-video-ark-remove-mibstore.patch \
|
||||
|
|
|
@ -0,0 +1,23 @@
|
|||
Revert this upstream commit which breaks a test case in "notmuch":
|
||||
|
||||
https://git.xapian.org/?p=xapian;a=commitdiff;h=5489fb2f838c0f0b0a593b4c17df282a93a1fe5a
|
||||
|
||||
See the notmuch FAQ entry:
|
||||
|
||||
https://notmuchmail.org/faq/#index12h2
|
||||
|
||||
This should be fixed for later releases.
|
||||
|
||||
diff --git a/backends/glass/glass_postlist.cc b/xapian-core/backends/glass/glass_postlist.cc
|
||||
index 80e578b85..a47f14a68 100644
|
||||
--- a/backends/glass/glass_postlist.cc
|
||||
+++ b/backends/glass/glass_postlist.cc
|
||||
@@ -759,7 +759,7 @@ GlassPostList::open_nearby_postlist(const std::string & term_,
|
||||
(void)need_pos;
|
||||
if (term_.empty())
|
||||
RETURN(NULL);
|
||||
- if (!this_db.get() || this_db->postlist_table.is_modified())
|
||||
+ if (!this_db.get() || this_db->postlist_table.is_writable())
|
||||
RETURN(NULL);
|
||||
RETURN(new GlassPostList(this_db, term_, cursor->clone()));
|
||||
}
|
|
@ -52,6 +52,7 @@
|
|||
(method url-fetch)
|
||||
(uri (string-append "https://oligarchy.co.uk/xapian/" version
|
||||
"/xapian-core-" version ".tar.xz"))
|
||||
(patches (search-patches "xapian-revert-5489fb2f8.patch"))
|
||||
(sha256
|
||||
(base32 "166qpfq7pvyrj2w2x07v31ypvqg6c2xyvds5sms9h4g2sg0z23hy"))))
|
||||
(build-system gnu-build-system)
|
||||
|
|
Loading…
Reference in New Issue