gnu: scribus: Update to 1.5.5.
* gnu/packages/scribus.scm (scribus): Update to 1.5.5. [source]: Remove unnecessary patches and snippet. [description]: Change freetype to FreeType. * gnu/packages/patches/scribus-poppler.patch: Remove file. * gnu/local.mk: Apply removal.
This commit is contained in:
parent
f9ccde2460
commit
77bdfe2f13
|
@ -1293,7 +1293,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/scheme48-tests.patch \
|
||||
%D%/packages/patches/scotch-build-parallelism.patch \
|
||||
%D%/packages/patches/scotch-integer-declarations.patch \
|
||||
%D%/packages/patches/scribus-poppler.patch \
|
||||
%D%/packages/patches/sdl-libx11-1.6.patch \
|
||||
%D%/packages/patches/seq24-rename-mutex.patch \
|
||||
%D%/packages/patches/sharutils-CVE-2018-1000097.patch \
|
||||
|
|
|
@ -1,72 +0,0 @@
|
|||
Fix build with recent Poppler.
|
||||
|
||||
From d867ec3c386baaed1b8e076dd70b278863411480 Mon Sep 17 00:00:00 2001
|
||||
From: Jean Ghali <jghali@libertysurf.fr>
|
||||
Date: Mon, 30 Apr 2018 09:19:33 +0000
|
||||
Subject: [PATCH] =?UTF-8?q?#15289:=20FTBFS=201.5.4=20with=20error:=20inval?=
|
||||
=?UTF-8?q?id=20conversion=20from=20=E2=80=98const=20GooString*=E2=80=99?=
|
||||
=?UTF-8?q?=20to=20=E2=80=98GooString*=E2=80=99?=
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
git-svn-id: svn://scribus.net/trunk/Scribus@22498 11d20701-8431-0410-a711-e3c959e3b870
|
||||
---
|
||||
scribus/plugins/import/pdf/importpdf.cpp | 2 +-
|
||||
scribus/plugins/import/pdf/importpdf.h | 2 +-
|
||||
scribus/plugins/import/pdf/slaoutput.cpp | 2 +-
|
||||
scribus/plugins/import/pdf/slaoutput.h | 2 +-
|
||||
4 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/scribus/plugins/import/pdf/importpdf.cpp b/scribus/plugins/import/pdf/importpdf.cpp
|
||||
index c1802861aa..d4c5a9ba49 100644
|
||||
--- a/scribus/plugins/import/pdf/importpdf.cpp
|
||||
+++ b/scribus/plugins/import/pdf/importpdf.cpp
|
||||
@@ -1081,7 +1081,7 @@ QRectF PdfPlug::getCBox(int box, int pgNum)
|
||||
return cRect;
|
||||
}
|
||||
|
||||
-QString PdfPlug::UnicodeParsedString(GooString *s1)
|
||||
+QString PdfPlug::UnicodeParsedString(const GooString *s1)
|
||||
{
|
||||
if ( !s1 || s1->getLength() == 0 )
|
||||
return QString();
|
||||
diff --git a/scribus/plugins/import/pdf/importpdf.h b/scribus/plugins/import/pdf/importpdf.h
|
||||
index c8c5efcd0d..5249562692 100644
|
||||
--- a/scribus/plugins/import/pdf/importpdf.h
|
||||
+++ b/scribus/plugins/import/pdf/importpdf.h
|
||||
@@ -81,7 +81,7 @@ class PdfPlug : public QObject
|
||||
private:
|
||||
bool convert(const QString& fn);
|
||||
QRectF getCBox(int box, int pgNum);
|
||||
- QString UnicodeParsedString(GooString *s1);
|
||||
+ QString UnicodeParsedString(const GooString *s1);
|
||||
|
||||
QList<PageItem*> Elements;
|
||||
double baseX, baseY;
|
||||
diff --git a/scribus/plugins/import/pdf/slaoutput.cpp b/scribus/plugins/import/pdf/slaoutput.cpp
|
||||
index be1815dc29..17b6357246 100644
|
||||
--- a/scribus/plugins/import/pdf/slaoutput.cpp
|
||||
+++ b/scribus/plugins/import/pdf/slaoutput.cpp
|
||||
@@ -4252,7 +4252,7 @@ void SlaOutputDev::pushGroup(QString maskName, GBool forSoftMask, GBool alpha, b
|
||||
m_groupStack.push(gElements);
|
||||
}
|
||||
|
||||
-QString SlaOutputDev::UnicodeParsedString(GooString *s1)
|
||||
+QString SlaOutputDev::UnicodeParsedString(const GooString *s1)
|
||||
{
|
||||
if ( !s1 || s1->getLength() == 0 )
|
||||
return QString();
|
||||
diff --git a/scribus/plugins/import/pdf/slaoutput.h b/scribus/plugins/import/pdf/slaoutput.h
|
||||
index 20e8b2d311..6698c030e0 100644
|
||||
--- a/scribus/plugins/import/pdf/slaoutput.h
|
||||
+++ b/scribus/plugins/import/pdf/slaoutput.h
|
||||
@@ -266,7 +266,7 @@ class SlaOutputDev : public OutputDev
|
||||
int getBlendMode(GfxState *state);
|
||||
void applyMask(PageItem *ite);
|
||||
void pushGroup(QString maskName = "", GBool forSoftMask = gFalse, GBool alpha = gFalse, bool inverted = false);
|
||||
- QString UnicodeParsedString(GooString *s1);
|
||||
+ QString UnicodeParsedString(const GooString *s1);
|
||||
bool checkClip();
|
||||
bool pathIsClosed;
|
||||
QString CurrColorFill;
|
|
@ -47,7 +47,7 @@
|
|||
(define-public scribus
|
||||
(package
|
||||
(name "scribus")
|
||||
(version "1.5.4")
|
||||
(version "1.5.5")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -55,60 +55,7 @@
|
|||
version "/scribus-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"00ys0p6h3iq77kh72dkl0qrf7qvznq18qdrgiq10gfxja1995034"))
|
||||
(patches (append
|
||||
;; Scribus relies heavily on Poppler internals, which have
|
||||
;; changed a lot since the latest Scribus release (2018-04).
|
||||
;; Thus, we require a bunch of patches to stay compatible.
|
||||
(search-patches "scribus-poppler.patch")
|
||||
(list (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"https://github.com/scribusproject/scribus/commit/"
|
||||
"7d4ceeb5cac32287769e3c0238699e0b3e56c24d.patch"))
|
||||
(file-name "scribus-poppler-0.64.patch")
|
||||
(sha256
|
||||
(base32
|
||||
"1kr27bfzkpabrh42nsrrvlqyycdg9isbavpaa5spgmrhidcg02xj")))
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"https://github.com/scribusproject/scribus/commit/"
|
||||
"76561c1a55cd07c268f8f2b2fea888532933700b.patch"))
|
||||
(file-name "scribus-poppler-config.patch")
|
||||
(sha256
|
||||
(base32
|
||||
"01k18xjj82c3ndzp89dlpfhhdccc8z0acf8b04r592jyr5y9rc19")))
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"https://github.com/scribusproject/scribus/commit/"
|
||||
"8e05d26c19097ac2ad5b4ebbf40a3771ee6faf9c.patch"))
|
||||
(file-name "scribus-poppler-0.69.patch")
|
||||
(sha256
|
||||
(base32
|
||||
"1avdmsj5l543j0irq18nxgiw99n395jj56ih5dsal59fn0wbqk42")))
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://git.archlinux.org/svntogit/"
|
||||
"community.git/plain/trunk/scribus-"
|
||||
"poppler-0.70.patch?h=packages/scribus&id="
|
||||
"8ef43ee2fceb0753ed5a76bb0a11c84775898ffc"))
|
||||
(file-name "scribus-poppler-0.70.patch")
|
||||
(sha256
|
||||
(base32
|
||||
"0dw7ix3jaj0y1q97cmmqwb2qgdx760yhxx86wa8rnx0xhfi5x6qr"))))))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
(for-each (lambda (file)
|
||||
(substitute* file
|
||||
;; These are required for compatibility with Poppler 0.71.
|
||||
(("GBool") "bool") (("gTrue") "true") (("gFalse") "false")
|
||||
;; ...and this for Poppler 0.72.
|
||||
(("getCString") "c_str")))
|
||||
(find-files "scribus/plugins/import/pdf"))
|
||||
#t))))
|
||||
"0w9zzsiaq3f7vpxybk01c9z2b4qqg67mzpyfb2gjchz8dhdb423r"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
`(#:tests? #f ;no test target
|
||||
|
@ -118,9 +65,9 @@
|
|||
(modify-phases %standard-phases
|
||||
(add-after 'install 'wrap-program
|
||||
(lambda* (#:key inputs outputs #:allow-other-keys)
|
||||
;; Fix "ImportError: No module named _sysconfigdata_nd" where
|
||||
;; Scribus checks PATH and eventually runs system's Python
|
||||
;; instead of package's.
|
||||
;; Fix "ImportError: No module named _sysconfigdata_nd"
|
||||
;; runtime error where Scribus checks PATH and eventually
|
||||
;; runs system's Python instead of package's.
|
||||
(let* ((out (assoc-ref outputs "out"))
|
||||
(py2 (assoc-ref inputs "python")))
|
||||
(wrap-program (string-append out "/bin/scribus")
|
||||
|
@ -161,12 +108,13 @@
|
|||
(home-page "https://www.scribus.net")
|
||||
(synopsis "Desktop publishing and page layout program")
|
||||
(description
|
||||
"Scribus is a @dfn{desktop publishing} (DTP) application and can be used
|
||||
for many tasks; from brochure design to newspapers, magazines, newsletters and
|
||||
posters to technical documentation. Scribus supports professional DTP
|
||||
features, such as CMYK color and a color management system to soft proof
|
||||
images for high quality color printing, flexible PDF creation options,
|
||||
Encapsulated PostScript import/export and creation of four color separations,
|
||||
import of EPS/PS and SVG as native vector graphics, Unicode text including
|
||||
right to left scripts such as Arabic and Hebrew via freetype.")
|
||||
"Scribus is a @dfn{desktop publishing} (DTP) application and can
|
||||
be used for many tasks; from brochure design to newspapers, magazines,
|
||||
newsletters and posters to technical documentation. Scribus supports
|
||||
professional DTP features, such as CMYK color and a color management
|
||||
system to soft proof images for high quality color printing, flexible
|
||||
PDF creation options, Encapsulated PostScript import/export and
|
||||
creation of four color separations, import of EPS/PS and SVG as native
|
||||
vector graphics, Unicode text including right to left scripts such as
|
||||
Arabic and Hebrew via FreeType.")
|
||||
(license license:gpl2+)))
|
||||
|
|
Loading…
Reference in New Issue