glib: Patch around prlimit(2) failure.
* gnu/packages/glib.scm (glib)[source]: Switch to mirror://gnome. [inputs]: Add `patch/tests-prlimit'. [arguments]: Add it. * gnu/packages/patches/glib-tests-prlimit.patch: New file. * Makefile.am (dist_patch_DATA): Add it.
This commit is contained in:
parent
0b5aa854a0
commit
785db4d877
|
@ -201,6 +201,7 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/gettext-gets-undeclared.patch \
|
gnu/packages/patches/gettext-gets-undeclared.patch \
|
||||||
gnu/packages/patches/glib-tests-desktop.patch \
|
gnu/packages/patches/glib-tests-desktop.patch \
|
||||||
gnu/packages/patches/glib-tests-homedir.patch \
|
gnu/packages/patches/glib-tests-homedir.patch \
|
||||||
|
gnu/packages/patches/glib-tests-prlimit.patch \
|
||||||
gnu/packages/patches/glib-tests-timezone.patch \
|
gnu/packages/patches/glib-tests-timezone.patch \
|
||||||
gnu/packages/patches/glibc-bootstrap-system.patch \
|
gnu/packages/patches/glibc-bootstrap-system.patch \
|
||||||
gnu/packages/patches/glibc-no-ld-so-cache.patch \
|
gnu/packages/patches/glibc-no-ld-so-cache.patch \
|
||||||
|
|
|
@ -76,7 +76,7 @@ shared NFS home directories.")
|
||||||
(version "2.34.3")
|
(version "2.34.3")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "http://ftp.gnome.org/pub/gnome/sources/"
|
(uri (string-append "mirror://gnome/sources/"
|
||||||
name "/2.34/"
|
name "/2.34/"
|
||||||
name "-" version ".tar.xz"))
|
name "-" version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
|
@ -99,11 +99,14 @@ shared NFS home directories.")
|
||||||
("patch/tests-homedir"
|
("patch/tests-homedir"
|
||||||
,(search-patch "glib-tests-homedir.patch"))
|
,(search-patch "glib-tests-homedir.patch"))
|
||||||
("patch/tests-desktop"
|
("patch/tests-desktop"
|
||||||
,(search-patch "glib-tests-desktop.patch"))))
|
,(search-patch "glib-tests-desktop.patch"))
|
||||||
|
("patch/tests-prlimit"
|
||||||
|
,(search-patch "glib-tests-prlimit.patch"))))
|
||||||
(arguments
|
(arguments
|
||||||
'(#:patches (list (assoc-ref %build-inputs "patch/tests-tzdata")
|
'(#:patches (list (assoc-ref %build-inputs "patch/tests-tzdata")
|
||||||
(assoc-ref %build-inputs "patch/tests-homedir")
|
(assoc-ref %build-inputs "patch/tests-homedir")
|
||||||
(assoc-ref %build-inputs "patch/tests-desktop"))
|
(assoc-ref %build-inputs "patch/tests-desktop")
|
||||||
|
(assoc-ref %build-inputs "patch/tests-prlimit"))
|
||||||
#:phases (alist-cons-before
|
#:phases (alist-cons-before
|
||||||
'build 'pre-build
|
'build 'pre-build
|
||||||
(lambda* (#:key inputs outputs #:allow-other-keys)
|
(lambda* (#:key inputs outputs #:allow-other-keys)
|
||||||
|
|
|
@ -0,0 +1,14 @@
|
||||||
|
prlimit(2) returns ENOSYS on Linux 2.6.32-5-xen-amd64 as found on
|
||||||
|
hydra.gnu.org, and strace(1) doesn't recognize it.
|
||||||
|
|
||||||
|
--- glib-2.34.3/glib/tests/thread.c 2012-11-20 15:27:12.000000000 +0100
|
||||||
|
+++ glib-2.34.3/glib/tests/thread.c 2013-03-27 14:48:31.000000000 +0100
|
||||||
|
@@ -130,7 +130,7 @@ test_thread3 (void)
|
||||||
|
static void
|
||||||
|
test_thread4 (void)
|
||||||
|
{
|
||||||
|
-#ifdef HAVE_PRLIMIT
|
||||||
|
+#if 0
|
||||||
|
struct rlimit ol, nl;
|
||||||
|
GThread *thread;
|
||||||
|
GError *error;
|
Loading…
Reference in New Issue