gnu: multiqc: Update to 1.2.

* gnu/packages/bioinformatics.scm (multiqc): Update to 1.2.
[source]: Remove patches.
[arguments]: Remove to enable tests.
[propagated-inputs]: Add python-spectra, python-requests, python-markdown,
python-lzstring.
* gnu/packages/patches/multiqc-fix-git-subprocess-error.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Ricardo Wurmus 2017-08-30 17:12:23 +02:00 committed by Ricardo Wurmus
parent 4a7d2009c8
commit 799247d2d9
No known key found for this signature in database
GPG Key ID: 197A5888235FACAC
3 changed files with 6 additions and 24 deletions

View File

@ -853,7 +853,6 @@ dist_patch_DATA = \
%D%/packages/patches/mozjs38-shell-version.patch \
%D%/packages/patches/mozjs38-tracelogger.patch \
%D%/packages/patches/mozjs38-version-detection.patch \
%D%/packages/patches/multiqc-fix-git-subprocess-error.patch \
%D%/packages/patches/mumps-build-parallelism.patch \
%D%/packages/patches/mupdf-build-with-openjpeg-2.1.patch \
%D%/packages/patches/mupen64plus-ui-console-notice.patch \

View File

@ -8575,25 +8575,24 @@ replacement for strverscmp.")
(define-public multiqc
(package
(name "multiqc")
(version "0.9")
(version "1.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "multiqc" version))
(sha256
(base32
"12gs1jw2jrxrij529rnl5kaqxfcqn15yzcsggxkfhdx634ml0cny"))
(patches (search-patches "multiqc-fix-git-subprocess-error.patch"))))
"032svgym67k2ds7wp0cxzv79gi30yrdl45zbqn74lni3dk04qm33"))))
(build-system python-build-system)
(arguments
;; Tests are to be introduced in the next version, see
;; https://github.com/ewels/MultiQC/issues/376
`(#:tests? #f))
(propagated-inputs
`(("python-jinja2" ,python-jinja2)
("python-simplejson" ,python-simplejson)
("python-pyyaml" ,python-pyyaml)
("python-click" ,python-click)
("python-spectra" ,python-spectra)
("python-requests" ,python-requests)
("python-markdown" ,python-markdown)
("python-lzstring" ,python-lzstring)
("python-matplotlib" ,python-matplotlib)
("python-numpy" ,python-numpy)
;; MultQC checks for the presence of nose at runtime.

View File

@ -1,16 +0,0 @@
Without this patch, the incorrect exception is caught when 'git' is not in
PATH. See https://github.com/ewels/MultiQC/pull/377.
diff --git a/multiqc/utils/config.py b/multiqc/utils/config.py
index 01fa554..4a11793 100755
--- a/multiqc/utils/config.py
+++ b/multiqc/utils/config.py
@@ -28,7 +28,7 @@ try:
git_hash = subprocess.check_output(['git', 'rev-parse', 'HEAD'], stderr=subprocess.STDOUT)
git_hash_short = git_hash[:7]
version = '{} ({})'.format(version, git_hash_short)
-except subprocess.CalledProcessError:
+except (subprocess.CalledProcessError, FileNotFoundError):
pass
os.chdir(cwd)