gnu: hmmer: Build reproducibly.
* gnu/packages/patches/hmmer-remove-cpu-specificity.patch: New file. * gnu/packages/bioinformatics.scm (hmmer): Use it.
This commit is contained in:
parent
5ded35d89d
commit
79f09fa239
|
@ -2839,15 +2839,17 @@ indexing scheme is called a @dfn{Hierarchical Graph FM index} (HGFM).")
|
|||
(package
|
||||
(name "hmmer")
|
||||
(version "3.1b2")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"http://eddylab.org/software/hmmer"
|
||||
(version-prefix version 1) "/"
|
||||
version "/hmmer-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0djmgc0pfli0jilfx8hql1axhwhqxqb8rxg2r5rg07aw73sfs5nx"))))
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"http://eddylab.org/software/hmmer"
|
||||
(version-prefix version 1) "/"
|
||||
version "/hmmer-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0djmgc0pfli0jilfx8hql1axhwhqxqb8rxg2r5rg07aw73sfs5nx"))
|
||||
(patches (search-patches "hmmer-remove-cpu-specificity.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs `(("perl" ,perl)))
|
||||
(home-page "http://hmmer.org/")
|
||||
|
|
|
@ -0,0 +1,22 @@
|
|||
This patch removes compilation flags which make the build for the machine
|
||||
where compilation takes place, rendering the build not reproducible.
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 8b6aaef..49a6afc 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -6125,14 +6125,6 @@ fi # guess arch
|
||||
|
||||
if test "x$ax_gcc_arch" != x -a "x$ax_gcc_arch" != xno; then
|
||||
for arch in $ax_gcc_arch; do
|
||||
- if test "x$acx_maxopt_portable" = xyes; then # if we require portable code
|
||||
- flags="-mtune=$arch"
|
||||
- # -mcpu=$arch and m$arch generate nonportable code on every arch except
|
||||
- # x86. And some other arches (e.g. Alpha) don't accept -mtune. Grrr.
|
||||
- case $host_cpu in i*86|x86_64*) flags="$flags -mcpu=$arch -m$arch";; esac
|
||||
- else
|
||||
- flags="-march=$arch -mcpu=$arch -m$arch"
|
||||
- fi
|
||||
for flag in $flags; do
|
||||
as_CACHEVAR=`$as_echo "ax_cv_check_cflags__$flag" | $as_tr_sh`
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts $flag" >&5
|
Loading…
Reference in New Issue