gnu: delly: Update to 0.7.9.
* gnu/packages/bioinformatics.scm (delly): Update to 0.7.9. [source]: Fetch from git. [arguments]: Add phase install-templates; use default install phase. [native-inputs]: Remove python-2. [home-page]: Use new home page. * gnu/packages/patches/delly-use-system-libraries.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove patch.
This commit is contained in:
parent
4d494a4fa3
commit
7a1e62ca67
|
@ -642,7 +642,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/datamash-arm-tests.patch \
|
%D%/packages/patches/datamash-arm-tests.patch \
|
||||||
%D%/packages/patches/dbus-helper-search-path.patch \
|
%D%/packages/patches/dbus-helper-search-path.patch \
|
||||||
%D%/packages/patches/deja-dup-use-ref-keyword-for-iter.patch \
|
%D%/packages/patches/deja-dup-use-ref-keyword-for-iter.patch \
|
||||||
%D%/packages/patches/delly-use-system-libraries.patch \
|
|
||||||
%D%/packages/patches/dfu-programmer-fix-libusb.patch \
|
%D%/packages/patches/dfu-programmer-fix-libusb.patch \
|
||||||
%D%/packages/patches/diffutils-gets-undeclared.patch \
|
%D%/packages/patches/diffutils-gets-undeclared.patch \
|
||||||
%D%/packages/patches/diffutils-getopt.patch \
|
%D%/packages/patches/diffutils-getopt.patch \
|
||||||
|
|
|
@ -2155,42 +2155,42 @@ identify enrichments with functional annotations of the genome.")
|
||||||
(define-public delly
|
(define-public delly
|
||||||
(package
|
(package
|
||||||
(name "delly")
|
(name "delly")
|
||||||
(version "0.7.7")
|
(version "0.7.9")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method git-fetch)
|
||||||
(uri (string-append
|
(uri (git-reference
|
||||||
"https://github.com/tobiasrausch/delly/archive/v"
|
(url "https://github.com/dellytools/delly.git")
|
||||||
version ".tar.gz"))
|
(commit (string-append "v" version))))
|
||||||
(file-name (string-append name "-" version ".tar.gz"))
|
(file-name (git-file-name name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0dkwy3pyxmi6dhh1lpsr3698ri5sslw9qz67hfys0bz8dgrqwabj"))
|
(base32 "034jqsxswy9gqdh2zkgc1js99qkv75ks4xvzgmh0284sraagv61z"))
|
||||||
(patches (search-patches "delly-use-system-libraries.patch"))))
|
(modules '((guix build utils)))
|
||||||
|
(snippet
|
||||||
|
'(begin
|
||||||
|
(delete-file-recursively "src/htslib")
|
||||||
|
#t))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:tests? #f ; There are no tests to run.
|
`(#:tests? #f ; There are no tests to run.
|
||||||
#:make-flags '("PARALLEL=1") ; Allow parallel execution at run-time.
|
#:make-flags
|
||||||
|
(list "PARALLEL=1" ; Allow parallel execution at run-time.
|
||||||
|
(string-append "prefix=" (assoc-ref %outputs "out")))
|
||||||
#:phases
|
#:phases
|
||||||
(modify-phases %standard-phases
|
(modify-phases %standard-phases
|
||||||
(delete 'configure) ; There is no configure phase.
|
(delete 'configure) ; There is no configure phase.
|
||||||
(replace 'install
|
(add-after 'install 'install-templates
|
||||||
(lambda _
|
(lambda* (#:key outputs #:allow-other-keys)
|
||||||
(let ((bin (string-append (assoc-ref %outputs "out") "/bin"))
|
(let ((templates (string-append (assoc-ref outputs "out")
|
||||||
(templates (string-append (assoc-ref %outputs "out")
|
|
||||||
"/share/delly/templates")))
|
"/share/delly/templates")))
|
||||||
(mkdir-p bin)
|
|
||||||
(mkdir-p templates)
|
(mkdir-p templates)
|
||||||
(copy-recursively "excludeTemplates" templates)
|
(copy-recursively "excludeTemplates" templates)
|
||||||
(install-file "src/cov" bin)
|
#t))))))
|
||||||
(install-file "src/delly" bin)
|
|
||||||
(install-file "src/dpe" bin)))))))
|
|
||||||
(native-inputs
|
|
||||||
`(("python" ,python-2)))
|
|
||||||
(inputs
|
(inputs
|
||||||
`(("boost" ,boost)
|
`(("boost" ,boost)
|
||||||
("htslib" ,htslib)
|
("htslib" ,htslib)
|
||||||
("zlib" ,zlib)
|
("zlib" ,zlib)
|
||||||
("bzip2" ,bzip2)))
|
("bzip2" ,bzip2)))
|
||||||
(home-page "https://github.com/tobiasrausch/delly")
|
(home-page "https://github.com/dellytools/delly")
|
||||||
(synopsis "Integrated structural variant prediction method")
|
(synopsis "Integrated structural variant prediction method")
|
||||||
(description "Delly is an integrated structural variant prediction method
|
(description "Delly is an integrated structural variant prediction method
|
||||||
that can discover and genotype deletions, tandem duplications, inversions and
|
that can discover and genotype deletions, tandem duplications, inversions and
|
||||||
|
|
|
@ -1,56 +0,0 @@
|
||||||
--- a/Makefile 2017-04-09 12:48:15.000000000 +0200
|
|
||||||
+++ b/Makefile 2017-06-21 14:26:02.749282787 +0200
|
|
||||||
@@ -9,8 +9,8 @@
|
|
||||||
|
|
||||||
# Flags
|
|
||||||
CXX=g++
|
|
||||||
-CXXFLAGS += -isystem ${SEQTK_ROOT} -isystem ${BOOST_ROOT} -pedantic -W -Wall -Wno-unknown-pragmas -D__STDC_LIMIT_MACROS -fno-strict-aliasing
|
|
||||||
-LDFLAGS += -L${SEQTK_ROOT} -L${BOOST_ROOT}/stage/lib -lboost_iostreams -lboost_filesystem -lboost_system -lboost_program_options -lboost_date_time
|
|
||||||
+CXXFLAGS += -pedantic -W -Wall -Wno-unknown-pragmas -D__STDC_LIMIT_MACROS -fno-strict-aliasing
|
|
||||||
+LDFLAGS += -lboost_iostreams -lboost_filesystem -lboost_system -lboost_program_options -lboost_date_time
|
|
||||||
|
|
||||||
# Additional flags for release/debug
|
|
||||||
ifeq (${PARALLEL}, 1)
|
|
||||||
@@ -23,7 +23,7 @@
|
|
||||||
ifeq (${STATIC}, 1)
|
|
||||||
LDFLAGS += -static -static-libgcc -pthread -lhts -lz
|
|
||||||
else
|
|
||||||
- LDFLAGS += -lhts -lz -Wl,-rpath,${SEQTK_ROOT},-rpath,${BOOST_ROOT}/stage/lib
|
|
||||||
+ LDFLAGS += -lhts -lz
|
|
||||||
endif
|
|
||||||
ifeq (${DEBUG}, 1)
|
|
||||||
CXXFLAGS += -g -O0 -fno-inline -DDEBUG
|
|
||||||
@@ -41,29 +41,17 @@
|
|
||||||
DELLYSOURCES = $(wildcard src/*.h) $(wildcard src/*.cpp)
|
|
||||||
|
|
||||||
# Targets
|
|
||||||
-TARGETS = .htslib .bcftools .boost src/delly src/cov src/dpe
|
|
||||||
+TARGETS = src/delly src/cov src/dpe
|
|
||||||
|
|
||||||
all: $(TARGETS)
|
|
||||||
|
|
||||||
-.htslib: $(HTSLIBSOURCES)
|
|
||||||
- cd src/htslib && make && make lib-static && cd ../../ && touch .htslib
|
|
||||||
-
|
|
||||||
-.bcftools: $(HTSLIBSOURCES)
|
|
||||||
- cd src/bcftools && make && cd ../../ && touch .bcftools
|
|
||||||
-
|
|
||||||
-.boost: $(BOOSTSOURCES)
|
|
||||||
- cd src/modular-boost && ./bootstrap.sh --prefix=${PWD}/src/modular-boost --without-icu --with-libraries=iostreams,filesystem,system,program_options,date_time && ./b2 && ./b2 headers && cd ../../ && touch .boost
|
|
||||||
-
|
|
||||||
-src/delly: .htslib .bcftools .boost $(DELLYSOURCES)
|
|
||||||
- $(CXX) $(CXXFLAGS) $@.cpp -o $@ $(LDFLAGS)
|
|
||||||
-
|
|
||||||
-src/cov: .htslib .bcftools .boost $(DELLYSOURCES)
|
|
||||||
+src/cov: $(DELLYSOURCES)
|
|
||||||
$(CXX) $(CXXFLAGS) $@.cpp -o $@ $(LDFLAGS)
|
|
||||||
|
|
||||||
-src/dpe: .htslib .bcftools .boost $(DELLYSOURCES)
|
|
||||||
+src/dpe: $(DELLYSOURCES)
|
|
||||||
$(CXX) $(CXXFLAGS) $@.cpp -o $@ $(LDFLAGS)
|
|
||||||
|
|
||||||
clean:
|
|
||||||
cd src/htslib && make clean
|
|
||||||
cd src/modular-boost && ./b2 --clean-all
|
|
||||||
- rm -f $(TARGETS) $(TARGETS:=.o) .htslib .boost .bcftools
|
|
||||||
+ rm -f $(TARGETS) $(TARGETS:=.o)
|
|
Loading…
Reference in New Issue