gnu: qtoctave: Fix build for Qt 5.11.

* gnu/packages/maths.scm (qtoctave)[source]: Add patch.
[native-inputs]: Add texlive.
* gnu/packages/patches/qtoctave-qt-5.11-fix.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
master
Kei Kebreau 2018-06-30 20:03:42 -04:00
parent 1314d34939
commit 7a3772b374
No known key found for this signature in database
GPG Key ID: E6A5EE3C19467A0D
3 changed files with 33 additions and 0 deletions

View File

@ -1088,6 +1088,7 @@ dist_patch_DATA = \
%D%/packages/patches/qemu-CVE-2018-11806.patch \
%D%/packages/patches/qt4-ldflags.patch \
%D%/packages/patches/qtbase-use-TZDIR.patch \
%D%/packages/patches/qtoctave-qt-5.11-fix.patch \
%D%/packages/patches/qtscript-disable-tests.patch \
%D%/packages/patches/quagga-reproducible-build.patch \
%D%/packages/patches/quassel-qt-5.11.patch \

View File

@ -1400,12 +1400,18 @@ script files.")
(define-public qtoctave
(package (inherit octave)
(name "qtoctave")
(source (origin
(inherit (package-source octave))
(patches (append (origin-patches (package-source octave))
(search-patches
"qtoctave-qt-5.11-fix.patch")))))
(inputs
`(("qscintilla" ,qscintilla)
("qt" ,qtbase)
,@(package-inputs octave)))
(native-inputs
`(("qttools" , qttools) ;for lrelease
("texlive" ,texlive) ;for texi2dvi
,@(package-native-inputs octave)))
(arguments
(substitute-keyword-arguments (package-arguments octave)

View File

@ -0,0 +1,26 @@
This patch comes from upstream:
https://hg.savannah.gnu.org/hgweb/octave/rev/cdaa884568b1.
# HG changeset patch
# User Mike Miller <mtmiller@octave.org>
# Date 1527214835 25200
# Node ID cdaa884568b159549bd373f04386ff62417f6df9
# Parent 9e39a53b4e007d3f79f88b711ab9fa5f2f24fbc9
add Qt include needed to build against Qt 5.11 (bug #53978)
* settings-dialog.cc: Add missing include for <QButtonGroup> to fix build
failure with Qt 5.11.
diff --git a/libgui/src/settings-dialog.cc b/libgui/src/settings-dialog.cc
--- a/libgui/src/settings-dialog.cc
+++ b/libgui/src/settings-dialog.cc
@@ -34,6 +34,8 @@
#include "workspace-model.h"
#include "settings-dialog.h"
#include "ui-settings-dialog.h"
+
+#include <QButtonGroup>
#include <QDir>
#include <QFileInfo>
#include <QFileDialog>