gnu: gnunet: Fix failing testcases.
* gnu/packages/gnunet.scm (gnurl): Add pkg-config. * gnu/packages/patches/gnunet-fix-tests.patch: Append fix for integration testcases. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
bdff90a16a
commit
7af52bd58c
|
@ -153,8 +153,9 @@ and support for SSL3 and TLS.")
|
||||||
("libidn" ,libidn)
|
("libidn" ,libidn)
|
||||||
("zlib" ,zlib)))
|
("zlib" ,zlib)))
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("perl" ,perl)
|
`(("groff" ,groff)
|
||||||
("groff" ,groff)
|
("perl" ,perl)
|
||||||
|
("pkg-config" ,pkg-config)
|
||||||
("python" ,python-2)))
|
("python" ,python-2)))
|
||||||
(arguments
|
(arguments
|
||||||
`(#:configure-flags '("--enable-ipv6" "--with-gnutls" "--without-libssh2"
|
`(#:configure-flags '("--enable-ipv6" "--with-gnutls" "--without-libssh2"
|
||||||
|
@ -211,7 +212,8 @@ supports HTTPS, HTTPS and GnuTLS.")
|
||||||
(search-patch "gnunet-fix-scheduler.patch")
|
(search-patch "gnunet-fix-scheduler.patch")
|
||||||
;; Patch to fix bugs in testcases:
|
;; Patch to fix bugs in testcases:
|
||||||
;; * Disable peerinfo-tool tests as they depend on reverse DNS lookups
|
;; * Disable peerinfo-tool tests as they depend on reverse DNS lookups
|
||||||
;; * Allow revocation testcase to run on loopback; upstream: #32130
|
;; * Allow revocation and integration-tests testcases to run on
|
||||||
|
;; loopback; upstream: #32130, #32326
|
||||||
;; * Skip GNS testcases requiring DNS lookups; upstream: #32118
|
;; * Skip GNS testcases requiring DNS lookups; upstream: #32118
|
||||||
(search-patch "gnunet-fix-tests.patch")))
|
(search-patch "gnunet-fix-tests.patch")))
|
||||||
(patch-flags '("-p0"))))
|
(patch-flags '("-p0"))))
|
||||||
|
|
|
@ -44,3 +44,15 @@ Index: src/gns/test_gns_cname_lookup.sh
|
||||||
rm -rf /tmp/test-gnunet-gns-peer-1/
|
rm -rf /tmp/test-gnunet-gns-peer-1/
|
||||||
|
|
||||||
TEST_DOMAIN_PLUS="www.gnu"
|
TEST_DOMAIN_PLUS="www.gnu"
|
||||||
|
Index: src/integration-tests/confs/test_defaults.conf
|
||||||
|
===================================================================
|
||||||
|
--- src/integration-tests/confs/test_defaults.conf (revision 32320)
|
||||||
|
+++ src/integration-tests/confs/test_defaults.conf (working copy)
|
||||||
|
@@ -17,6 +17,7 @@
|
||||||
|
EXTERNAL_ADDRESS = 127.0.0.1
|
||||||
|
INTERNAL_ADDRESS = 127.0.0.1
|
||||||
|
BINDTO = 127.0.0.1
|
||||||
|
+RETURN_LOCAL_ADDRESSES = YES
|
||||||
|
|
||||||
|
[hostlist]
|
||||||
|
SERVERS =
|
||||||
|
|
Loading…
Reference in New Issue