gnu: libvirt: Update to 5.6.0.

* gnu/packages/virtualization.scm (libvirt): Update to 5.6.0.
[source]: Remove patch.
* gnu/packages/patches/libvirt-remove-ATTRIBUTE_UNUSED.patch:
Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Tobias Geerinckx-Rice 2019-08-05 20:59:32 +02:00
parent d866acca9a
commit 7b88b71120
No known key found for this signature in database
GPG Key ID: 0DB0FF884F556D79
3 changed files with 2 additions and 39 deletions

View File

@ -1045,7 +1045,6 @@ dist_patch_DATA = \
%D%/packages/patches/libutils-add-includes.patch \
%D%/packages/patches/libutils-remove-damaging-includes.patch \
%D%/packages/patches/libvdpau-va-gl-unbundle.patch \
%D%/packages/patches/libvirt-remove-ATTRIBUTE_UNUSED.patch \
%D%/packages/patches/libvpx-CVE-2016-2818.patch \
%D%/packages/patches/libvpx-use-after-free-in-postproc.patch \
%D%/packages/patches/libxslt-generated-ids.patch \

View File

@ -1,34 +0,0 @@
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Thu, 25 Jul 2019 21:48:25 +0200
Subject: [PATCH]: libvirt: remove ATTRIBUTE_UNUSED
This should fix the error reported here[0]. Patch taken verbatim from
upstream[1].
[0]: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=36634#28
[1]: https://github.com/libvirt/libvirt/commit/759bf903a6c24a8efa25c7cf4b099d952eda9bd3
From 759bf903a6c24a8efa25c7cf4b099d952eda9bd3 Mon Sep 17 00:00:00 2001
From: Pavel Hrdina <phrdina@redhat.com>
Date: Mon, 22 Jul 2019 14:46:34 +0200
Subject: [PATCH] vircgroupv2: remove ATTRIBUTE_UNUSED for used attribute
Signed-off-by: Pavel Hrdina <phrdina@redhat.com>
Acked-by: Peter Krempa <pkrempa@redhat.com>
---
src/util/vircgroupv2.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/util/vircgroupv2.c b/src/util/vircgroupv2.c
index af3192c99c..e36c36685b 100644
--- a/src/util/vircgroupv2.c
+++ b/src/util/vircgroupv2.c
@@ -399,7 +399,7 @@ virCgroupV2EnableController(virCgroupPtr group,
static int
-virCgroupV2MakeGroup(virCgroupPtr parent ATTRIBUTE_UNUSED,
+virCgroupV2MakeGroup(virCgroupPtr parent,
virCgroupPtr group,
bool create,
unsigned int flags)

View File

@ -390,16 +390,14 @@ manage system or application containers.")
(define-public libvirt
(package
(name "libvirt")
(version "5.5.0")
(version "5.6.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://libvirt.org/sources/libvirt-"
version ".tar.xz"))
(sha256
(base32 "1s1mzw4cmkcfivs1kphpgy4lpddx0w1qnjysr4ggk5558w4yy1i3"))
(patches
(search-patches "libvirt-remove-ATTRIBUTE_UNUSED.patch"))))
(base32 "1d5rmcx5fgb024hw8chbiv886n3jal5wp2yajjk5l4qh9s9gkx35"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags