gnu: doxygen: Update to 1.8.11.

* gnu/packages/doxygen.scm (doxygen)[source]: Update to 1.8.11.
  Drop one patch.
  [build-system]: Switch to cmake-build-system, since gnu-build-system
  is not supported any more.
  [arguments]: Adapt.
  [native-inputs]: Drop unused perl.
* gnu/packages/patches/doxygen-tmake.patch: Remove file.
* gnu/packages/patches/doxygen-test.patch: Adapt.
* gnu-system.am (dist_patch_DATA): Unregister patch.
This commit is contained in:
Andreas Enge 2016-01-20 13:09:53 +01:00
parent 252ddedd4b
commit 7c853c02b8
4 changed files with 9 additions and 47 deletions

View File

@ -447,7 +447,6 @@ dist_patch_DATA = \
gnu/packages/patches/diffutils-gets-undeclared.patch \ gnu/packages/patches/diffutils-gets-undeclared.patch \
gnu/packages/patches/dfu-programmer-fix-libusb.patch \ gnu/packages/patches/dfu-programmer-fix-libusb.patch \
gnu/packages/patches/doxygen-test.patch \ gnu/packages/patches/doxygen-test.patch \
gnu/packages/patches/doxygen-tmake.patch \
gnu/packages/patches/duplicity-piped-password.patch \ gnu/packages/patches/duplicity-piped-password.patch \
gnu/packages/patches/duplicity-test_selection-tmp.patch \ gnu/packages/patches/duplicity-test_selection-tmp.patch \
gnu/packages/patches/elfutils-tests-ptrace.patch \ gnu/packages/patches/elfutils-tests-ptrace.patch \

View File

@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU ;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Andreas Enge <andreas@enge.fr> ;;; Copyright © 2014, 2016 Andreas Enge <andreas@enge.fr>
;;; ;;;
;;; This file is part of GNU Guix. ;;; This file is part of GNU Guix.
;;; ;;;
@ -20,7 +20,7 @@
#:use-module ((guix licenses) #:select (gpl3+)) #:use-module ((guix licenses) #:select (gpl3+))
#:use-module (guix packages) #:use-module (guix packages)
#:use-module (guix download) #:use-module (guix download)
#:use-module (guix build-system gnu) #:use-module (guix build-system cmake)
#:use-module (gnu packages) #:use-module (gnu packages)
#:use-module (gnu packages bison) #:use-module (gnu packages bison)
#:use-module (gnu packages flex) #:use-module (gnu packages flex)
@ -32,38 +32,25 @@
(define-public doxygen (define-public doxygen
(package (package
(name "doxygen") (name "doxygen")
(version "1.8.7") (version "1.8.11")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "http://ftp.stack.nl/pub/users/dimitri/" (uri (string-append "http://ftp.stack.nl/pub/users/dimitri/"
name "-" version ".src.tar.gz")) name "-" version ".src.tar.gz"))
(sha256 (sha256
(base32 (base32
"1ng3dv5fninhfi2fj75ghkr5jwsl653fxv2sxhaswj11x2vcdsn6")) "0ja02pm3fpfhc5dkry00kq8mn141cqvdqqpmms373ncbwi38pl35"))
(patches (list (search-patch "doxygen-tmake.patch") (patches (list (search-patch "doxygen-test.patch")))))
(search-patch "doxygen-test.patch"))))) (build-system cmake-build-system)
(build-system gnu-build-system)
(native-inputs (native-inputs
`(("bison" ,bison) `(("bison" ,bison)
("flex" ,flex) ("flex" ,flex)
("libxml2" ,libxml2) ; provides xmllint for the tests ("libxml2" ,libxml2) ; provides xmllint for the tests
("perl" ,perl) ; for the tests
("python" ,python-2))) ; for creating the documentation ("python" ,python-2))) ; for creating the documentation
(propagated-inputs (propagated-inputs
`(("graphviz" ,graphviz))) `(("graphviz" ,graphviz)))
(arguments (arguments
`(#:test-target "test" `(#:test-target "tests"))
#:phases
(alist-replace
'configure
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
;; do not pass "--enable-fast-install", which makes the
;; configure process fail
(zero? (system*
"./configure"
"--prefix" out))))
%standard-phases)))
(home-page "http://www.stack.nl/~dimitri/doxygen/") (home-page "http://www.stack.nl/~dimitri/doxygen/")
(synopsis "Generate documentation from annotated sources") (synopsis "Generate documentation from annotated sources")
(description "Doxygen is the de facto standard tool for generating (description "Doxygen is the de facto standard tool for generating

View File

@ -31,8 +31,8 @@ diff -u -r doxygen-1.8.7.orig/testing/012/indexpage.xml doxygen-1.8.7/testing/01
<title>My Project</title> <title>My Project</title>
<detaileddescription> <detaileddescription>
- <para>See <ref refid="citelist_1CITEREF_knuth79" kindref="member">[1]</ref> for more info. </para> - <para>See <ref refid="citelist_1CITEREF_knuth79" kindref="member">[1]</ref> for more info. </para>
+ <para>See <ref refid="citelist_1CITEREF_knuth79" kindref="member">knuth79</ref> for more info. </para> + <para>See knuth79 for more info. </para>
</detaileddescription> </detaileddescription>
</compounddef> </compounddef>
</doxygen> </doxygen>
Nur in doxygen-1.8.7/testing: test_output_012.

View File

@ -1,24 +0,0 @@
Fix the `check_unix' function, which looks for `/bin/uname' to determine
whether we're on a Unix-like system.
Taken from nixpkgs.
--- doxygen-1.5.8/tmake/bin/tmake 2008-12-06 14:16:20.000000000 +0100
+++ doxygen-1.5.8/tmake/bin/tmake 2009-03-05 11:29:55.000000000 +0100
@@ -234,17 +234,7 @@ sub tmake_verb {
#
sub check_unix {
- my($r);
- $r = 0;
- if ( -f "/bin/uname" ) {
- $r = 1;
- (-f "\\bin\\uname") && ($r = 0);
- }
- if ( -f "/usr/bin/uname" ) {
- $r = 1;
- (-f "\\usr\\bin\\uname") && ($r = 0);
- }
- return $r;
+ return 1;
}