gnu: gnucash: Convert price-quotes-perl patch to a phase.

* gnu/packages/patches/gnucash-price-quotes-perl.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Unregister it.
* gnu/packages/gnucash.scm (gnucash)[patches]: Remove it.
[phases]{fix-finance-quote-check}: Implement it using SUBSTITUTES*.
master
Maxim Cournoyer 2019-01-03 18:07:16 -05:00
parent 20626f62c4
commit 7c8ea31ac9
No known key found for this signature in database
GPG Key ID: 1260E46482E63562
3 changed files with 8 additions and 27 deletions

View File

@ -831,7 +831,6 @@ dist_patch_DATA = \
%D%/packages/patches/gmp-faulty-test.patch \
%D%/packages/patches/gnome-todo-libical-compat.patch \
%D%/packages/patches/gnome-tweak-tool-search-paths.patch \
%D%/packages/patches/gnucash-price-quotes-perl.patch \
%D%/packages/patches/gnucash-disable-failing-tests.patch \
%D%/packages/patches/gnucash-fix-test-transaction-failure.patch \
%D%/packages/patches/gnutls-skip-trust-store-test.patch \

View File

@ -60,8 +60,7 @@
(sha256
(base32
"0grr5qi5rn1xvr7qx5d7mcxa2mcgycy2b325ry73bb485a6yv5l3"))
(patches (search-patches "gnucash-price-quotes-perl.patch"
"gnucash-disable-failing-tests.patch"
(patches (search-patches "gnucash-disable-failing-tests.patch"
"gnucash-fix-test-transaction-failure.patch"))))
(build-system cmake-build-system)
(inputs
@ -119,6 +118,13 @@
(("set\\(SHELL /bin/bash\\)")
(string-append "set(SHELL " (which "bash") ")")))
#t)))
;; After wrapping gnc-fq-check and gnc-fq-helper we can no longer
;; execute them with perl, so execute them directly instead.
(add-after 'unpack 'fix-finance-quote-check
(lambda _
(substitute* "libgnucash/scm/price-quotes.scm"
(("\"perl\" \"-w\" ") ""))
#t))
;; There are about 100 megabytes of documentation.
(add-after 'install 'install-docs
(lambda* (#:key inputs outputs #:allow-other-keys)

View File

@ -1,24 +0,0 @@
After wrapping gnc-fq-check and gnc-fq-helper we can no longer execute them
with perl, so execute them directly instead.
diff -ur gnucash-3.2.old/libgnucash/scm/price-quotes.scm gnucash-3.2/libgnucash/scm/price-quotes.scm
--- gnucash-3.2.old/libgnucash/scm/price-quotes.scm 2018-09-15 00:48:33.718389646 -0400
+++ gnucash-3.2/libgnucash/scm/price-quotes.scm 2018-09-15 13:51:49.249862724 -0400
@@ -74,7 +74,7 @@
(define (start-program)
(if (not (string-null? gnc:*finance-quote-check*))
(set! program (gnc-spawn-process-async
- (list "perl" "-w" gnc:*finance-quote-check*) #t))))
+ (list gnc:*finance-quote-check*) #t))))
(define (get-sources)
(if (not (null? program))
@@ -158,7 +158,7 @@
(define (start-quoter)
(if (not (string-null? gnc:*finance-quote-helper*))
(set! quoter (gnc-spawn-process-async
- (list "perl" "-w" gnc:*finance-quote-helper*) #t))))
+ (list gnc:*finance-quote-helper*) #t))))
(define (get-quotes)
(if (not (null? quoter))