gnu: network-manager: Fix plugin loading problem.
* gnu/packages/patches/nm-plugin-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gnome.scm (network-manager)[source](patches): New field. Signed-off-by: Jelle Licht <jlicht@fsfe.org>
This commit is contained in:
parent
e13714b642
commit
7d1861e2d2
|
@ -1115,6 +1115,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/netsurf-longer-test-timeout.patch \
|
||||
%D%/packages/patches/nfs-utils-missing-headers.patch \
|
||||
%D%/packages/patches/ngircd-handle-zombies.patch \
|
||||
%D%/packages/patches/nm-plugin-path.patch \
|
||||
%D%/packages/patches/nss-increase-test-timeout.patch \
|
||||
%D%/packages/patches/nss-pkgconfig.patch \
|
||||
%D%/packages/patches/ntfs-3g-CVE-2019-9755.patch \
|
||||
|
|
|
@ -5297,6 +5297,7 @@ users.")
|
|||
(uri (string-append "mirror://gnome/sources/NetworkManager/"
|
||||
(version-major+minor version) "/"
|
||||
"NetworkManager-" version ".tar.xz"))
|
||||
(patches (search-patches "nm-plugin-path.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"1jn3g0f2x1irc88awqp8m3gnpdx1whqqqbdgkbgr4x55s702jki4"))
|
||||
|
|
|
@ -0,0 +1,51 @@
|
|||
From d3026a6d331298003ccc6cd9d2e20dcb7fa9ae1d Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Tom=C3=A1=C5=A1=20=C4=8Cech?= <sleep_walker@gnu.org>
|
||||
Date: Wed, 3 Jul 2019 13:31:54 +0200
|
||||
Subject: [PATCH] respect NM_VPN_PLUGIN_DIR
|
||||
|
||||
---
|
||||
src/vpn/nm-vpn-manager.c | 14 ++++++++++++++
|
||||
1 file changed, 14 insertions(+)
|
||||
|
||||
diff --git a/src/vpn/nm-vpn-manager.c b/src/vpn/nm-vpn-manager.c
|
||||
index d063916..d779166 100644
|
||||
--- a/src/vpn/nm-vpn-manager.c
|
||||
+++ b/src/vpn/nm-vpn-manager.c
|
||||
@@ -223,6 +223,7 @@ nm_vpn_manager_init (NMVpnManager *self)
|
||||
GSList *infos, *info;
|
||||
const char *conf_dir_etc = _nm_vpn_plugin_info_get_default_dir_etc ();
|
||||
const char *conf_dir_lib = _nm_vpn_plugin_info_get_default_dir_lib ();
|
||||
+ const char *conf_dir_user = _nm_vpn_plugin_info_get_default_dir_user ();
|
||||
|
||||
/* Watch the VPN directory for changes */
|
||||
file = g_file_new_for_path (conf_dir_lib);
|
||||
@@ -241,6 +242,14 @@ nm_vpn_manager_init (NMVpnManager *self)
|
||||
G_CALLBACK (vpn_dir_changed), self);
|
||||
}
|
||||
|
||||
+ file = g_file_new_for_path (conf_dir_user);
|
||||
+ priv->monitor_etc = g_file_monitor_directory (file, G_FILE_MONITOR_NONE, NULL, NULL);
|
||||
+ g_object_unref (file);
|
||||
+ if (priv->monitor_etc) {
|
||||
+ priv->monitor_id_etc = g_signal_connect (priv->monitor_etc, "changed",
|
||||
+ G_CALLBACK (vpn_dir_changed), self);
|
||||
+ }
|
||||
+
|
||||
/* first read conf_dir_lib. The name files are not really user configuration, but
|
||||
* plugin configuration. Hence we expect ~newer~ plugins to install their files
|
||||
* in /usr/lib/NetworkManager. We want to prefer those files.
|
||||
@@ -255,6 +264,11 @@ nm_vpn_manager_init (NMVpnManager *self)
|
||||
try_add_plugin (self, info->data);
|
||||
g_slist_free_full (infos, g_object_unref);
|
||||
|
||||
+ infos = _nm_vpn_plugin_info_list_load_dir (conf_dir_user, TRUE, 0, NULL, NULL);
|
||||
+ for (info = infos; info; info = info->next)
|
||||
+ try_add_plugin (self, info->data);
|
||||
+ g_slist_free_full (infos, g_object_unref);
|
||||
+
|
||||
priv->active_services = g_hash_table_new_full (nm_str_hash, g_str_equal, g_free, NULL);
|
||||
}
|
||||
|
||||
--
|
||||
2.22.0
|
||||
|
Loading…
Reference in New Issue