gnu: sed: Update to 4.3.
* gnu/packages/base.scm (sed): Update to 4.3. [source]: Use xz tarball. Remove upstreamed patch. [arguments]: Fix '/bin/sh' -> 'bash' substitution. [home-page]: Use https. [native-inputs]: Add perl. * gnu/packages/patches/sed-hurd-path-max.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
9410a5aa91
commit
7d7ea947f5
|
@ -835,7 +835,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/ruby-symlinkfix.patch \
|
||||
%D%/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch\
|
||||
%D%/packages/patches/ruby-yard-fix-skip-of-markdown-tests.patch \
|
||||
%D%/packages/patches/sed-hurd-path-max.patch \
|
||||
%D%/packages/patches/scheme48-tests.patch \
|
||||
%D%/packages/patches/scotch-test-threading.patch \
|
||||
%D%/packages/patches/sdl-libx11-1.6.patch \
|
||||
|
|
|
@ -117,15 +117,14 @@ including, for example, recursive directory searching.")
|
|||
(define-public sed
|
||||
(package
|
||||
(name "sed")
|
||||
(version "4.2.2")
|
||||
(version "4.3")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/sed/sed-" version
|
||||
".tar.bz2"))
|
||||
".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1myvrmh99jsvk7v3d7crm0gcrq51hmmm1r2kjyyci152in1x2j7h"))
|
||||
(patches (search-patches "sed-hurd-path-max.patch"))))
|
||||
"1anhdgah8h423hlmn9hwzxzr7hjbqjm6hxq3z1p7p7nf8640vhj7"))))
|
||||
(build-system gnu-build-system)
|
||||
(synopsis "Stream editor")
|
||||
(arguments
|
||||
|
@ -140,8 +139,10 @@ including, for example, recursive directory searching.")
|
|||
(substitute* '("testsuite/bsd.sh"
|
||||
"testsuite/bug-regex9.c")
|
||||
(("/bin/sh")
|
||||
(string-append bash "/bin/bash")))
|
||||
(string-append bash "/bin/sh")))
|
||||
#t)))))))
|
||||
(native-inputs
|
||||
`(("perl" ,perl))) ; for build-aux/help2man
|
||||
(description
|
||||
"Sed is a non-interactive, text stream editor. It receives a text
|
||||
input from a file or from standard input and it then applies a series of text
|
||||
|
@ -149,7 +150,7 @@ editing commands to the stream and prints its output to standard output. It
|
|||
is often used for substituting text patterns in a stream. The GNU
|
||||
implementation offers several extensions over the standard utility.")
|
||||
(license gpl3+)
|
||||
(home-page "http://www.gnu.org/software/sed/")))
|
||||
(home-page "https://www.gnu.org/software/sed/")))
|
||||
|
||||
(define-public tar
|
||||
(package
|
||||
|
|
|
@ -1,34 +0,0 @@
|
|||
7bb8d35d0330161a5af5341471d0c183a067e8c2
|
||||
Author: Jose E. Marchesi <jemarch@gnu.org>
|
||||
Date: Sun Oct 6 14:43:38 2013 +0200
|
||||
|
||||
Set PATH_MAX to some constant in case it is not defined in system
|
||||
headers.
|
||||
|
||||
2013-10-06 Jose E. Marchesi <jemarch@gnu.org>
|
||||
|
||||
* basicdefs.h (PATH_MAX): Defined to some constant in case it is
|
||||
not defined by system headers.
|
||||
* sed/utils.c: Do not include pathmax.h anymore.
|
||||
* bootstrap.conf (gnulib_modules): Do not use the gnulib module
|
||||
pathmax.
|
||||
|
||||
diff --git a/basicdefs.h b/basicdefs.h
|
||||
index 0d28a97..09f5beb 100644
|
||||
--- a/basicdefs.h
|
||||
+++ b/basicdefs.h
|
||||
@@ -40,6 +41,13 @@ typedef unsigned long countT;
|
||||
#define obstack_chunk_alloc ck_malloc
|
||||
#define obstack_chunk_free free
|
||||
|
||||
+/* MAX_PATH is not defined in some platforms, most notably GNU/Hurd.
|
||||
+ In that case we define it here to some constant. Note however that
|
||||
+ this relies in the fact that sed does reallocation if a buffer
|
||||
+ needs to be larger than PATH_MAX. */
|
||||
+#ifndef PATH_MAX
|
||||
+# define PATH_MAX 200
|
||||
+#endif
|
||||
|
||||
/* handle misdesigned <ctype.h> macros (snarfed from lib/regex.c) */
|
||||
/* Jim Meyering writes:
|
||||
|
Loading…
Reference in New Issue