gnu: libcmis: Update to 0.5.1.
* gnu/packages/libreoffice.scm (libcmis): Update to 0.5.1. [source]: Use new source URL. Remove obsolete patch 'libcmis-fix-test-onedrive.patch'. [home-page]: Update URL. * gnu/packages/patches/libcmis-fix-test-onedrive.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
a160778cba
commit
7fc72c7731
|
@ -675,7 +675,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/liba52-use-mtune-not-mcpu.patch \
|
%D%/packages/patches/liba52-use-mtune-not-mcpu.patch \
|
||||||
%D%/packages/patches/libbonobo-activation-test-race.patch \
|
%D%/packages/patches/libbonobo-activation-test-race.patch \
|
||||||
%D%/packages/patches/libcanberra-sound-theme-freedesktop.patch \
|
%D%/packages/patches/libcanberra-sound-theme-freedesktop.patch \
|
||||||
%D%/packages/patches/libcmis-fix-test-onedrive.patch \
|
|
||||||
%D%/packages/patches/libdrm-symbol-check.patch \
|
%D%/packages/patches/libdrm-symbol-check.patch \
|
||||||
%D%/packages/patches/libevent-dns-tests.patch \
|
%D%/packages/patches/libevent-dns-tests.patch \
|
||||||
%D%/packages/patches/libevent-2.0-CVE-2016-10195.patch \
|
%D%/packages/patches/libevent-2.0-CVE-2016-10195.patch \
|
||||||
|
|
|
@ -243,15 +243,15 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
|
||||||
(define-public libcmis
|
(define-public libcmis
|
||||||
(package
|
(package
|
||||||
(name "libcmis")
|
(name "libcmis")
|
||||||
(version "0.5.0")
|
(version "0.5.1")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://sourceforge/" name "/" name "-"
|
(uri (string-append "https://github.com/tdf/libcmis/releases/download/v"
|
||||||
version ".tar.gz"))
|
version "/libcmis-" version ".tar.gz"))
|
||||||
(sha256 (base32
|
(sha256
|
||||||
"1dprvk4fibylv24l7gr49gfqbkfgmxynvgssvdcycgpf7n8h4zm8"))
|
(base32
|
||||||
(patches (search-patches "libcmis-fix-test-onedrive.patch"))))
|
"03kvl8ywsv5qrxblf0m6955mmvl5q2zpb6vj51vs7ayvxhidzjva"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("cppunit" ,cppunit)
|
`(("cppunit" ,cppunit)
|
||||||
|
@ -276,7 +276,7 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
|
||||||
;; fails without the following flag.
|
;; fails without the following flag.
|
||||||
(string-append "--with-boost="
|
(string-append "--with-boost="
|
||||||
(assoc-ref %build-inputs "boost")))))
|
(assoc-ref %build-inputs "boost")))))
|
||||||
(home-page "https://sourceforge.net/projects/libcmis/")
|
(home-page "https://github.com/tdf/libcmis")
|
||||||
(synopsis "CMIS client library")
|
(synopsis "CMIS client library")
|
||||||
(description "LibCMIS is a C++ client library for the CMIS interface. It
|
(description "LibCMIS is a C++ client library for the CMIS interface. It
|
||||||
allows C++ applications to connect to any ECM behaving as a CMIS server such
|
allows C++ applications to connect to any ECM behaving as a CMIS server such
|
||||||
|
|
|
@ -1,35 +0,0 @@
|
||||||
Patch from resolution of http://sourceforge.net/p/libcmis/tickets/13/
|
|
||||||
|
|
||||||
From 814c7845d53688b35a747cf193c2ff99e40a8652 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jonathan Wakely <jwakely@redhat.com>
|
|
||||||
Date: Wed, 2 Sep 2015 16:35:45 +0100
|
|
||||||
Subject: [PATCH 5/5] Remove invalid comments from test JSON file.
|
|
||||||
|
|
||||||
---
|
|
||||||
qa/libcmis/data/onedrive/search-result.json | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/qa/libcmis/data/onedrive/search-result.json b/qa/libcmis/data/onedrive/search-result.json
|
|
||||||
index 61d250a..2482429 100644
|
|
||||||
--- a/qa/libcmis/data/onedrive/search-result.json
|
|
||||||
+++ b/qa/libcmis/data/onedrive/search-result.json
|
|
||||||
@@ -8,7 +8,7 @@
|
|
||||||
},
|
|
||||||
"name":"OneDriveFile",
|
|
||||||
"description":"",
|
|
||||||
- "parent_id":"folderA", // path: /A/Wrong File
|
|
||||||
+ "parent_id":"folderA",
|
|
||||||
"size":18047,
|
|
||||||
"upload_location":"https://apis.live.net/v5.0/wrongFileId/content/",
|
|
||||||
"comments_count":0,
|
|
||||||
@@ -32,7 +32,7 @@
|
|
||||||
},
|
|
||||||
"name":"OneDriveFile",
|
|
||||||
"description":"",
|
|
||||||
- "parent_id":"folderC", // path: /A/B/C/Right File
|
|
||||||
+ "parent_id":"folderC",
|
|
||||||
"size":4,
|
|
||||||
"upload_location":"https://apis.live.net/v5.0/rightFileId/content/",
|
|
||||||
"comments_count":0,
|
|
||||||
--
|
|
||||||
2.4.3
|
|
Loading…
Reference in New Issue