gnu: bigloo: Upgrade to 4.1a.
* gnu/packages/scheme.scm (bigloo): Upgrade to 4.1a.
This commit is contained in:
parent
75475ff728
commit
7fe492e8d9
|
@ -1,7 +1,7 @@
|
||||||
Patch shebangs in source that gets unpacked by `configure'.
|
Patch shebangs in source that gets unpacked by `configure'.
|
||||||
|
|
||||||
--- bigloo4.0b/gc/install-gc-7.3alpha3-20130330 2013-08-19 10:45:20.000000000 +0200
|
--- bigloo4.1a/gc/install-gc-7.4.0 2014-02-04 14:55:03.000000000 +0100
|
||||||
+++ bigloo4.0b/gc/install-gc-7.3alpha3-20130330 2013-08-19 10:46:36.000000000 +0200
|
+++ bigloo4.1a/gc/install-gc-7.4.0 2014-02-04 14:55:36.000000000 +0100
|
||||||
@@ -29,10 +29,12 @@ fi
|
@@ -29,10 +29,12 @@ fi
|
||||||
|
|
||||||
# untar the two versions of the GC
|
# untar the two versions of the GC
|
||||||
|
|
|
@ -1,5 +1,5 @@
|
||||||
;;; GNU Guix --- Functional package management for GNU
|
;;; GNU Guix --- Functional package management for GNU
|
||||||
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
|
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -116,14 +116,14 @@ features an integrated Emacs-like editor and a large runtime library.")
|
||||||
(define-public bigloo
|
(define-public bigloo
|
||||||
(package
|
(package
|
||||||
(name "bigloo")
|
(name "bigloo")
|
||||||
(version "4.0b")
|
(version "4.1a")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "ftp://ftp-sop.inria.fr/indes/fp/Bigloo/bigloo"
|
(uri (string-append "ftp://ftp-sop.inria.fr/indes/fp/Bigloo/bigloo"
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1fck2h48f0bvh8fl437cagmp0syfxy9lqacy1zwsis20fc76jvzi"))
|
"170q7nh08n4v20xl81fxb0xcdxphqqacfa643hsa8i2ar6pki04c"))
|
||||||
(patches (list (search-patch "bigloo-gc-shebangs.patch")))))
|
(patches (list (search-patch "bigloo-gc-shebangs.patch")))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
|
@ -163,6 +163,9 @@ features an integrated Emacs-like editor and a large runtime library.")
|
||||||
(zero?
|
(zero?
|
||||||
(system* "./configure"
|
(system* "./configure"
|
||||||
(string-append "--prefix=" out)
|
(string-append "--prefix=" out)
|
||||||
|
;; FIXME: Currently fails, see
|
||||||
|
;; <http://article.gmane.org/gmane.lisp.scheme.bigloo/6126>.
|
||||||
|
;; "--customgc=no" ; use our libgc
|
||||||
(string-append"--mv=" (which "mv"))
|
(string-append"--mv=" (which "mv"))
|
||||||
(string-append "--rm=" (which "rm"))))))
|
(string-append "--rm=" (which "rm"))))))
|
||||||
(alist-cons-after
|
(alist-cons-after
|
||||||
|
|
Loading…
Reference in New Issue