gnu: meson: Update to 0.50.0.
* gnu/packages/build-tools.scm (meson): Update to 0.50.0. * gnu/packages/patches/at-spi2-core-meson-compat.patch, gnu/packages/patches/totem-meson-compat.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gnome.scm (totem)[source](patches): Add totem-meson.compat.patch. * gnu/packages/gtk.scm (at-spi2-core)[source](patches): New field.
This commit is contained in:
parent
1e33331cce
commit
81382e3f6d
|
@ -652,6 +652,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/apr-skip-getservbyname-test.patch \
|
||||
%D%/packages/patches/aria2-CVE-2019-3500.patch \
|
||||
%D%/packages/patches/aspell-default-dict-dir.patch \
|
||||
%D%/packages/patches/at-spi2-core-meson-compat.patch \
|
||||
%D%/packages/patches/ath9k-htc-firmware-binutils.patch \
|
||||
%D%/packages/patches/ath9k-htc-firmware-gcc.patch \
|
||||
%D%/packages/patches/ath9k-htc-firmware-objcopy.patch \
|
||||
|
@ -1287,6 +1288,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/tk-find-library.patch \
|
||||
%D%/packages/patches/ttf2eot-cstddef.patch \
|
||||
%D%/packages/patches/ttfautohint-source-date-epoch.patch \
|
||||
%D%/packages/patches/totem-meson-compat.patch \
|
||||
%D%/packages/patches/totem-meson-easy-codec.patch \
|
||||
%D%/packages/patches/tuxpaint-stamps-path.patch \
|
||||
%D%/packages/patches/twinkle-include-qregexpvalidator.patch \
|
||||
|
|
|
@ -160,7 +160,7 @@ files and generates build instructions for the Ninja build system.")
|
|||
(define-public meson
|
||||
(package
|
||||
(name "meson")
|
||||
(version "0.49.2")
|
||||
(version "0.50.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://github.com/mesonbuild/meson/"
|
||||
|
@ -168,7 +168,7 @@ files and generates build instructions for the Ninja build system.")
|
|||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1z89f71r29laywx75bamjakybv9653wz0vd2l4xhvqy1dqr197zg"))))
|
||||
"07q2wz23wjfk8z66mli1cc9as0ycjp5f39fd4awny82qv8nw86ra"))))
|
||||
(build-system python-build-system)
|
||||
(arguments
|
||||
`(;; FIXME: Tests require many additional inputs, a fix for the RUNPATH
|
||||
|
|
|
@ -3766,7 +3766,8 @@ for application developers.")
|
|||
(sha256
|
||||
(base32
|
||||
"1llyisls3pzf5bwkpxyfyxc2d3gpa09n5pjy7qsjdqrp3ya4k36g"))
|
||||
(patches (search-patches "totem-meson-easy-codec.patch"))))
|
||||
(patches (search-patches "totem-meson-easy-codec.patch"
|
||||
"totem-meson-compat.patch"))))
|
||||
(build-system meson-build-system)
|
||||
(native-inputs
|
||||
`(("pkg-config" ,pkg-config)
|
||||
|
|
|
@ -561,6 +561,7 @@ in the GNOME project.")
|
|||
(uri (string-append "mirror://gnome/sources/" name "/"
|
||||
(version-major+minor version) "/"
|
||||
name "-" version ".tar.xz"))
|
||||
(patches (search-patches "at-spi2-core-meson-compat.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"083j1v7kdjrpjsv1b9dl3d8xqj39jyp4cfn8i9gbbm7q2g93b923"))))
|
||||
|
|
|
@ -0,0 +1,18 @@
|
|||
Fix build with Meson 0.50.0 and above.
|
||||
|
||||
Taken from upstream repository:
|
||||
https://gitlab.gnome.org/GNOME/at-spi2-core/commit/44a812ea51223d82f21a098a2d45fcc5c329ce7a
|
||||
|
||||
diff --git a/atspi/meson.build b/atspi/meson.build
|
||||
index b7a9357df1c4857dffa2ec123cd3073e67a07fea..2a6915d76202dabf923b50e6a8b85cbb83cb43d0 100644
|
||||
--- a/atspi/meson.build
|
||||
+++ b/atspi/meson.build
|
||||
@@ -57,7 +57,7 @@ atspi_headers = [
|
||||
|
||||
atspi_includedir = join_paths(get_option('prefix'), get_option('includedir'), 'at-spi-2.0', 'atspi')
|
||||
|
||||
-install_headers(atspi_headers, subdir: atspi_includedir)
|
||||
+install_headers(atspi_headers, install_dir: atspi_includedir)
|
||||
|
||||
atspi_enums = gnome.mkenums('atspi-enum-types',
|
||||
sources: [ 'atspi-constants.h', 'atspi-types.h' ],
|
|
@ -0,0 +1,14 @@
|
|||
Fix an error that occurs with Meson 0.50.0 and later:
|
||||
"ERROR: Subdir keyword must not be an absolute path".
|
||||
|
||||
--- a/src/meson.build 2019-03-15 00:10:26.882293850 +0100
|
||||
+++ b/src/meson.build 2019-03-15 00:10:54.312197229 +0100
|
||||
@@ -82,7 +82,7 @@
|
||||
|
||||
install_headers(
|
||||
headers,
|
||||
- subdir: join_paths(totem_includedir, totem_api_path)
|
||||
+ install_dir: join_paths(totem_includedir, totem_api_path)
|
||||
)
|
||||
|
||||
libtotem_player_sources = files(
|
Loading…
Reference in New Issue