gnu: libepoxy: Update to 1.4.0.

* gnu/packages/patches/libepoxy-gl-null-checks.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/gl.scm (libepoxy): Update to 1.4.0.
[source]: Remove patch. Use release tarball and remove explicit file-name.
[arguments]: Drop 'autoreconf' phase. Remove obsolete test substitution.
[native-inputs]: Remove AUTOCONF, AUTOMAKE and LIBTOOL.
This commit is contained in:
Marius Bakke 2017-02-22 06:29:21 +01:00
parent a6d352cc01
commit 827dc6295c
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 6 additions and 79 deletions

View File

@ -673,7 +673,6 @@ dist_patch_DATA = \
%D%/packages/patches/libcanberra-sound-theme-freedesktop.patch \
%D%/packages/patches/libcmis-fix-test-onedrive.patch \
%D%/packages/patches/libdrm-symbol-check.patch \
%D%/packages/patches/libepoxy-gl-null-checks.patch \
%D%/packages/patches/libevent-dns-tests.patch \
%D%/packages/patches/libevent-2.0-CVE-2016-10195.patch \
%D%/packages/patches/libevent-2.0-CVE-2016-10196.patch \

View File

@ -456,25 +456,20 @@ OpenGL graphics API.")
(define-public libepoxy
(package
(name "libepoxy")
(version "1.3.1")
(version "1.4.0")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/anholt/libepoxy/archive/v"
"https://github.com/anholt/libepoxy/releases/download/v"
(version-major+minor version) "/libepoxy-"
version
".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
".tar.xz"))
(sha256
(base32
"1d1brhwfmlzgnphmdwlvn5wbcrxsdyzf1qfcf8nb89xqzznxs037"))
(patches (search-patches "libepoxy-gl-null-checks.patch"))))
"0hdbaapbxjjfdqsdvag460kfjvs800da5sngi2sc46wj9aqhda95"))))
(arguments
`(#:phases
(modify-phases %standard-phases
(add-after
'unpack 'autoreconf
(lambda _
(zero? (system* "autoreconf" "-vif"))))
(add-before
'configure 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
@ -485,23 +480,10 @@ OpenGL graphics API.")
(substitute* (find-files "." "\\.[ch]$")
(("libGL.so.1") (string-append mesa "/lib/libGL.so.1"))
(("libEGL.so.1") (string-append mesa "/lib/libEGL.so.1")))
;; XXX On armhf systems, we must add "GLIBC_2.4" to the list of
;; versions in test/dlwrap.c:dlwrap_real_dlsym. It would be
;; better to make this a normal patch, but for now we do it here
;; to prevent rebuilding on other platforms.
,@(if (string-prefix? "arm" (or (%current-target-system)
(%current-system)))
'((substitute* '"test/dlwrap.c"
(("\"GLIBC_2\\.0\"") "\"GLIBC_2.0\", \"GLIBC_2.4\"")))
'())
#t))))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
("pkg-config" ,pkg-config)
`(("pkg-config" ,pkg-config)
("python" ,python)))
(inputs
`(("mesa" ,mesa)))

View File

@ -1,54 +0,0 @@
This patch from <https://bugzilla.redhat.com/show_bug.cgi?id=1395366> adds NULL
checks to avoid crashes when GL support is missing, as is the case when running
Xvfb.
Upstream issue: <https://github.com/anholt/libepoxy/issues/72>.
diff -ur libepoxy-1.3.1/src/dispatch_common.c libepoxy-1.3.1/src/dispatch_common.c
--- libepoxy-1.3.1/src/dispatch_common.c 2015-07-15 19:46:36.000000000 -0400
+++ libepoxy-1.3.1/src/dispatch_common.c 2016-11-16 09:03:52.809066247 -0500
@@ -348,6 +348,8 @@
epoxy_extension_in_string(const char *extension_list, const char *ext)
{
const char *ptr = extension_list;
+ if (! ptr) return false;
+ if (! ext) return false;
int len = strlen(ext);
/* Make sure that don't just find an extension with our name as a prefix. */
@@ -380,6 +382,7 @@
for (i = 0; i < num_extensions; i++) {
const char *gl_ext = (const char *)glGetStringi(GL_EXTENSIONS, i);
+ if (! gl_ext) return false;
if (strcmp(ext, gl_ext) == 0)
return true;
}
diff -ur libepoxy-1.3.1/src/dispatch_egl.c libepoxy-1.3.1/src/dispatch_egl.c
--- libepoxy-1.3.1/src/dispatch_egl.c 2015-07-15 19:46:36.000000000 -0400
+++ libepoxy-1.3.1/src/dispatch_egl.c 2016-11-16 08:40:34.069358709 -0500
@@ -46,6 +46,7 @@
int ret;
version_string = eglQueryString(dpy, EGL_VERSION);
+ if (! version_string) return 0;
ret = sscanf(version_string, "%d.%d", &major, &minor);
assert(ret == 2);
return major * 10 + minor;
diff -ur libepoxy-1.3.1/src/dispatch_glx.c libepoxy-1.3.1/src/dispatch_glx.c
--- libepoxy-1.3.1/src/dispatch_glx.c 2015-07-15 19:46:36.000000000 -0400
+++ libepoxy-1.3.1/src/dispatch_glx.c 2016-11-16 08:41:03.065730370 -0500
@@ -57,11 +57,13 @@
int ret;
version_string = glXQueryServerString(dpy, screen, GLX_VERSION);
+ if (! version_string) return 0;
ret = sscanf(version_string, "%d.%d", &server_major, &server_minor);
assert(ret == 2);
server = server_major * 10 + server_minor;
version_string = glXGetClientString(dpy, GLX_VERSION);
+ if (! version_string) return 0;
ret = sscanf(version_string, "%d.%d", &client_major, &client_minor);
assert(ret == 2);
client = client_major * 10 + client_minor;